[PATCH] Add llvm-9, clang-9 and clang-toolchain-9

  • Done
  • quality assurance status badge
Details
2 participants
  • David Truby
  • Mathieu Othacehe
Owner
unassigned
Submitted by
David Truby
Severity
normal

Debbugs page

David Truby wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
20191120120222.31844-1-david.truby@arm.com
* gnu/packages/llvm.scm (llvm-9): New variable.
(clang-9): New variable.
(clang-toolchain-9): New variable.
---
gnu/packages/llvm.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 863d43d7d6..082e6e96ca 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -458,6 +458,31 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(define-public clang-toolchain
(make-clang-toolchain clang))
+(define-public llvm-9
+ (package
+ (inherit llvm)
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "117ymdz1by2nkfq1c2p9m4050dp848kbjbiv6nsfj8hzy9f5d86n"))))
+ (license license:asl2.0)))
+
+(define-public clang-runtime-9
+ (clang-runtime-from-llvm
+ llvm-9
+ "03ni43lbkp63lr3p6sc94dphqmvnz5av5mml0xmk930xvnbcvr2n"))
+
+(define-public clang-9
+ (clang-from-llvm llvm-9 clang-runtime-9
+ "0426ma80i41qsgzm1qdz81mjskck426diygxi2k5vji2gkpixa3v"))
+
+(define-public clang-toolchain-9
+ (make-clang-toolchain clang-9))
+
(define-public llvm-7
(package
(inherit llvm)
--
2.24.0
Mathieu Othacehe wrote 5 years ago
control message for bug #38297
(address . control@debbugs.gnu.org)
87v9re5o5i.fsf@gmail.com
close 38297
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38297@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38297
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help