David Wilson wrote 5 years ago
(address . guix-patches@gnu.org)
Hi Guix!
This patch adds the "openwith" package for Emacs to make it easier to launch external applications for configured file types. I've tested the package and run it through "guix lint", all looks good.
Thanks!
David
From cdd934a91f03450b1eb8fd89aca8272d94438620 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Tue, 19 Nov 2019 06:24:31 -0800
Subject: [PATCH] gnu: Add emacs-openwith.
* gnu/packages/emacs-xyz.scm (emacs-openwith) New variable.
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)
Toggle diff (34 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ea4ab0e6f9..4fab900c7a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10248,6 +10248,27 @@ list of commands is displayed in a handy popup.")
characters from end of lines.")
(license license:gpl3+)))
+(define-public emacs-openwith
+ (let ((commit "1dc89670822966fab6e656f6519fdd7f01e8301a")
+ (revision "0"))
+ (package
+ (name "emacs-openwith")
+ (home-page "https://github.com/emacsmirror/openwith")
+ (version (git-version "0.0.1" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1wl6gnxsyhaad4cl9bxjc0qbc5jzvlwbwjbajs0n1s6qr07d6r01"))))
+ (build-system emacs-build-system)
+ (synopsis "Emacs")
+ (description
+ "This package enables external applications to be launched for
+configured file types when you use commands like @code{find-file}, etc.")
+ (license license:gpl2+))))
+
(define-public emacs-org-edit-latex
(package
(name "emacs-org-edit-latex")
--
2.24.0