[PATCH] Add llvm-9, clang-9 and clang-toolchain-9

  • Done
  • quality assurance status badge
Details
2 participants
  • David Truby
  • Mathieu Othacehe
Owner
unassigned
Submitted by
David Truby
Severity
normal

Debbugs page

David Truby wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
20191119134620.17085-1-david.truby@arm.com
---
gnu/packages/llvm.scm | 26 +++++++++++++++++++++++++-
1 file changed, 25 insertions(+), 1 deletion(-)
Toggle diff (46 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index a5170a4f10..c1bb1937a5 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2019 David Truby <David.Truby@arm.com>
+;;; Copyright © 2019 Arm Ltd. <David.Truby@arm.com>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
;;;
;;; This file is part of GNU Guix.
@@ -458,6 +458,30 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(define-public clang-toolchain
(make-clang-toolchain clang))
+(define-public llvm-9
+ (package
+ (inherit llvm)
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "117ymdz1by2nkfq1c2p9m4050dp848kbjbiv6nsfj8hzy9f5d86n"))))))
+
+(define-public clang-runtime-9
+ (clang-runtime-from-llvm
+ llvm-9
+ "03ni43lbkp63lr3p6sc94dphqmvnz5av5mml0xmk930xvnbcvr2n"))
+
+(define-public clang-9
+ (clang-from-llvm llvm-9 clang-runtime-9
+ "0426ma80i41qsgzm1qdz81mjskck426diygxi2k5vji2gkpixa3v"))
+
+(define-public clang-toolchain-9
+ (make-clang-toolchain clang-9))
+
(define-public llvm-7
(package
(inherit llvm)
--
2.24.0
David Truby wrote 5 years ago
4fcabb4f52579d48cba9b477f4fb722b06b4a62c.camel@arm.com
Hi Mathieu,
Sorry, I'll read up on the correct format for commit messages and then
send again :).
I also just realised the license has changed for LLVM-9 so I need to
change that in the package too!
David
On Tue, 2019-11-19 at 16:58 +0100, Mathieu Othacehe wrote:
Toggle quote (12 lines)
> Hello David,
>
> This patch LGTM. However, you need to write a commit log compliant
> with
> ChangeLog format. See:
> https://guix.gnu.org/manual/en/html_node/Submitting-Patches.html.
>
> Can you please send a v2 :) ?
>
> Thanks,
>
> Mathieu
David Truby wrote 5 years ago
[PATCH] Add llvm-9, clang-9 and clang-toolchain-9
(name . 38268@debbugs.gnu.org)(address . 38268@debbugs.gnu.org)
20191119171510.43045-1-david.truby@arm.com
* gnu/packages/llvm.scm (llvm-9): New variable.
(clang-9): New variable.
(clang-toolchain-9): New variable.
---
gnu/packages/llvm.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 863d43d7d6..082e6e96ca 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -458,6 +458,31 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(define-public clang-toolchain
(make-clang-toolchain clang))
+(define-public llvm-9
+ (package
+ (inherit llvm)
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "117ymdz1by2nkfq1c2p9m4050dp848kbjbiv6nsfj8hzy9f5d86n"))))
+ (license license:asl2.0)))
+
+(define-public clang-runtime-9
+ (clang-runtime-from-llvm
+ llvm-9
+ "03ni43lbkp63lr3p6sc94dphqmvnz5av5mml0xmk930xvnbcvr2n"))
+
+(define-public clang-9
+ (clang-from-llvm llvm-9 clang-runtime-9
+ "0426ma80i41qsgzm1qdz81mjskck426diygxi2k5vji2gkpixa3v"))
+
+(define-public clang-toolchain-9
+ (make-clang-toolchain clang-9))
+
(define-public llvm-7
(package
(inherit llvm)
--
2.24.0
David Truby wrote 5 years ago
(name . guix-patches@gnu.org)(address . guix-patches@gnu.org)
20191120120222.31844-1-david.truby@arm.com
* gnu/packages/llvm.scm (llvm-9): New variable.
(clang-9): New variable.
(clang-toolchain-9): New variable.
---
gnu/packages/llvm.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/llvm.scm b/gnu/packages/llvm.scm
index 863d43d7d6..082e6e96ca 100644
--- a/gnu/packages/llvm.scm
+++ b/gnu/packages/llvm.scm
@@ -458,6 +458,31 @@ with that of libgomp, the GNU Offloading and Multi Processing Library.")
(define-public clang-toolchain
(make-clang-toolchain clang))
+(define-public llvm-9
+ (package
+ (inherit llvm)
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://llvm.org/releases/"
+ version "/llvm-" version ".src.tar.xz"))
+ (sha256
+ (base32
+ "117ymdz1by2nkfq1c2p9m4050dp848kbjbiv6nsfj8hzy9f5d86n"))))
+ (license license:asl2.0)))
+
+(define-public clang-runtime-9
+ (clang-runtime-from-llvm
+ llvm-9
+ "03ni43lbkp63lr3p6sc94dphqmvnz5av5mml0xmk930xvnbcvr2n"))
+
+(define-public clang-9
+ (clang-from-llvm llvm-9 clang-runtime-9
+ "0426ma80i41qsgzm1qdz81mjskck426diygxi2k5vji2gkpixa3v"))
+
+(define-public clang-toolchain-9
+ (make-clang-toolchain clang-9))
+
(define-public llvm-7
(package
(inherit llvm)
--
2.24.0
Mathieu Othacehe wrote 5 years ago
(address . guix-patches@gnu.org)
87o8x6wmu8.fsf@gmail.com
Hey David,

Pushed with a slightly edited commit title.

Thanks,

Mathieu
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38268@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38268
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help