[PATCH] gnu: Add r-harmony.

  • Done
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Mădălin Ionel Patrașcu
  • zimoun
Owner
unassigned
Submitted by
Mădălin Ionel Patrașcu
Severity
normal

Debbugs page

Mădălin Ionel Patrașcu wrote 5 years ago
(address . guix-patches@gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
20191118172216.21813-1-madalinionel.patrascu@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-harmony): New variable.
---
gnu/packages/bioinformatics.scm | 38 ++++++++++++++++++++++++++++++++-
1 file changed, 37 insertions(+), 1 deletion(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 07c70fb82c..5da95d66a6 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
-;;; Copyright © 2018 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
+;;; Copyright © 2018, 2019 Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
;;;
@@ -15349,3 +15349,39 @@ methylation metrics from them. MethylDackel requires an indexed fasta file
containing the reference genome as well.")
;; See https://github.com/dpryan79/MethylDackel/issues/85
(license license:expat)))
+
+(define-public r-harmony
+ (let ((commit "1a6d77aae524a08a2ca91737a152ab2047ccee78")
+ (revision "1"))
+ (package
+ (name "r-harmony")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/immunogenomics/harmony.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1905qsbl5iv3kxki73gmyzshyb8zc6asdaymywndscn7mjkwm7aw"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-cowplot" ,r-cowplot)
+ ("r-dplyr" ,r-dplyr)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-irlba" ,r-irlba)
+ ("r-matrix" ,r-matrix)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-rcppprogress" ,r-rcppprogress)
+ ("r-rlang" ,r-rlang)
+ ("r-tibble" ,r-tibble)
+ ("r-tidyr" ,r-tidyr)))
+ (home-page "https://github.com/immunogenomics/harmony.git")
+ (synopsis "Fast, sensitive, and accurate integration of single cell data")
+ (description
+ "Harmony software is the R implementation of the algorithm with the same
+name for single cell integration, described in Korsunsky et al 2018. Package
+includes a standalone Harmony function and interfaces to external frameworks.")
+ (license license:gpl3))))
--
2.17.1
Ludovic Courtès wrote 5 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38259-done@debbugs.gnu.org)
87ftihil6v.fsf@gnu.org
Hello Mădălin,

Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (r-harmony): New variable.

Applied with the changes below.

Thank you!

Ludo’.
Toggle diff (13 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 5da95d66a6..d1d17dc3d5 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15382,6 +15382,6 @@ containing the reference genome as well.")
(synopsis "Fast, sensitive, and accurate integration of single cell data")
(description
"Harmony software is the R implementation of the algorithm with the same
-name for single cell integration, described in Korsunsky et al 2018. Package
+name for single cell integration, described in Korsunsky et al 2018. The package
includes a standalone Harmony function and interfaces to external frameworks.")
- (license license:gpl3))))
+ (license license:gpl3+))))
Closed
Ludovic Courtès wrote 5 years ago
(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)(address . 38259@debbugs.gnu.org)
87blt5ik08.fsf@gnu.org
Mădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de> skribis:

Toggle quote (2 lines)
> * gnu/packages/bioinformatics.scm (r-harmony): New variable.

It took me a while but I then realized the package was already in, only
in a different file, cran.scm.

So I’ve not pushed your version, but let us know if you’d like to change
the existing package!

Thanks,
Ludo’.
zimoun wrote 5 years ago
Re: [bug#38259] [PATCH] gnu: Add r-harmony.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 38259@debbugs.gnu.org)(name . Mădălin Ionel Patrașcu)(address . madalinionel.patrascu@mdc-berlin.de)
CAJ3okZ2NqEkcyPVWUsJ24ktXc0uZt4b=fzBoriWYSZZhDRtkDg@mail.gmail.com
Hi,

On Thu, 21 Nov 2019 at 11:48, Ludovic Courtès <ludo@gnu.org> wrote:

Toggle quote (3 lines)
> It took me a while but I then realized the package was already in, only
> in a different file, cran.scm.

IMHO, some packages need to be moved in the right files.
For example this one. It is not a CRAN package because it does not
come from the CRAN archive but a Bioinformatics one written in R
language.


In the same topic, I moved [1] packages fetched from the CRAN archive
to the cran.scm file.



To me, keeping a clear file organisation helps. :-)


All the best,
simon
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38259@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38259
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help