[PATCH] Add emacs-spacegray-theme.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Wilson
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Wilson
Severity
normal

Debbugs page

David Wilson wrote 5 years ago
(address . guix-patches@gnu.org)
9b9d9c82-1a77-408b-8fcc-265a4da38223@www.fastmail.com
Hi Guix!

This patch adds the Spacegray theme for Emacs. I've tested it in a profile locally and it loads up just fine. `guix lint' output is also clean.

Thanks!

David
Attachment: file
From 56974fb35273e3a65eaf864842da2be1a1edeaa0 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Mon, 11 Nov 2019 06:54:59 -0800
Subject: [PATCH] gnu: Add emacs-spacegray-theme.

* gnu/packages/emacs-xyz.scm (emacs-spacegray-theme) New variable.
---
gnu/packages/emacs-xyz.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (37 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52a22ccca5..0ff92f0780 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4881,6 +4881,30 @@ is to keep colors easily distinguishable, contrast enough and still pleasant
for the eyes.")
(license license:expat))) ; MIT license
+(define-public emacs-spacegray-theme
+ (let ((commit "9826265c2bceb2ebc1c5e16a45021da0253ace97")
+ (revision "0"))
+ (package
+ (name "emacs-spacegray-theme")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bruce/emacs-spacegray-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aplwmm17ypbns5blc4rf5rr6dasj0zp5ibykpfl43fh4bd8z89n"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bruce/emacs-spacegray-theme")
+ (synopsis "Port of Sublime Text's Spacegray theme for Emacs")
+ (description
+ "@code{spacegray-theme} is an Emacs port of the Spacegray theme from
+Sublime Text. It features a dark blue/gray background and soft blue, green,
+orange and red as accent colors.")
+ (license license:expat)))) ; MIT license
+
(define-public emacs-2048-game
(package
(name "emacs-2048-game")
--
2.24.0
David Wilson wrote 5 years ago
(address . guix-patches@gnu.org)
5bf42018-6e74-40c0-9fe7-9769a9d7807e@www.fastmail.com
Forgot to add myself to the copyright header! Here's an updated patch.

Thanks!

David
From 586a88ab702cab13990df2cf04413d0650cc5003 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Mon, 11 Nov 2019 06:54:59 -0800
Subject: [PATCH] gnu: Add emacs-spacegray-theme.

* gnu/packages/emacs-xyz.scm (emacs-spacegray-theme) New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 52a22ccca5..5775870053 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4881,6 +4882,30 @@ is to keep colors easily distinguishable, contrast enough and still pleasant
for the eyes.")
(license license:expat))) ; MIT license
+(define-public emacs-spacegray-theme
+ (let ((commit "9826265c2bceb2ebc1c5e16a45021da0253ace97")
+ (revision "0"))
+ (package
+ (name "emacs-spacegray-theme")
+ (version (git-version "0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bruce/emacs-spacegray-theme.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0aplwmm17ypbns5blc4rf5rr6dasj0zp5ibykpfl43fh4bd8z89n"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/bruce/emacs-spacegray-theme")
+ (synopsis "Port of Sublime Text's Spacegray theme for Emacs")
+ (description
+ "@code{spacegray-theme} is an Emacs port of the Spacegray theme from
+Sublime Text. It features a dark blue/gray background and soft blue, green,
+orange and red as accent colors.")
+ (license license:expat)))) ; MIT license
+
(define-public emacs-2048-game
(package
(name "emacs-2048-game")
--
2.24.0
Ludovic Courtès wrote 5 years ago
Re: [bug#38177] [PATCH] Add emacs-spacegray-theme.
(name . David Wilson)(address . david@daviwil.com)(address . 38177-done@debbugs.gnu.org)
8736ermnae.fsf@gnu.org
Hello David,

"David Wilson" <david@daviwil.com> skribis:

Toggle quote (7 lines)
> From 586a88ab702cab13990df2cf04413d0650cc5003 Mon Sep 17 00:00:00 2001
> From: David Wilson <david@daviwil.com>
> Date: Mon, 11 Nov 2019 06:54:59 -0800
> Subject: [PATCH] gnu: Add emacs-spacegray-theme.
>
> * gnu/packages/emacs-xyz.scm (emacs-spacegray-theme) New variable.

Applied, thanks!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38177@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38177
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help