[PATCH] gnu: Add carla.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
2b9e5d7b6cba2d46fa7c7dd41c9030d4@posteo.net
From 77de9785c18683c68dc22f640afb614ef4e88a6c Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 23:56:58 +0000
Subject: [PATCH] gnu: Add carla.

* gnu/packages/audio.scm (carla): New variable.
---
gnu/packages/audio.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (82 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 28dbf06f3b..20c093e610 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3773,3 +3774,59 @@ other Gnaural instances, allowing synchronous
sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the
audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public carla
+ (package
+ (name "carla")
+ (version "2.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/falkTX/Carla/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0hbcxwi6ln9vrv61vv11f7dn0z8q3wimjqvzh2z9mklcgx0xij6h"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable-and-show-features
+ (lambda _
+ (setenv "CC" "gcc")
+ (invoke "make" "features")))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ffmpeg" ,ffmpeg)
+ ("fluidsynth" ,fluidsynth)
+ ("file" ,file)
+ ("liblo" ,liblo)
+ ("libsndfile" ,libsndfile)
+ ("gtk+" ,gtk+)
+ ("python-pyliblo" ,python-pyliblo)
+ ("python-pyqt" ,python-pyqt)
+ ("python-rdflib" ,python-rdflib)
+ ;; python-pyqt shows the following error without python-wrapper:
+ ;; Error while finding module specification for
'PyQt5.uic.pyuic'
+ ;; (ModuleNotFoundError: No module named 'PyQt5')
+ ("python-wrapper" ,python-wrapper)
+ ("libx11" ,libx11)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://kxstudio.linuxaudio.org/Applications:Carla")
+ (synopsis "Audio plugin host")
+ (description " Carla is a fully-featured modular audio plugin host,
with
+support for many audio drivers and plugin formats. It has features like
+transport control, automation of parameters via MIDI CC and remote
control
+over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2,
VST2,
+and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as
the
+default and preferred audio driver but also supports native drivers
like ALSA.")
+ (license license:gpl2+)))
--
2.24.0
Alexandros Theodotou wrote 5 years ago
(address . 38141@debbugs.gnu.org)
b7791944ef03e21799ec9b1efeec143c734ec8de.camel@zrythm.org
Updated patch. Note that I can't get it to build the same derivation
twice:
```
output ‘/gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-2.0.0’ of
‘/gnu/store/nlyk7zhcnq0fl57z95qyf78gf4qsbl2r-carla-2.0.0.drv’ differs
from ‘/gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-2.0.0-check’
from previous round
```
From 5dcd5d3f035e6865c68295dcbcdb4d03c5e6c049 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 23:56:58 +0000
Subject: [PATCH] gnu: Add carla.

* gnu/packages/audio.scm (carla): New variable.
---
gnu/packages/audio.scm | 57 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 57 insertions(+)

Toggle diff (74 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bc79225115..3ce3929165 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3766,3 +3767,59 @@ other Gnaural instances, allowing synchronous sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public carla
+ (package
+ (name "carla")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/falkTX/Carla.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable-and-show-features
+ (lambda _
+ (setenv "CC" "gcc")
+ (invoke "make" "features")))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ffmpeg" ,ffmpeg)
+ ("fluidsynth" ,fluidsynth)
+ ("file" ,file)
+ ("liblo" ,liblo)
+ ("libsndfile" ,libsndfile)
+ ("gtk+" ,gtk+)
+ ("python-pyliblo" ,python-pyliblo)
+ ("python-pyqt" ,python-pyqt)
+ ("python-rdflib" ,python-rdflib)
+ ;; python-pyqt shows the following error without python-wrapper:
+ ;; Error while finding module specification for 'PyQt5.uic.pyuic'
+ ;; (ModuleNotFoundError: No module named 'PyQt5')
+ ("python-wrapper" ,python-wrapper)
+ ("libx11" ,libx11)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://kx.studio/Applications:Carla")
+ (synopsis "Audio plugin host")
+ (description "Carla is a modular audio plugin host, with features like
+transport control, automation of parameters via MIDI CC and remote control
+over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
+and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
+default and preferred audio driver but also supports native drivers like ALSA.")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I7DcACgkQAi6uQjE9
cPNeeAgAi75wRiWCw0jmRpAyIJ70SArRIbQ3spi8xfjPxzYh6Zk6UtY5ktBCAQ1N
Dt0yc07Vgxq8+t7U8zEEnBATe32XQGg3P5MP36SE5R4EVf1PL0KLBe2yKj1u4SAJ
TwGMKOZnC0Y1po7xxnFURWA6l25P5Y2SubJZR24hkP0BKiW0Xojd/8w45T4rhqNA
AetuD5ELiHdosxkTMo1bfmZxZcBxSpmIXKrdTGMLys1Lj1pfkMA4cgUbomHibCEM
3UnrFwj4Bipnu89FjQS3EJI8y4eTM5rTq7rT2ZFoOAQOafEmI232qfbtgQjVxTm2
dIm+RAbA0cfeFryGSyKrgJDiraDHNg==
=zCW4
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
87r229f0wd.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (9 lines)
> Updated patch. Note that I can't get it to build the same derivation
> twice:
> ```
> output ‘/gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-2.0.0’ of
> ‘/gnu/store/nlyk7zhcnq0fl57z95qyf78gf4qsbl2r-carla-2.0.0.drv’ differs
> from ‘/gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-2.0.0-check’
> from previous round
> ```

Can you build with '--keep-failed', and then run:

diffoscope /gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-2.0.0{,-check}

and send the output?

The updated patch LGTM, but does not apply any more. Can you rebase it
on top of current 'master'?

TIA!
Marius
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3O7rIACgkQoqBt8qM6
VPrgYwgAgTvsho4ugB9SfpKj5+IRb4RtP0y3SI+nDSNGy9EViUY8YTEG07syQKUD
e0vk6qvHV8PWo0Tdtz8aVs1+IvnGyvnmpbfM4C6sU4o1/49GUZVPVRAPMfLNI4Nh
jdmFLmfcQOItftBsMYmmKrKSnInMDxCZGnxf5NE8Bxh6B0kGDA6o0e/u4JH7x0uz
6iVjACbPwTzqxIExrkH/GbSBgRClKRHplfS+thtPYAQtfoupg5J4T+405O/mprA/
QKcZCE2pHyUzjsdK2JZwT2kTgYylo5fS8eIN8IstCo7yRFv16UEi3ZMMjQko/xoQ
TuESscJyXIK/meXAFi20nEtfE4pgFw==
=GAZq
-----END PGP SIGNATURE-----

Alexandros Theodotou wrote 5 years ago
5d54f57ec6e1b265d8c3bf9f1790f8aad5bc32f6.camel@zrythm.org
Hi Marius,

Toggle quote (11 lines)
> Can you build with '--keep-failed', and then run:
>
> diffoscope /gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-
> 2.0.0{,-check}
>
> and send the output?
>
> The updated patch LGTM, but does not apply any more. Can you rebase
> it
> on top of current 'master'?

Attaching the diffoscope output and updated patch. The output from
diffoscope was 8.5MB so I compressed it. Note that the hash has
changed.
From 879230335a8ef5b40d09f493f380ab310c6976b3 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 23:56:58 +0000
Subject: [PATCH] gnu: Add carla.

* gnu/packages/audio.scm (carla): New variable.
---
gnu/packages/audio.scm | 56 ++++++++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)

Toggle diff (66 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index d59b4eb87e..453fa7581f 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3811,3 +3811,59 @@ therefore satisfying any requirements they may have to be self contained,
as is the case with audio plugins.")
(home-page "https://gitlab.com/geontime/redkite")
(license license:gpl3+)))
+
+(define-public carla
+ (package
+ (name "carla")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/falkTX/Carla.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fqgncqlr86n38yy7pa118mswfacmfczj7w9xx6c6k0jav3wk29k"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no "check" target
+ #:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'set-CC-variable-and-show-features
+ (lambda _
+ (setenv "CC" "gcc")
+ (invoke "make" "features")))
+ (delete 'configure))))
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("ffmpeg" ,ffmpeg)
+ ("fluidsynth" ,fluidsynth)
+ ("file" ,file)
+ ("liblo" ,liblo)
+ ("libsndfile" ,libsndfile)
+ ("gtk+" ,gtk+)
+ ("python-pyliblo" ,python-pyliblo)
+ ("python-pyqt" ,python-pyqt)
+ ("python-rdflib" ,python-rdflib)
+ ;; python-pyqt shows the following error without python-wrapper:
+ ;; Error while finding module specification for 'PyQt5.uic.pyuic'
+ ;; (ModuleNotFoundError: No module named 'PyQt5')
+ ("python-wrapper" ,python-wrapper)
+ ("libx11" ,libx11)
+ ("qtbase" ,qtbase)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "https://kx.studio/Applications:Carla")
+ (synopsis "Audio plugin host")
+ (description "Carla is a modular audio plugin host, with features like
+transport control, automation of parameters via MIDI CC and remote control
+over OSC. Carla currently supports LADSPA (including LRDF), DSSI, LV2, VST2,
+and VST3 plugin formats, plus SF2 and SFZ file support. It uses JACK as the
+default and preferred audio driver but also supports native drivers like ALSA.")
+ (license license:gpl2+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3Qa7IACgkQAi6uQjE9
cPNnEAf/bAgO2BbeSHwoN+MGSyhE7/K+GSI4n7Fizu4xrwwfkBrGPsozPDX2+UrY
d3rjy/miZCa43DZJ2tGl16jvlR6pNNyGmZrGDvLg0NLTOhU8LCJNjBVZiz3/GPFn
/4Daf2afG3YOtcsZNwmczaFDe9fSxrkRbaXrWgvVPwlXYoYmulSPpwC9HJoH9dfY
GC4L+/Yr6m/QZOyVzcE9c3VErc0n5EL2Ptby6JxVeiLhH0ynXKDN5tke2eFtgxJH
sUJMyk39TD6bupG1ugGQYyjxG9M0RG1r95HX/RJS2cirahGwd9Gp0DnONzpeahqG
U9ssZk/mLEJB0DF5TjvdAZeMlL6Zrw==
=WxOG
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
87ftij8nhq.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (17 lines)
> Hi Marius,
>
>> Can you build with '--keep-failed', and then run:
>>
>> diffoscope /gnu/store/k22jfy6asbwsxbmmajgghcnnrz6dgaqi-carla-
>> 2.0.0{,-check}
>>
>> and send the output?
>>
>> The updated patch LGTM, but does not apply any more. Can you rebase
>> it
>> on top of current 'master'?
>
> Attaching the diffoscope output and updated patch. The output from
> diffoscope was 8.5MB so I compressed it. Note that the hash has
> changed.

Thanks. So it looks like resources_rc.py is not reproducible. It is
not really possible to tell why from the diffoscope output though.

It is generated by PyQt, so I opened a separate bug report about it:


[...]

Toggle quote (7 lines)
> From 879230335a8ef5b40d09f493f380ab310c6976b3 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 23:56:58 +0000
> Subject: [PATCH] gnu: Add carla.
>
> * gnu/packages/audio.scm (carla): New variable.

Applied (with indentation change), thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3UeBEACgkQoqBt8qM6
VPpP7wf9F74OrR7CfEwl1CZpkGCZzi5hIBpDM+cTHxWnLd9mPV5Q5kWXQbF/iq1E
e+NWSrrDU9ac59zHmBWI+hnpBN4J9qO2DaTzmL2stBTiwGgwZzu9lqliuF4+Ia3S
YiN1e1NM7OOjggQb/Ko5o3EPIDuCFOBIZw+pEHeAy0z3Wmx6S+Jxw3UOq4DYQQkI
oXCCpfia+fjIzY/2zGok/umOds9n2JSeuG0T7isiLO7l7OplaKNYPvAyL58CDJut
0tReMjAC3f/U7sGd7yHp3LztjQY75G942CKY/cAb+SMsWQMO7ZBVkQIV0CdDL1U4
sKlIA5HTofTr/q/oHeEqCJL5wWbTLA==
=PjeW
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38141@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38141
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help