[PATCH] gnu: Add libltc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
7396e826a5e7f7de0ccefe67068f540d@posteo.net
From 061201b2179f5ac1c0a3cce89a256d7722c31978 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:45:11 +0000
Subject: [PATCH] gnu: Add libltc.

* gnu/packages/audio.scm: (libltc): New variable.
---
gnu/packages/audio.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (48 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 28dbf06f3b..acfd517bee 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3773,3 +3774,30 @@ other Gnaural instances, allowing synchronous
sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the
audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public libltc
+ (package
+ (name "libltc")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/x42/libltc/releases/download/v"
+ version "/libltc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f)) ; tests fail
+ (inputs
+ `(("glibc" ,glibc)))
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Linear/Logitudinal Time Code (LTC) Library")
+ (description "Libltc is a POSIX-C Library for handling
Linear/Logitudinal
+Time Code (LTC).")
+ (home-page "http://x42.github.io/libltc/")
+ (license license:lgpl3+)))
--
2.24.0
Marius Bakke wrote 5 years ago
877e47l74z.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 061201b2179f5ac1c0a3cce89a256d7722c31978 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:45:11 +0000
> Subject: [PATCH] gnu: Add libltc.
>
> * gnu/packages/audio.scm: (libltc): New variable.

[...]

Toggle quote (17 lines)
> +(define-public libltc
> + (package
> + (name "libltc")
> + (version "1.3.1")
> + (source
> + (origin
> + (method url-fetch)
> + (uri (string-append
> + "https://github.com/x42/libltc/releases/download/v"
> + version "/libltc-" version ".tar.gz"))
> + (sha256
> + (base32
> + "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
> + (build-system gnu-build-system)
> + (arguments
> + `(#:tests? #f)) ; tests fail

Could you give some information as to why the tests fail? Often it's
simply because of '/bin/sh' references and similar. You can investigate
a failed build with 'guix build --keep-failed'.

Toggle quote (3 lines)
> + (inputs
> + `(("glibc" ,glibc)))

glibc is always available and does not need to be explicitly provided.

Toggle quote (8 lines)
> + (native-inputs
> + `(("doxygen" ,doxygen)
> + ("pkg-config" ,pkg-config)))
> + (synopsis "Linear/Logitudinal Time Code (LTC) Library")
> + (description "Libltc is a POSIX-C Library for handling
> Linear/Logitudinal
> +Time Code (LTC).")
> + (home-page "http://x42.github.io/libltc/")
^^^
HTTPS
Toggle quote (3 lines)
> + (license license:lgpl3+)))
> --
> 2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IiZwACgkQoqBt8qM6
VPrh3gf+KUKcVTNnCUNUv8vNhWkRRw1Bs50CdWWJ03UZBG5PYSJ56+yB9Bwa0f43
lm2DXolx19g74GIbx96rU8Xw69zJkh3eJ17VUyuRbaoKsI65Ijng80K4/PHrQ6QX
mqX18gV5iOAaPDZR5Q5TvdZNniAyseC6MsaX/XplGbkOZCuMFbZ4aKQOXEck8ms2
1jALhS6dzW6lZLG1fEzfkADHzUbTAibqrQ8UP6Y6DE46G/kq3E8mkNRgC5drT8ZK
tS9XNPWV5u6nnJ65CFygwAUxzXh/SoSkw2U4/8s67PPK9onM0x59U/klPadomcJY
w0D4qqQjw6ehj17euJcWqZH7wB1C8w==
=mF+V
-----END PGP SIGNATURE-----

Alexandros Theodotou wrote 5 years ago
0ddcb7b9868cf83ed5e5066a67bdc2b1487cbe06.camel@zrythm.org
Patch updated
From 54e5a26b1a2d95370167d09591c2d12bf7b87503 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 10:45:11 +0000
Subject: [PATCH] gnu: Add libltc.

* gnu/packages/audio.scm: (libltc): New variable.
---
gnu/packages/audio.scm | 26 ++++++++++++++++++++++++++
1 file changed, 26 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bc79225115..43917d3eb4 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3766,3 +3767,28 @@ other Gnaural instances, allowing synchronous sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public libltc
+ (package
+ (name "libltc")
+ (version "1.3.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://github.com/x42/libltc/releases/download/v"
+ version "/libltc-" version ".tar.gz"))
+ (sha256
+ (base32
+ "173h9dgmain3nyrwk6q2d7yl4fnh4vacag4s2p01n5b7nyrkxrjh"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:parallel-tests? #f)) ; tests fail otherwise
+ (native-inputs
+ `(("doxygen" ,doxygen)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "Linear/Logitudinal Time Code (LTC) Library")
+ (description "Libltc is a POSIX-C Library for handling Linear/Logitudinal
+Time Code (LTC).")
+ (home-page "https://x42.github.io/libltc/")
+ (license license:lgpl3+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3IyQsACgkQAi6uQjE9
cPPz7Af/ZtdQbggOrmALSjJ3T9Cw4CVkw0AU/w6+kwI3Kj28ibkEOmLopZrDrPYl
gxzA5dBsM5eVYr/x8ksUK/CoNUgSnTVdHfzSZY33Tz1gMl70FfiDAPZVeJst+GC4
0+9+ULgWYdQbbCOVvp+kRKGz18bL0OL1tUVNuhn4y4kOG9F6NOEdiga+xVpod3Qu
I5H+NIwN+hvURTa32BeapXOCyIE7g3Q3y3EpukVDxrtwHOdMoq/9ewsehd5yH4CN
9RRCnWlJQc5DPrU3RNMQyptctwOJZYvAi073UkuY0Em6xGJs6gxQnGxobUP9+wtO
dh1EqVRIIAsoYvbXYIwLWx8WyMQCJw==
=00wp
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
87r22bifbo.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (7 lines)
> From 54e5a26b1a2d95370167d09591c2d12bf7b87503 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 10:45:11 +0000
> Subject: [PATCH] gnu: Add libltc.
>
> * gnu/packages/audio.scm: (libltc): New variable.

This was missing a module import for (gnu packages documentation).

I also tweaked synopsis and description slightly. Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3MgusACgkQoqBt8qM6
VPrBPwf+LvjzIQGHc92I3+RlSxU/vZOb+J0YGu8bntZIyP75w7iI0Fows8VEt3Hu
qVB0LCELeJa/396YS7096FaqSGgZPHw7dUlDCHMnXfcP3IploN8MNdDmxoZLtADQ
S9/IkTVUT145RmHcIfyeZIbjjrQvlcAuAlPwlIDOYcW2Xy2OTPOdWKKW3qqINvEF
ZRsS4mqwHY8/Hv008tkmYtbEX+zhSgGCySg8x64SFTln95BI4ThNHKZMnmWSVPHN
kurLgSz9dRRfmT2IpNuglhjYyXU8XUBSJj96wyyQxPZGQT3XsqPlpNU2enSxYAJk
1d+xUzeimBZCECG5R0gIHx5oh0C0EQ==
=oOHD
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38126@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38126
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help