[PATCH] gnu: Add redkite.

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexandros Theodotou
  • Marius Bakke
Owner
unassigned
Submitted by
Alexandros Theodotou
Severity
normal

Debbugs page

Alexandros Theodotou wrote 5 years ago
(name . Guix patches)(address . guix-patches@gnu.org)
c9dbda4349ae3f5aeb133ca1f90bb9ac@posteo.net
Adding this to audio because it's a GUI toolkit for audio plugins.

From 2991c39c555873b8bed3db3139ce6d35bb156a8e Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:47:25 +0000
Subject: [PATCH] gnu: Add redkite.

* gnu/packages/audio.scm: (redkite): New variable.
---
gnu/packages/audio.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 28dbf06f3b..e13833bf23 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3773,3 +3774,30 @@ other Gnaural instances, allowing synchronous
sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the
audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public redkite
+ (package
+ (name "redkite")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://gitlab.com/iurie/redkite/-/archive/v"
+ version "/redkite-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qif1x3s96zi81zkg11zkszf2i5mvfyrg9b3z2lr0jpzihgblk7y"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("cairo" ,cairo)
+ ("glibc" ,glibc)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Small GUI toolkit")
+ (description "Redkite is a small GUI toolkit developed in C++17 and
+inspired from other well known GUI toolkits.")
+ (home-page "https://gitlab.com/iurie/redkite")
+ (license license:gpl3+)))
--
2.24.0
Marius Bakke wrote 5 years ago
87v9rrjrpq.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (9 lines)
> Adding this to audio because it's a GUI toolkit for audio plugins.
>
> From 2991c39c555873b8bed3db3139ce6d35bb156a8e Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:47:25 +0000
> Subject: [PATCH] gnu: Add redkite.
>
> * gnu/packages/audio.scm: (redkite): New variable.

Thanks!

[...]

Toggle quote (4 lines)
> + (uri
> + (string-append "https://gitlab.com/iurie/redkite/-/archive/v"
> + version "/redkite-v" version ".tar.gz"))

This can be condensed to two lines.

Toggle quote (6 lines)
> + (native-inputs
> + `(("pkg-config", pkg-config)))
> + (synopsis "Small GUI toolkit")
> + (description "Redkite is a small GUI toolkit developed in C++17 and
> +inspired from other well known GUI toolkits.")

Can you expand on this description a bit? What makes it different from
(or similar to) other GUI toolkits?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3IjfEACgkQoqBt8qM6
VPo4zwgAoBTQJyJ/C2WN8Y6598zvlxslLa0XOVF3UOI0uZG6RtpOL3JXzCIIksFQ
0k5zUmuuKR4X9R6sIo2t/jL11m01H5MUmpV7Q5fJwVWtT7IXXDtA6jSymPSgGM7H
c1+wKU2iGccyUa6EF6DD3aClRrWJDM/FA4tep3yZDjQUSPINPAO0ln6nalJDWWNO
r71MbFgi5hgN8RQg03CBwdVWPiXs7NVdniVH0ItsTICitSXvWiTVyDy9+JdqED63
QCBZVSqxAhizXyV+YNnBRrH3hWDE0AE7IIp4xaqLe+T7vU6/4azQ6htWJQnrh9gj
8MVaThAjlo8ptMu8SFet/KbnTwsing==
=sKQ7
-----END PGP SIGNATURE-----

Alexandros Theodotou wrote 5 years ago
d9ed727a87706e704ee13189c1d311ef708c08f5.camel@zrythm.org
Marius,

Thanks for the reviews! Updated.

The new description feels a bit too formal - the upstream descriptions
were too short so I had to come up with something. Feel free to edit
it.
From f50684e58e8b4c6f8bc105dd9f0650fcb366b875 Mon Sep 17 00:00:00 2001
From: Alexandros Theodotou <alex@zrythm.org>
Date: Fri, 8 Nov 2019 09:47:25 +0000
Subject: [PATCH] gnu: Add redkite.

* gnu/packages/audio.scm: (redkite): New variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index bc79225115..04b43e2412 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -23,6 +23,7 @@
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2019 Mathieu Othacehe <m.othacehe@gmail.com>
+;;; Copyright © 2019 Alexandros Theodotou <alex@zrythm.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3766,3 +3767,32 @@ other Gnaural instances, allowing synchronous sessions between many users.")
a sound card, encodes it into Ogg Vorbis and/or mp3, and sends the audio
stream to one or more IceCast and/or ShoutCast servers.")
(license license:gpl3+)))
+
+(define-public redkite
+ (package
+ (name "redkite")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://gitlab.com/iurie/redkite/-/archive/v"
+ version "/redkite-v" version ".tar.gz"))
+ (sha256
+ (base32
+ "0qif1x3s96zi81zkg11zkszf2i5mvfyrg9b3z2lr0jpzihgblk7y"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ; no tests included
+ (inputs
+ `(("cairo" ,cairo)
+ ("glibc" ,glibc)))
+ (native-inputs
+ `(("pkg-config", pkg-config)))
+ (synopsis "Small GUI toolkit")
+ (description "Redkite is a small GUI toolkit developed in C++17 and
+inspired from other well known GUI toolkits such as Qt and GTK. It is
+minimal on purpose and is intended to be statically linked to applications,
+therefore satisfying any requirements they may have to be self contained,
+as is the case with audio plugins.")
+ (home-page "https://gitlab.com/iurie/redkite")
+ (license license:gpl3+)))
--
2.24.0
-----BEGIN PGP SIGNATURE-----

iQEzBAABCAAdFiEESBMjhK0999huJUuDAi6uQjE9cPMFAl3I1OEACgkQAi6uQjE9
cPPaPggAkqZ6qvDB5eJQskBpxfCjbV6adlc6csQwJcqGlSouD3QPYvJ4/73mog1m
0ksgskM/jRJah6VuWpu8uXxxYB3uGrZJaGdAWZCyz8rCkfvPN8pjXMbmeR3MjRmN
uTtETitg4QMcFENqIp75y16RehrJy+XFodFVvN78Q7FxvvV3n2tPJEbjCLGz0yqT
aOBwPs22DaUdCXPXslVYWTwM84Wni8mI2xuKazC9xRyot7zEff0YNbWykPHKBvTf
rW1z4jDjBHVzjstBItUxiuC5GZl7WIdbkQmtH1S01dkc4+SpfdC7UWyiupGL9g9f
iZSrfDVnGjSd0tQprRM1GOYU2fM8BA==
=9uI8
-----END PGP SIGNATURE-----


Marius Bakke wrote 5 years ago
87muczif85.fsf@devup.no
Alexandros Theodotou <alex@zrythm.org> writes:

Toggle quote (8 lines)
> Marius,
>
> Thanks for the reviews! Updated.
>
> The new description feels a bit too formal - the upstream descriptions
> were too short so I had to come up with something. Feel free to edit
> it.

Looks good to me! We can always adjust it later.

On a related note, it feels weird to have a GUI toolkit in audio.scm,
but I could not think of a better place for it. Suggestions welcome.

Toggle quote (7 lines)
> From f50684e58e8b4c6f8bc105dd9f0650fcb366b875 Mon Sep 17 00:00:00 2001
> From: Alexandros Theodotou <alex@zrythm.org>
> Date: Fri, 8 Nov 2019 09:47:25 +0000
> Subject: [PATCH] gnu: Add redkite.
>
> * gnu/packages/audio.scm: (redkite): New variable.

Applied, thanks!

[...]

Toggle quote (2 lines)
The URL redirects to 'gitlab.com/geontime/redkite', so I updated it.

I also made a follow-up patch that downloads a git checkout instead of
an autogenerated tarball, because the tarball hash might change in the
future when GitLab generates a new one.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl3Mg2oACgkQoqBt8qM6
VPoBWQf/ROVlAliGl1mT8gs92jOlHHTSfVMPiG6DxW/X+tQi6WSjxQkO0cXoVm6r
zV0GUVUmQWaxkbhz7t2GU8p9H2WXopkc4LdpwRPwB2Tpy69uEor1sefGj0Mguj2k
zQ90guobUh+nIsHI1S4hjVwDaNWUsi8MtbQGz9H9Q/uyZrWDQHqGUeApUhBdYLYs
RI/Akf3peIFAGYQg/xpWoNbkDS8iTzuiqc/fFn+NHQuDhtuwEa9Za57xQw8pap+A
CwDqYHqZ+MUEAad2UlSIgBhWii4UfjeoZgcejMSQiF7yPm5av0zNZb83Ew10Mxv4
MjxQ6MgozHzOsxGsMXl/bGBUj9EGqg==
=MdAW
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38119@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38119
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help