[PATCH] gnu: lmms: Update to 1.2.1.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Marius Bakke
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20191103045127.27469-1-kkebreau@posteo.net
* gnu/packages/music.scm (lmms): Update to 1.2.1.
[arguments]: Enable Qt 5 support and disbale VST support in configure-flags.
Add 'unpack-rpmalloc' phase and remove 'remove-Werror' phase.
[native-inputs]: Add qttools and rpmalloc.
[inputs]: Replace qt-4 and fluidsynth-1 with qtbase and fluidsynth,
respectively; add qtx11extras.
---
gnu/packages/music.scm | 38 +++++++++++++++++++++++++++-----------
1 file changed, 27 insertions(+), 11 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index c14055cd5d..c219113867 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -3707,7 +3707,7 @@ are a C compiler and glib. Full API documentation and examples are included.")
(define-public lmms
(package
(name "lmms")
- (version "1.1.3")
+ (version "1.2.1")
(source
(origin
(method git-fetch)
@@ -3717,12 +3717,23 @@ are a C compiler and glib. Full API documentation and examples are included.")
(file-name (git-file-name name version))
(sha256
(base32
- "03hhymc6d73fa3wbcqb7rm1l03zkw605k5i9kvkvjmv488bqh3pd"))))
+ "1gx730z361xx30iqbsm99aam1k2c8yf561gcay6sryyjksb4w1wy"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; no tests
+ ;; Qt 5 support must be explicitly enabled in the 1.2 stable versions of
+ ;; LMMS, so try removing "-DWANT_QT5=ON" in later versions.
+ ;; Also, explicitly disabling VST support gets rid of the in-tree
+ ;; dependency on qt5-x11embed.
+ #:configure-flags '("-DWANT_QT5=ON"
+ "-DWANT_VST=OFF")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'unpack-rpmalloc
+ (lambda* (#:key inputs #:allow-other-keys)
+ (copy-recursively (assoc-ref inputs "rpmalloc")
+ "src/3rdparty/rpmalloc/rpmalloc")
+ #t))
(add-before 'configure 'set-ldflags
(lambda* (#:key outputs #:allow-other-keys)
(setenv "LDFLAGS"
@@ -3733,12 +3744,6 @@ are a C compiler and glib. Full API documentation and examples are included.")
(assoc-ref outputs "out") "/lib/lmms/ladspa"
"\""))
#t))
- (add-before 'configure 'remove-Werror
- (lambda _
- (substitute* "CMakeLists.txt"
- (("SET\\(WERROR_FLAGS \"\\$\\{WERROR_FLAGS\\} -Werror")
- "SET(WERROR_FLAGS \"${WERROR_FLAGS}"))
- #t))
(add-before 'reset-gzip-timestamps 'make-manpages-writable
(lambda* (#:key outputs #:allow-other-keys)
(map (lambda (file)
@@ -3748,14 +3753,25 @@ are a C compiler and glib. Full API documentation and examples are included.")
".*\\.gz$"))
#t)))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)
+ ("rpmalloc"
+ ,(origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mjansson/rpmalloc.git")
+ (commit "b5bdc18051bb74a22f0bde4bcc90b01cf590b496")))
+ (sha256
+ (base32
+ "0g9pls46iggg7rdm65vzfj8nyr3v2n5xkp54c4qbh9hhalpsw4ay"))))))
(inputs
`(("sdl" ,sdl)
- ("qt" ,qt-4)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
("fltk" ,fltk)
("libogg" ,libogg)
("libsamplerate" ,libsamplerate)
- ("fluidsynth" ,fluidsynth-1) ;XXX: try using 2.x when updating
+ ("fluidsynth" ,fluidsynth)
("libvorbis" ,libvorbis)
("alsa-lib" ,alsa-lib)
("portaudio" ,portaudio)
--
2.23.0
Marius Bakke wrote 5 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)
87eeyporok.fsf@devup.no
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (7 lines)
> * gnu/packages/music.scm (lmms): Update to 1.2.1.
> [arguments]: Enable Qt 5 support and disbale VST support in configure-flags.
> Add 'unpack-rpmalloc' phase and remove 'remove-Werror' phase.
> [native-inputs]: Add qttools and rpmalloc.
> [inputs]: Replace qt-4 and fluidsynth-1 with qtbase and fluidsynth,
> respectively; add qtx11extras.

Can you add a comment about what rpmalloc is, and how to tell which
version to pick?

Otherwise LGTM, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl2+/tsACgkQoqBt8qM6
VPpaOAf/W3pDOY4M4CvYW0ngnmCM8fJSy/78PYMl/eF7m73CVR7tIHghFa5gPiv4
niaJpJMHu8S7u+BZpMuS0Rc/cbnq6lT8vlPnxHuubbBxil712sDK6a1ZD+NoO0T8
+AIBoCtfb+Wla8X97r6ZcdqOMwqANOu7a0xgF0w9gcFqzgAcUwlRlJmgo1gLItt5
f5PxrhgNdfs18VAefGrM1ByJpjxnNFLO9q1yQOZGeygukSDWEq0NtUykQ9ZMi+3/
VaAnQbm1eUwNxHcavDduVfiu1GA9NqWrjOFrObnY3UenTEMausGvbFiugTYqNZL0
hCM6n3BCNI5KNZcgISjpwh1tvR26RA==
=qC3m
-----END PGP SIGNATURE-----

Kei Kebreau wrote 5 years ago
(name . Marius Bakke)(address . mbakke@fastmail.com)(address . 38042-done@debbugs.gnu.org)
87k18gqvr9.fsf@posteo.net
Marius Bakke <mbakke@fastmail.com> writes:

Toggle quote (13 lines)
> Kei Kebreau <kkebreau@posteo.net> writes:
>
>> * gnu/packages/music.scm (lmms): Update to 1.2.1.
>> [arguments]: Enable Qt 5 support and disbale VST support in configure-flags.
>> Add 'unpack-rpmalloc' phase and remove 'remove-Werror' phase.
>> [native-inputs]: Add qttools and rpmalloc.
>> [inputs]: Replace qt-4 and fluidsynth-1 with qtbase and fluidsynth,
>> respectively; add qtx11extras.
>
> Can you add a comment about what rpmalloc is, and how to tell which
> version to pick?
>

I included the following comment and pushed to the master branch:

rpmalloc is a public domain memory allocator. This version specified
below is the version required by LMMS.
To get the new commit of rpmalloc to use here, run
`git submodule--helper list | grep rpmalloc | cut -f2 -d' '`
in the cloned LMMS repository.

Toggle quote (2 lines)
> Otherwise LGTM, thanks!

Thanks for reviewing!
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCAAdFiEEg7ZwOtzKO2lLzi2m5qXuPBlGeg0FAl2/fboACgkQ5qXuPBlG
eg287Q//cMpbLWyCEl8kl4ibrnduhAKu/UA451IbxJocrS5sCYKeKpLLozHULXY5
lCwgH66FAs/N4kmxMKdOhNLlhx3loLTM8PYxaHdJzZfFVQaJbm1gp0BzTjGF3B/o
5eEDJczHbsLZ1xe+iXTArcMLkrye6QkU2bxLIGQIy+M+J5Vr905Hw3NDRYTIs5Xb
B3/dNkO7YRlJCEuKpF7ji80Zo8f8v3eNa42mQtv7MASmlzS43xXT/GeDlNzFrVhA
MOUiK3wIHLl3AFxTTQhwP9GBO08yRtPYXuTpuYnamD+Cl/pJBAqFn4O71FYczY8d
JMvNTk2hAReL5SDhHCDBE4seYjvqeWnmCRGoEf8v1P3L4fCD3v6lg3KBKMliOF7r
E3VnY2wTFwuMiNwPiqXRBEtcwsb/ULbJIUjMRX7aQJJBG+A7hdb6mRsoUx8HqqTe
Ip2s1b3s4qL08VAGpKnhromrab7GzKsqwwMdt6o4TwlSHRZuGdPMl2piQd4nsm3l
NeexTkGEGu/aaYaf/kvpyYzJTPeHxSzhfG1b3uODnyhKr54ZJ/TZDrjOLhBqjhw2
Kta9xlrWtQ/ob3AMYAxC/8VESOyQTGvSOXzLGQzSZ3OBYwl2h/0RdjQqpP+Jidjl
raVYBVrAHXIgvcesb1puIXYR5AavKuvt6cckRVo9Ft/2XTbG1UU=
=F9c/
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38042@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38042
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help