[PATCH] gnu: Add emacs-leaf

  • Done
  • quality assurance status badge
Details
2 participants
  • Leo Prikler
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
20191101114602.31959-1-leo.prikler@student.tugraz.at
* gnu/packages/emacs-xyz: (emacs-leaf): New variable.
---
gnu/packages/emacs-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 6f584f72b7..0b206121b2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8959,6 +8959,36 @@ configuration in your @file{.emacs} file in a way that is both
performance-oriented and tidy.")
(license license:gpl2+)))
+(define-public emacs-leaf
+ (package
+ (name "emacs-leaf")
+ (version "3.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/conao3/leaf.el.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1rgd59146wad92yc64las0qgx67k2ifgsw1vwhp40xvkd7kb0r6d"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/conao3/leaf.el")
+ (arguments
+ `(#:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "leaf-tests.el"
+ "-f" "cort-test-run")))
+ (synopsis
+ "Simplify your init.el configuration, extended use-package")
+ (description
+ "Provides macros that allow you to declaratively configure settings typical
+of an Elisp package with various keywords. The syntax is similar, but not
+identical to use-package -- overall, leaf aims at a cleaner and more predictable
+implementation.")
+ (license license:agpl3+)))
+
(define-public emacs-strace-mode
(let* ((commit "6a69b4b06db6797af56f33eda5cb28af94e59f11")
(revision "1"))
--
2.23.0
Mathieu Othacehe wrote 5 years ago
(address . guix-patches@gnu.org)(address . 38018-done@debbugs.gnu.org)
877e4gc8c5.fsf@gmail.com
Hello Leo,

I fixed the indentation, added your copyright and pushed your patch :)

Thanks,

Mathieu
?
Your comment

This issue is archived.

To comment on this conversation send an email to 38018@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 38018
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help