Ivan Gankevich wrote 5 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
---
I have updated pocl to the latest version because current version (1.2)
does not compile with llvm 8 which is the default LLVM version in Guix.
gnu/packages/opencl.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
Toggle diff (33 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index fc9c11caa5..81e5bab9db 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -296,7 +296,7 @@ back-end for the LLVM compiler framework.")
(define-public pocl
(package
(name "pocl")
- (version "1.2")
+ (version "1.4")
(source
(origin
(method git-fetch)
@@ -304,7 +304,7 @@ back-end for the LLVM compiler framework.")
(url "https://github.com/pocl/pocl.git")
(commit (string-append "v" version))))
(sha256
- (base32 "0fyiwd9nrqhl0jsac0bx17p9acpfzhyxp50mmp28mzn7psb9qidg"))
+ (base32 "1c4y69zks6hkq5fqh9waxgb8g4ka7y6h3vacmsm720kba0h57g8a"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
@@ -313,7 +313,7 @@ back-end for the LLVM compiler framework.")
(inputs
`(("clang" ,clang)
("hwloc" ,hwloc-2.0 "lib")
- ("llvm" ,llvm)
+ ("llvm" ,llvm-8)
("ocl-icd" ,ocl-icd)))
(arguments
`(#:configure-flags
--
2.23.0