[PATCH] gnu: pocl: Update to 1.4.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ivan Gankevich
  • Marius Bakke
Owner
unassigned
Submitted by
Ivan Gankevich
Severity
normal

Debbugs page

Ivan Gankevich wrote 5 years ago
(address . guix-patches@gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
20191030160509.28129-1-i.gankevich@spbu.ru
---
I have updated pocl to the latest version because current version (1.2)
does not compile with llvm 8 which is the default LLVM version in Guix.

gnu/packages/opencl.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/opencl.scm b/gnu/packages/opencl.scm
index fc9c11caa5..81e5bab9db 100644
--- a/gnu/packages/opencl.scm
+++ b/gnu/packages/opencl.scm
@@ -296,7 +296,7 @@ back-end for the LLVM compiler framework.")
(define-public pocl
(package
(name "pocl")
- (version "1.2")
+ (version "1.4")
(source
(origin
(method git-fetch)
@@ -304,7 +304,7 @@ back-end for the LLVM compiler framework.")
(url "https://github.com/pocl/pocl.git")
(commit (string-append "v" version))))
(sha256
- (base32 "0fyiwd9nrqhl0jsac0bx17p9acpfzhyxp50mmp28mzn7psb9qidg"))
+ (base32 "1c4y69zks6hkq5fqh9waxgb8g4ka7y6h3vacmsm720kba0h57g8a"))
(file-name (git-file-name name version))))
(build-system cmake-build-system)
(native-inputs
@@ -313,7 +313,7 @@ back-end for the LLVM compiler framework.")
(inputs
`(("clang" ,clang)
("hwloc" ,hwloc-2.0 "lib")
- ("llvm" ,llvm)
+ ("llvm" ,llvm-8)
("ocl-icd" ,ocl-icd)))
(arguments
`(#:configure-flags
--
2.23.0
Marius Bakke wrote 5 years ago
(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)(address . 37995-done@debbugs.gnu.org)(name . Ivan Gankevich)(address . i.gankevich@spbu.ru)
87k18lpylx.fsf@devup.no
Ivan Gankevich <i.gankevich@spbu.ru> writes:

Toggle quote (4 lines)
> ---
> I have updated pocl to the latest version because current version (1.2)
> does not compile with llvm 8 which is the default LLVM version in Guix.

Thanks! Pushed in bbad38f4d8e6b6ecc15c476b973094cdf96cdeae with a
ChangeLog-style commit message.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl26JYoACgkQoqBt8qM6
VPrvrQgAsCoIpEay2V9CdEsalgSrltzSBtzo9Tjca4oTevWIa8NzfapUe7hCqGmn
WHN3bnLv5CrQ+mdVpb+eWDFlK7ZgrBSLIpCkuXynGoM+lEpPbmzJHRUeiJ5YXqQL
rNbvSLyGzBDWnhDu43T+Bfui85gHqLIdXrzMMYZrBqshOqt33ZhLY6X8KUceSuFM
qz8rVjjifUxujpkHaa/TdW2RJvzECbp4U++HEZh2FOwYDvBk+PxPP+4OMgby3IDB
Yt2GgPLROQ7veprQFs2s2tfSxoNJkM9lyZg26TRfkNLxlHlQqKGxZJ/jc3XhPtwy
zX34GnLw/fb990ZSdXKxYC12rXNq7Q==
=Kap4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37995@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37995
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help