[PATCH 1/1] * audio.scm (define public lilv): enable python bindings

  • Done
  • quality assurance status badge
Details
3 participants
  • Florian Paul Schmidt
  • Jelle Licht
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Florian Paul Schmidt
Severity
normal
F
F
Florian Paul Schmidt wrote on 29 Oct 2019 10:45
(address . guix-patches@gnu.org)
20191029104423.2513c959@uni-bielefeld.de

From 5afa9eac9c34c2e74114f96a6fe746a571b752ee Mon Sep 17 00:00:00 2001
From: Florian Paul Schmidt <florian_paul.schmidt@uni-bielefeld.de>
Date: Tue, 29 Oct 2019 10:34:45 +0100
Subject: [PATCH 1/1] * audio.scm (define public lilv): enable python bindings
to be built

---
gnu/packages/audio.scm | 16 ++++++++++++++--
1 file changed, 14 insertions(+), 2 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 88f3b5eccd..6438e4e3c6 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1828,6 +1828,7 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target
+ #:configure-flags (list "--bindings")
#:phases
(modify-phases %standard-phases
(add-before
@@ -1836,6 +1837,16 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
(setenv "LDFLAGS"
(string-append "-Wl,-rpath="
(assoc-ref outputs "out") "/lib"))
+ #t))
+ (add-after
+ 'unpack 'full-store-path-to-shared-library
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chdir "bindings/python")
+ (substitute*
+ "lilv.py"
+ (("liblilv-0.so") (string-append (assoc-ref outputs "out")
+ "/lib/liblilv-0.so")))
+ (chdir "../../")
#t)))))
;; Required by lilv-0.pc.
(propagated-inputs
@@ -1844,8 +1855,9 @@ included are the command line utilities @code{send_osc} and @code{dump_osc}.")
("sord" ,sord)
("sratom" ,sratom)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "https://drobilla.net/software/lilv/")
+ `(("python" ,python)
+ ("pkg-config" ,pkg-config)))
+ (home-page "https://drobilla.net/software/lilv")
(synopsis "Library to simplify use of LV2 plugins in applications")
(description
"Lilv is a C library to make the use of LV2 plugins as simple as possible
--
2.23.0
M
M
Mathieu Othacehe wrote on 30 Oct 2019 10:48
(address . guix-patches@gnu.org)(address . 37979@debbugs.gnu.org)
87v9s6bm35.fsf@gmail.com
Hello,

You can use with-directory-excursion instead of doing:

Toggle snippet (5 lines)
(chdir "bindings/python")
...
(chdir "../..")

Also the commit title should be:

gnu: lilv: Enable python bindings.

Can you please send a v2 :) ?

Thanks,

Mathieu
J
J
Jelle Licht wrote on 28 May 2023 23:36
Re: bug#37979: [PATCH 1/1] * audio.scm (define public lilv): enable python bindings
(address . 37979-done@debbugs.gnu.org)(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
87ilccp28g.fsf@fsfe.org
The lilv on master seems to expose python bindings, closing.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37979@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37979
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch