parse-error in latest news entry

  • Done
  • quality assurance status badge
Details
One participant
  • Eric Bavier
Owner
unassigned
Submitted by
Eric Bavier
Severity
normal

Debbugs page

Eric Bavier wrote 5 years ago
(address . bug-guix@gnu.org)
564677810.293420.1572281868245.JavaMail.zimbra@centurylink.net

News for channel 'guix'
Backtrace:
16 (apply-smob/1 #<catch-closure 7f64e679a200>)
In ice-9/boot-9.scm:
705:2 15 (call-with-prompt _ _ #<procedure default-prompt-handle…>)
In ice-9/eval.scm:
619:8 14 (_ #(#(#<directory (guile-user) 7f64e644b140>)))
In guix/ui.scm:
1730:12 13 (run-guix-command _ . _)
In ice-9/boot-9.scm:
829:9 12 (catch _ _ #<procedure 7f64e63bb018 at guix/ui.scm:642…> …)
829:9 11 (catch _ _ #<procedure 7f64e63bb030 at guix/ui.scm:765…> …)
829:9 10 (catch _ _ #<procedure 7f64e3d27878 at guix/scripts/pu…> …)
In srfi/srfi-1.scm:
640:9 9 (for-each #<procedure 7f64e3d256e0 at guix/scripts/pul…> …)
In guix/scripts/pull.scm:
283:11 8 (display-channel-specific-news _ _ #:port _ #:concise? _)
In srfi/srfi-1.scm:
640:9 7 (for-each #<procedure 7f64d5b03720 at guix/scripts/pul…> …)
In guix/scripts/pull.scm:
251:2 6 (display-news-entry #<<channel-news-entry> commit: "49…> …)
241:12 5 (display-news-entry-title _ _ #<output: file /dev/pts/19>)
In guix/ui.scm:
1210:23 4 (texi->plain-text _)
In texinfo.scm:
1131:22 3 (parse _)
979:31 2 (loop #<input: string 7f64e6483230> (*fragment*) _ _ _)
910:31 1 (loop #<input: string 7f64e6483230> #f #<procedure ide…> …)
745:27 0 (_ #<input: string 7f64e6483230> #f #f #<procedure 7f6…> …)

texinfo.scm:745:27: Throw to key `parser-error' with args `(#<input: string 7f64e6483230> "EOF while reading a token " "reading char data")'

I believe this is due to missing trailing '}' in the en title:

(entry (commit "49af34cfac89d384c46269bfd9388b2c73b1220a")
(title (en "@command{guix pull} now honors
@file{/etc/guix/channels.scm")
^

BTW, is there a good way to test these news entries, since they appear to be code and can cause errors for users like this? './pre-inst-env guix pull --news' seems to still read news ~/.config/guix/current.

--
`~Eric
Eric Bavier wrote 5 years ago
(address . 37965@debbugs.gnu.org)
1018582292.389516.1572294463512.JavaMail.zimbra@centurylink.net
FWIW, hacky way to check news items in shell:

```
commit=HEAD
previous=$(git rev-parase ${commit}^)
guix pull --url="file://$PWD" --commit="$previous" --profile=$PWD/_pull_check
guix pull --uri="file://$PWD" --commit="$commit" --profile=$PWD/_pull_check
guix pull --profile=$PWD/_pull_check --news
rm -rf $PWD/_pull_check
```

`~Eric

----- On Oct 28, 2019, at 4:58 PM, GNU bug Tracking System help-debbugs@gnu.org wrote:

Toggle quote (22 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> Your message has been sent to the package maintainer(s):
> bug-guix@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 37965@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 37965: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37965
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems

--
`~Eric
Eric Bavier wrote 5 years ago
(name . 37965)(address . 37965@debbugs.gnu.org)
1792031641.405898.1572296348813.JavaMail.zimbra@centurylink.net
Something like this is probably better:

```scheme
(use-modules (guix ui)
(srfi srfi-1))
(define (strings lst)
(fold (lambda (i result)
(cond
((string? i) (cons i result))
((list? i) (append (strings i) result))
(else result)))
(list)
lst))
(map texi->plain-text
(strings (call-with-input-file "etc/news.scm" read))
```

----- On Oct 28, 2019, at 8:27 PM, Eric Bavier ericbavier@centurylink.net wrote:

Toggle quote (41 lines)
> FWIW, hacky way to check news items in shell:
>
> ```
> commit=HEAD
> previous=$(git rev-parase ${commit}^)
> guix pull --url="file://$PWD" --commit="$previous" --profile=$PWD/_pull_check
> guix pull --uri="file://$PWD" --commit="$commit" --profile=$PWD/_pull_check
> guix pull --profile=$PWD/_pull_check --news
> rm -rf $PWD/_pull_check
> ```
>
> `~Eric
>
> ----- On Oct 28, 2019, at 4:58 PM, GNU bug Tracking System help-debbugs@gnu.org
> wrote:
>
>> Thank you for filing a new bug report with debbugs.gnu.org.
>>
>> This is an automatically generated reply to let you know your message
>> has been received.
>>
>> Your message is being forwarded to the package maintainers and other
>> interested parties for their attention; they will reply in due course.
>>
>> Your message has been sent to the package maintainer(s):
>> bug-guix@gnu.org
>>
>> If you wish to submit further information on this problem, please
>> send it to 37965@debbugs.gnu.org.
>>
>> Please do not send mail to help-debbugs@gnu.org unless you wish
>> to report a problem with the Bug-tracking system.
>>
>> --
>> 37965: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=37965
>> GNU Bug Tracking System
>> Contact help-debbugs@gnu.org with problems
>
> --
> `~Eric

--
`~Eric
Eric Bavier wrote 5 years ago
(address . control@debbugs.gnu.org)
1569445653.439043.1572300215418.JavaMail.zimbra@centurylink.net
close 37965 6b00a5f4a79819db08cb4d8e9f24a01445b7962b
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37965@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37965
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help