[PATCH 0/2] gnu: profanity: Add configure flags and inputs for better defaults.

  • Done
  • quality assurance status badge
Details
2 participants
  • Mathieu Othacehe
  • Tanguy Le Carrour
Owner
unassigned
Submitted by
Tanguy Le Carrour
Severity
normal
T
T
T
Tanguy Le Carrour wrote on 25 Oct 2019 17:20
[PATCH 1/2] gnu: profanity: Add configure flags and inputs for better defaults.
(address . 37923@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20191025152040.25196-1-tanguy@bioneland.org
* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-omemo, --enable-notifications and --enable-icon.
[native-inputs]: Add libnotify and libsignal-protocol-c.
---
gnu/packages/messaging.scm | 7 +++++++
1 file changed, 7 insertions(+)

Toggle diff (28 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f890ad8dd5..ca01a4492e 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1627,6 +1627,11 @@ are both supported).")
(base32
"0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--enable-omemo"
+ "--enable-icon"
+ "--enable-notifications")))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -1642,7 +1647,9 @@ are both supported).")
("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("cmocka" ,cmocka)
+ ("libnotify" ,libnotify)
("libtool" ,libtool)
+ ("libsignal-protocol-c" ,libsignal-protocol-c)
("pkg-config" ,pkg-config)))
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
--
2.23.0
T
T
Tanguy Le Carrour wrote on 25 Oct 2019 17:20
[PATCH 2/2] gnu: profanity: Update home-page URL.
(address . 37923@debbugs.gnu.org)(name . Tanguy Le Carrour)(address . tanguy@bioneland.org)
20191025152040.25196-2-tanguy@bioneland.org
* gnu/packages/messaging.scm (profanity)[home-page]: Update URL.
---
gnu/packages/messaging.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index ca01a4492e..afbb97487a 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1654,7 +1654,7 @@ are both supported).")
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
using ncurses and libmesode, inspired by Irssi.")
- (home-page "http://www.profanity.im")
+ (home-page "https://profanity-im.github.io")
(license license:gpl3+)))
(define-public libircclient
--
2.23.0
M
M
Mathieu Othacehe wrote on 25 Oct 2019 19:25
Re: [bug#37923] [PATCH 1/2] gnu: profanity: Add configure flags and inputs for better defaults.
(address . guix-patches@gnu.org)
87h83wu49h.fsf@gmail.com
Hey Tanguy,

Much better with git send-email ;) A few remarks below:

Toggle quote (1 lines)
> + `(#:configure-flags
^
It can be ' because there are no unquoting in the following list.

Toggle quote (1 lines)
> + "--enable-icon"
^
I think it is --enable-icons but that triggers missing inputs. You can
have a look to nix recipe if needed.

Thanks,

Mathieu
T
T
Tanguy Le Carrour wrote on 26 Oct 2019 18:12
(name . Mathieu Othacehe)(address . m.othacehe@gmail.com)
20191026161246.bi6kxcrc6zkdqns5@melmoth
Hi Mathieu,


Le 10/25, Mathieu Othacehe a écrit :
Toggle quote (6 lines)
> Much better with git send-email ;) A few remarks below:
>
> > + `(#:configure-flags
> ^
> It can be ' because there are no unquoting in the following list.

Done!


Toggle quote (5 lines)
> > + "--enable-icon"
> ^
> I think it is --enable-icons but that triggers missing inputs. You can
> have a look to nix recipe if needed.

Outch! Sorry for that! Actually when I added it I thought "if I don't
spell it properly, configure will fail, won't it?"… obviously I was
wrong! ^_^'


v2 is following.

I also added "--enable-c-plugins" and "--enable-otr" with the comment
from Nix expression ("Enable feature flags, so that build fail if libs
are missing") in the commit message. And I added "--enable-pgp" in
a separate commit… but I guess you'll squash everything together, right?

I tried to add "--enable-python-plugins" and "python" as a native input,
but it did not work! So, for now, I left it out.

Thanks again for reviewing!

--
Tanguy
T
T
tanguy wrote on 26 Oct 2019 18:16
[PATCH v2 1/4] gnu: profanity: Add configure flags and inputs for better defaults.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026161653.11871-1-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-omemo, --enable-notifications and --enable-icon.
[native-inputs]: Add libnotify and libsignal-protocol-c.
---
gnu/packages/messaging.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f890ad8dd5..b56a3e92cb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1627,6 +1627,11 @@ are both supported).")
(base32
"0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "--enable-omemo"
+ "--enable-icons"
+ "--enable-notifications")))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -1642,7 +1647,10 @@ are both supported).")
("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("cmocka" ,cmocka)
+ ("gtk+" ,gtk+-2)
+ ("libnotify" ,libnotify)
("libtool" ,libtool)
+ ("libsignal-protocol-c" ,libsignal-protocol-c)
("pkg-config" ,pkg-config)))
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 18:16
[PATCH v2 3/4] gnu: profanity: Add configure flags, so that build fail if libs are missing.
(address . 37923@debbugs.gnu.org)
20191026161653.11871-3-tanguy@bioneland.org
From: "tlecarrour@easter-eggs.com" <tlecarrour@easter-eggs.com>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-c-plugins and --enable-otr.
---
gnu/packages/messaging.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 63b14287ce..626aec4908 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1629,7 +1629,9 @@ are both supported).")
(build-system gnu-build-system)
(arguments
'(#:configure-flags
- (list "--enable-omemo"
+ (list "--enable-c-plugins"
+ "--enable-otr"
+ "--enable-omemo"
"--enable-icons"
"--enable-notifications")))
(inputs
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 18:16
[PATCH v2 4/4] gnu: profanity: Add configure flags for better defaults.
(address . 37923@debbugs.gnu.org)
20191026161653.11871-4-tanguy@bioneland.org
From: "tlecarrour@easter-eggs.com" <tlecarrour@easter-eggs.com>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-pgp.
---
gnu/packages/messaging.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 626aec4908..a6e9dcbbb3 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1632,6 +1632,7 @@ are both supported).")
(list "--enable-c-plugins"
"--enable-otr"
"--enable-omemo"
+ "--enable-pgp"
"--enable-icons"
"--enable-notifications")))
(inputs
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 18:16
[PATCH v2 2/4] gnu: profanity: Update home-page URL.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026161653.11871-2-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[home-page]: Update URL.
---
gnu/packages/messaging.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b56a3e92cb..63b14287ce 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1655,7 +1655,7 @@ are both supported).")
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
using ncurses and libmesode, inspired by Irssi.")
- (home-page "http://www.profanity.im")
+ (home-page "https://profanity-im.github.io")
(license license:gpl3+)))
(define-public libircclient
--
2.23.0
T
T
Tanguy Le Carrour wrote on 26 Oct 2019 23:09
[PATCH 0/4] gnu: profanity: Add configure flags and inputs for better defaults.
(address . 37923@debbugs.gnu.org)
20191026210958.ockiczrqehbqtqcl@melmoth
Wrong author in 2 of the commits! Sorry, sending v3!

--
Tanguy
T
T
tanguy wrote on 26 Oct 2019 23:11
[PATCH v3 1/4] gnu: profanity: Add configure flags and inputs for better defaults.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026211110.2595-1-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-omemo, --enable-notifications and --enable-icon.
[native-inputs]: Add libnotify and libsignal-protocol-c.
---
gnu/packages/messaging.scm | 8 ++++++++
1 file changed, 8 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index f890ad8dd5..b56a3e92cb 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1627,6 +1627,11 @@ are both supported).")
(base32
"0nxh81j8ky0fzv47pip1jb7rs5rrin3jx0f3h632bvpjiya45r1z"))))
(build-system gnu-build-system)
+ (arguments
+ '(#:configure-flags
+ (list "--enable-omemo"
+ "--enable-icons"
+ "--enable-notifications")))
(inputs
`(("curl" ,curl)
("expat" ,expat)
@@ -1642,7 +1647,10 @@ are both supported).")
("autoconf-archive" ,autoconf-archive)
("automake" ,automake)
("cmocka" ,cmocka)
+ ("gtk+" ,gtk+-2)
+ ("libnotify" ,libnotify)
("libtool" ,libtool)
+ ("libsignal-protocol-c" ,libsignal-protocol-c)
("pkg-config" ,pkg-config)))
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 23:11
[PATCH v3 3/4] gnu: profanity: Add configure flags, so that build fail if libs are missing.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026211110.2595-3-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-c-plugins and --enable-otr.
---
gnu/packages/messaging.scm | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 63b14287ce..626aec4908 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1629,7 +1629,9 @@ are both supported).")
(build-system gnu-build-system)
(arguments
'(#:configure-flags
- (list "--enable-omemo"
+ (list "--enable-c-plugins"
+ "--enable-otr"
+ "--enable-omemo"
"--enable-icons"
"--enable-notifications")))
(inputs
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 23:11
[PATCH v3 2/4] gnu: profanity: Update home-page URL.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026211110.2595-2-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[home-page]: Update URL.
---
gnu/packages/messaging.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index b56a3e92cb..63b14287ce 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1655,7 +1655,7 @@ are both supported).")
(synopsis "Console-based XMPP client")
(description "Profanity is a console based XMPP client written in C
using ncurses and libmesode, inspired by Irssi.")
- (home-page "http://www.profanity.im")
+ (home-page "https://profanity-im.github.io")
(license license:gpl3+)))
(define-public libircclient
--
2.23.0
T
T
tanguy wrote on 26 Oct 2019 23:11
[PATCH v3 4/4] gnu: profanity: Add configure flags for better defaults.
(address . 37923@debbugs.gnu.org)(address . tanguy@bioneland.org)
20191026211110.2595-4-tanguy@bioneland.org
From: Tanguy Le Carrour <tanguy@bioneland.org>

* gnu/packages/messaging.scm (profanity)[arguments]<#configure-flags>:
Add --enable-pgp.
---
gnu/packages/messaging.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 626aec4908..a6e9dcbbb3 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -1632,6 +1632,7 @@ are both supported).")
(list "--enable-c-plugins"
"--enable-otr"
"--enable-omemo"
+ "--enable-pgp"
"--enable-icons"
"--enable-notifications")))
(inputs
--
2.23.0
M
M
Mathieu Othacehe wrote on 28 Oct 2019 11:31
Re: [bug#37923] [PATCH v3 1/4] gnu: profanity: Add configure flags and inputs for better defaults.
(address . guix-patches@gnu.org)
87v9s9yxec.fsf@gmail.com
Hello Tanguy,

Pushed with minor changes in commit log and title.

Thanks,

Mathieu
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37923@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37923
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch