gnu: meld: Fix startup

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Leo Prikler
Owner
unassigned
Submitted by
Leo Prikler
Severity
normal

Debbugs page

Leo Prikler wrote 5 years ago
(address . guix-patches@gnu.org)
3b9ad3a65c0b37c02e7d54131d0d683195276119.camel@student.tugraz.at
It was reported in IRC, that Meld is having troubles starting up. After
some building on my own I've decided to fix it.

Caveat: Running `guix build meld` followed by `/gnu/store/.../bin/meld`
will lead to a crash -- it seems GSettings is having some trouble.
`guix environment --ad-hoc meld` should work, though.

Regards,

Leo
From d0b647ac2b038e8bed5b99fa8dd4a70b4b4be357 Mon Sep 17 00:00:00 2001
From: Leo Prikler <leo.prikler@student.tugraz.at>
Date: Fri, 25 Oct 2019 11:01:50 +0200
Subject: [PATCH] gnu: meld: Fix startup.

* /gnu/packages/patchutils.scm: (meld)[inputs]: Use gtksourceview-3.
[arguments]<#:phases>: Add 'wrap-typelib'.
---
gnu/packages/patchutils.scm | 11 +++++++++--
1 file changed, 9 insertions(+), 2 deletions(-)

Toggle diff (31 lines)
diff --git a/gnu/packages/patchutils.scm b/gnu/packages/patchutils.scm
index a63d889cff..4cd6bbbf48 100644
--- a/gnu/packages/patchutils.scm
+++ b/gnu/packages/patchutils.scm
@@ -265,7 +265,7 @@ GiB).")
(inputs
`(("python-cairo" ,python-pycairo)
("python-gobject" ,python-pygobject)
- ("gtksourceview" ,gtksourceview)))
+ ("gtksourceview" ,gtksourceview-3)))
(propagated-inputs
`(("dconf" ,dconf)))
(arguments
@@ -292,7 +292,14 @@ GiB).")
(setenv "HOME" "/tmp")
(invoke "py.test" "-v" "-k"
;; TODO: Those tests fail, why?
- "not test_classify_change_actions"))))))
+ "not test_classify_change_actions")))
+ (add-after 'wrap 'wrap-typelib
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (wrap-program (string-append out "/bin/meld")
+ `("GI_TYPELIB_PATH" prefix
+ ,(search-path-as-string->list (getenv "GI_TYPELIB_PATH"))))
+ #t))))))
(home-page "https://meldmerge.org/")
(synopsis "Compare files, directories and working copies")
(description "Meld is a visual diff and merge tool targeted at
--
2.23.0
Danny Milosavljevic wrote 5 years ago
(name . Leo Prikler)(address . leo.prikler@student.tugraz.at)(address . 37918-done@debbugs.gnu.org)
20191027105357.4c5994e7@scratchpost.org
Hi,

On Fri, 25 Oct 2019 11:17:26 +0200
Leo Prikler <leo.prikler@student.tugraz.at> wrote:

Toggle quote (4 lines)
> Caveat: Running `guix build meld` followed by `/gnu/store/.../bin/meld`
> will lead to a crash -- it seems GSettings is having some trouble.
> `guix environment --ad-hoc meld` should work, though.

Thanks! I've pushed this fix since it's already improving things a lot!

It might make sense to investigate the other problem as well.
Could you open a bug about that by E-Mailing to bug-guix@gnu.org ?
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl21aTUACgkQ5xo1VCww
uqXwIAf/VwDicaKjIxiri7UeH1qglYBBltSessN5slCsvaPTALAoPBq4M4KOpc1F
1VKFHUW84sYipixNxwsY/qBZxGbQvgD+1s3U7QmLs7/tRM0/NaYZSvKxIe9QG4oy
lmPP1jCIjNZ0cNTEnc8/zvse1phot2avgK96i+8qtWn3kAFdJwmE6Y/Y8poBY8Sb
T5guVl8Lex1gzhCDo5LH7d6LyaxOIzOcQ9jvbVlziDk4oxMzF2SM7jQsnzMxbR/7
L8/l5xvKkimkdxm+cwpXksyFB8zEzgg+W3/5lnCHYey7VfXQ1jmk7F0qhDkqgJH4
s33KO8V/5WYChAgzbHcJQc8b/uN0cw==
=2ONP
-----END PGP SIGNATURE-----


Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37918@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37918
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help