Kyle Andrews wrote 5 years ago
(address . guix-patches@gnu.org)
Hi Guix,
I am working my way through installing Guix on a system using the
"manual" method and wanted to help improve the documentation.
I find it difficult to read bash commands which make use of cryptic
short argument flags, so I have taken the liberty of replacing one such
instance of that in the manual with a human readable equivalent.
Also, following, the principle of parallel construction I included an
example of how to bring a network device up using ip in addition to
ifconfig.
Please see the patch below:
Toggle snippet (48 lines)
From ff3c71cad60c50812bdf6d561a24ed59fb2e26bc Mon Sep 17 00:00:00 2001
From: Kyle Andrews <kyle.c.andrews@gmail.com>
Date: Wed, 23 Oct 2019 23:24:11 -0400
Subject: [PATCH] * doc/guix: Use human readable arguments for ip command.
---
doc/guix.texi | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)
diff --git a/doc/guix.texi b/doc/guix.texi
index 6703c2756c..ff12a1bb51 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -66,6 +66,7 @@ Copyright @copyright{} 2019 Josh Holland@*
Copyright @copyright{} 2019 Diego Nicola Barbato@*
Copyright @copyright{} 2019 Ivan Petkov@*
Copyright @copyright{} 2019 Jakob L. Kreuze@*
+Copyright @copyright{} 2019 Kyle Andrews@*
Permission is granted to copy, distribute and/or modify this document
under the terms of the GNU Free Documentation License, Version 1.3 or
@@ -2110,7 +2111,7 @@ ifconfig -a
@dots{} or, using the GNU/Linux-specific @command{ip} command:
@example
-ip a
+ip address
@end example
@c https://cgit.freedesktop.org/systemd/systemd/tree/src/udev/udev-builtin-net_id.c#n20
@@ -2128,6 +2129,13 @@ To configure a wired network run the following command, substituting
ifconfig @var{interface} up
@end example
+@noindent
+@dots{} or, using the GNU/Linux-specific @command{ip} command:
+
+@example
+ip link set @var{interface} up
+@end example
+
@item Wireless connection
@cindex wireless
@cindex WiFi
--
2.23.0