Trivial rust 1.37.0-compiled program immediately segfaults on newest master

  • Done
  • quality assurance status badge
Details
2 participants
  • Danny Milosavljevic
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 5 years ago
(address . bug-guix@gnu.org)
20191015181054.3042fe5c@scratchpost.org
$ cat b.rs
fn main() {
}
$ rustc b.rs
$ ./b
Segmentation fault
$ gdb ./b
(gdb) r
(gdb) bt
#0 0x00007ffff7fe40f8 in call_init.part () from /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
#1 0x00007ffff7fe428e in _dl_init () from /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
#2 0x00007ffff7fd624a in _dl_start_user () from /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
#3 0x0000000000000001 in ?? ()
#4 0x00007fffffffdfa1 in ?? ()
#5 0x0000000000000000 in ?? ()
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl2l744ACgkQ5xo1VCww
uqV/Owf/en9Jx6sqpSZp+AtVvPyxLfG7kSB5fO7GeQrXf7qpGH3klDHBH0o4VOoO
HDZQKJqJ/43G9T4ztZqEKfTxY4ophOqwgCSSq+023HALp1UVHRjuLxE6bRbZtybd
YDZ4DMXC8WQoxuy7NCZdQpAN7cPTnbMQb5gxLJw/DFwAV3Ab5eXVTdt/lwLUG78j
kKNOALhwrJsBUn/UkOLWABaptoXSScKzZdCUyNaOGKia9vtWrlWdR3CQJdTxwPwc
z/Qp2SuGZg+37Y7j0F6QCT0BFCzyTYBk89t7NlG4rMePwjIdXC3N6VCD+mtn27QT
zvg0Tl0Dw5VjJwjBqV5BeEKsw0KVHw==
=STH0
-----END PGP SIGNATURE-----


Danny Milosavljevic wrote 5 years ago
(address . 37765@debbugs.gnu.org)
20191015181811.29f0fd70@scratchpost.org
Generation 28 Oct 14 2019 20:42:05 (current)
guix dc505e3
branch: master
commit: dc505e3eb88faf3c952aa1de4a12a42111c3742c
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEds7GsXJ0tGXALbPZ5xo1VCwwuqUFAl2l8UMACgkQ5xo1VCww
uqXZ2Af/Ronm+KsXFYGNo32EZUc+1RYPgRo6XzGhRkNef1mQQLfWrLOrOVviI3rQ
NGu4tK78Vhf5wyvr95Ib49ssIyAKP8DdpPHg4hs4M7Y3LgXsFwrZL+Eg4fZfIBZG
m48n78C1ndlRlWSNN4AF21zYgXmxRuCvwYIi6suacKZuxz8T+iY+k/bQVjjB1eu5
dSfgsuEOPcn9VlqJRxtXyp24kKozoEp4nhJVb1quncgcwJbwbY5IWWPcuvZlSuGn
NUAcKfjQ9kd9nB0zIrR580Ui0p3zm5OdOh44m/n0NcOJH/3POP4GJQQA6Nfdg9NZ
Z7HkTUbDkJvNjW4Cu15WguoH98FNTw==
=zHDk
-----END PGP SIGNATURE-----


Maxim Cournoyer wrote 3 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 37765-done@debbugs.gnu.org)
87o7xt16x9.fsf@gmail.com
Hi,

Danny Milosavljevic <dannym@scratchpost.org> writes:

Toggle quote (19 lines)
> $ cat b.rs
> fn main() {
> }
> $ rustc b.rs
> $ ./b
> Segmentation fault
> $ gdb ./b
> (gdb) r
> (gdb) bt
> #0 0x00007ffff7fe40f8 in call_init.part () from
> /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> #1 0x00007ffff7fe428e in _dl_init () from
> /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> #2 0x00007ffff7fd624a in _dl_start_user () from
> /gnu/store/ahqgl4h89xqj695lgqvsaf6zh2nhy4pj-glibc-2.29/lib/ld-linux-x86-64.so.2
> #3 0x0000000000000001 in ?? ()
> #4 0x00007fffffffdfa1 in ?? ()
> #5 0x0000000000000000 in ?? ()

I can't reproduce this on current master with Rust 1.57.

Closing.

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37765@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37765
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help