Hi Ludo,
Sure, here is a minimal operating system configuration that we used for a
minimal LXQt desktop on Guix:
```
(use-modules (gnu) (gnu system nss) (gnu packages kde-plasma))
(use-service-modules desktop networking ssh sddm dbus)
(use-package-modules ssh certs tls lxqt xorg)
(operating-system
(host-name "panther")
(timezone "Asia/Tehran")
(locale "en_US.utf8")
;; Boot in "legacy" BIOS mode
(bootloader (bootloader-configuration
(bootloader grub-bootloader)
(target "/dev/sda")))
(file-systems (cons (file-system
(device (file-system-label "my-root"))
(mount-point "/")
(type "ext4"))
%base-file-systems))
(users (cons (user-account
(name "user")
(password "1234")
(group "users")
(supplementary-groups '("wheel" "audio" "video"))
(home-directory "/home/user"))
%base-user-accounts))
(packages (cons* openssh nss-certs gnutls
lxqt lxqt-globalkeys
;; commented in order to re-produce the issue
; libkscreen
%base-packages))
(services (cons*
(sddm-service
(sddm-configuration
(minimum-uid 1000)
(theme "elarun")))
(elogind-service)
(udisks-service)
(dbus-service)
(colord-service)
(service polkit-service-type)
(service upower-service-type)
(service dhcp-client-service-type)
;; network configuration
(service openssh-service-type
(openssh-configuration
(port-number 22)
(permit-root-login #t)
(authorized-keys
`(("panther" ,(local-file "/etc/vagrant.pub"))
("root" ,(local-file "/etc/vagrant.pub"))))))
(service wpa-supplicant-service-type)
%base-services))
;; Allow resolution of '.local' host names with mDNS.
(name-service-switch %mdns-host-lookup-nss))
```
the issue occurs when I try to execute `lxqt-config-monitor`.
here is also the GDB backtrace log that I received during application crash:
```
root@panther /home/panther# cat monitor.txt
Starting program: /gnu/store/k09wlkkmllwyr5d41bzn2mn9kvylgszr-profile/bin/lxqt-config-monitor
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/gnu/store/h90vnqw0nwd0hhm1l5dgxsdrigddfmq4-glibc-2.28/lib/libthread_db.so.1".
[New Thread 0x7ffff3bfb700 (LWP 860)]
[New Thread 0x7ffff32d4700 (LWP 861)]
[Detaching after fork from child process 862]
[New Thread 0x7fffea615700 (LWP 863)]
[New Thread 0x7fffe9e14700 (LWP 864)]
[New Thread 0x7fffe9613700 (LWP 865)]
[New Thread 0x7fffe8e12700 (LWP 866)]
Thread 1 "lxqt-config-mon" received signal SIGSEGV, Segmentation fault.
0x00007ffff7fa1b01 in KScreen::GetConfigOperation::start() ()
from /gnu/store/ds7ib4ndgy48ac0hxrrsgc6xc4lsccva-libkscreen-5.15.1/lib/libKF5Screen.so.7
#0 0x00007ffff7fa1b01 in KScreen::GetConfigOperation::start() ()
from /gnu/store/ds7ib4ndgy48ac0hxrrsgc6xc4lsccva-libkscreen-5.15.1/lib/libKF5Screen.so.7
#1 0x00007ffff7fbe48d in KScreen::ConfigOperation::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) ()
from /gnu/store/ds7ib4ndgy48ac0hxrrsgc6xc4lsccva-libkscreen-5.15.1/lib/libKF5Screen.so.7
#2 0x00007ffff6f28ad1 in QObject::event(QEvent*) () from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#3 0x00007ffff788214c in QApplicationPrivate::notify_helper(QObject*, QEvent*) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Widgets.so.5
#4 0x00007ffff7889280 in QApplication::notify(QObject*, QEvent*) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Widgets.so.5
#5 0x00007ffff6efd4f8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#6 0x00007ffff6efff2b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#7 0x00007ffff6f51643 in ?? () from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#8 0x00007ffff43ddb57 in g_main_context_dispatch () from /gnu/store/cgy82g6yv8l1chawgch47zh23b0jll3l-glib-2.56.3/lib/libglib-2.0.so.0
#9 0x00007ffff43ddd98 in g_main_context_iterate.isra () from /gnu/store/cgy82g6yv8l1chawgch47zh23b0jll3l-glib-2.56.3/lib/libglib-2.0.so.0
#10 0x00007ffff43dde3c in g_main_context_iteration () from /gnu/store/cgy82g6yv8l1chawgch47zh23b0jll3l-glib-2.56.3/lib/libglib-2.0.so.0
#11 0x00007ffff6f50caf in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#12 0x00007ffff3deb3c1 in ?? ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/qt5/plugins/platforms/../../../libQt5XcbQpa.so.5
#13 0x00007ffff6efbe4a in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) ()
from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#14 0x00007ffff6f04740 in QCoreApplication::exec() () from /gnu/store/ahyi57vlk48cmzsvxjwhxlxg2fdhxl9w-qtbase-5.11.3/lib/libQt5Core.so.5
#15 0x000000000040f92c in main ()
Quit
quit
```
Best,
Reza
On Fri, Oct 18, 2019, at 1:24 PM, Ludovic Courtès wrote:
Toggle quote (38 lines)
> Hi Reza,
>
> "Reza Alizadeh Majd" <r.majd@pantherx.org> skribis:
>
> > maybe I could describe better about this patch file.
> >
> > `libkscreen` is used by `lxqt-config-monitor` to modify
> > the desktop resolution in LXQt desktop.
> >
> > the problem is that, during execution of `lxqt-config-monitor`
> > application crashes with "segmentation fault".
> >
> > we had a review over `lxqt-config-monitor` source code,
> > but didn't find any unusual usage of `ksceen` library. just
> > a normal link during build process and binaries were made
> > successfully.
> >
> > this issue might because of crash inside `libkscreen`, but we
> > didn't review that yet.
> >
> > so as a quick workaround we find that adding the `libkscreen`
> > as a propagated input could fix this issue.
>
> Thanks for explaining, I understand better now.
>
> I think that it’s not satisfying to apply a workaround that we don’t
> understand. That is, intuitively, I see now reason why propagating
> libkscreen would “fix” a segfault.
>
> Could you either (1) provide an ‘operating-system’ config and
> instructions to reproduce the problem, or (2) grab a backtrace of the
> segfaulted program with GDB?
>
> Let us know if you need guidance.
>
> Thanks,
> Ludo’.
>