[PATCH] Add gnome-mahjongg.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Wilson
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Wilson
Severity
normal

Debbugs page

David Wilson wrote 5 years ago
(address . guix-patches@gnu.org)
269fdb5f-7d0e-4f2f-947d-eea43515c5df@www.fastmail.com
Hi fellow Guixers,

Here's a patch to add the (highly addictive) game Gnome Mahjongg. Please let me know if there's any way this package definition can be improved!

Happy hacking,

David
From a589ef5124d265b9c0fb646b35e8efe852b74855 Mon Sep 17 00:00:00 2001
From: David Wilson <david@daviwil.com>
Date: Sat, 12 Oct 2019 09:07:11 -0700
Subject: [PATCH] gnu: Add gnome-mahjongg.

* gnu/packages/gnome.scm (gnome-mahjongg) New variable.
---
gnu/packages/gnome.scm | 37 +++++++++++++++++++++++++++++++++++++
1 file changed, 37 insertions(+)

Toggle diff (54 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 91a781bfba..ce58ff4006 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2019 Jonathan Frederickson <jonathan@terracrypt.net>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019 Martin Becze <mjbecze@riseup.net>
+;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -8394,3 +8395,39 @@ access library. It only implements the core plumbing functions, not really the
higher level porcelain stuff.")
(home-page "https://wiki.gnome.org/Projects/Libgit2-glib")
(license license:gpl2+)))
+
+(define-public gnome-mahjongg
+ (package
+ (name "gnome-mahjongg")
+ (version "3.35.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.gnome.org/GNOME/gnome-mahjongg.git")
+ (commit version)))
+ (sha256
+ (base32
+ "019a66a4m5w4kkb0sm6gxj0wi54n06zdxdlmyqw7h8kbakjizv7l"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:glib-or-gtk? #t))
+ (native-inputs
+ `(("appstream-glib" ,appstream-glib)
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ;; For glib-compile-resources
+ ("gtk+" ,gtk+ "bin") ;; For gtk-update-icon-cache
+ ("itstool" ,itstool)
+ ("pkg-config" ,pkg-config)
+ ("vala" ,vala)))
+ (propagated-inputs
+ `(("dconf" ,dconf)))
+ (inputs
+ `(("glib" ,glib)
+ ("gtk+" ,gtk+)
+ ("librsvg" ,librsvg)))
+ (synopsis "Mahjongg tile-matching game")
+ (description "Gnome Mahjongg is a game based on the classic Chinese tile-
+matching game Mahjong. It features multiple board layouts, tile themes, and a
+high score table.")
+ (home-page "https://wiki.gnome.org/Apps/Mahjongg")
+ (license license:gpl2)))
--
2.23.0
Ludovic Courtès wrote 5 years ago
(name . David Wilson)(address . david@daviwil.com)(address . 37718-done@debbugs.gnu.org)
871rvew6cx.fsf@gnu.org
Hi David,

"David Wilson" <david@daviwil.com> skribis:

Toggle quote (7 lines)
> From a589ef5124d265b9c0fb646b35e8efe852b74855 Mon Sep 17 00:00:00 2001
> From: David Wilson <david@daviwil.com>
> Date: Sat, 12 Oct 2019 09:07:11 -0700
> Subject: [PATCH] gnu: Add gnome-mahjongg.
>
> * gnu/packages/gnome.scm (gnome-mahjongg) New variable.

Applied with the following changes, thanks!

Ludo’.
Toggle diff (24 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81566e6e42..99cd7a7cb6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8406,6 +8406,7 @@ higher level porcelain stuff.")
(uri (git-reference
(url "https://gitlab.gnome.org/GNOME/gnome-mahjongg.git")
(commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
"019a66a4m5w4kkb0sm6gxj0wi54n06zdxdlmyqw7h8kbakjizv7l"))))
@@ -8427,8 +8428,8 @@ higher level porcelain stuff.")
("gtk+" ,gtk+)
("librsvg" ,librsvg)))
(synopsis "Mahjongg tile-matching game")
- (description "Gnome Mahjongg is a game based on the classic Chinese tile-
-matching game Mahjong. It features multiple board layouts, tile themes, and a
-high score table.")
+ (description "GNOME Mahjongg is a game based on the classic Chinese
+tile-matching game Mahjong. It features multiple board layouts, tile themes,
+and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
(license license:gpl2)))
Closed
Ludovic Courtès wrote 5 years ago
(name . David Wilson)(address . david@daviwil.com)(address . 37718@debbugs.gnu.org)
87wod6urnl.fsf@gnu.org
Oops, and this change too:
Toggle diff (10 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 99cd7a7cb6..81cb2fb37f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8432,4 +8432,4 @@ higher level porcelain stuff.")
tile-matching game Mahjong. It features multiple board layouts, tile themes,
and a high score table.")
(home-page "https://wiki.gnome.org/Apps/Mahjongg")
- (license license:gpl2)))
+ (license license:gpl2+)))
… because source file headers carry the “or any later version” wording.

Ludo’.
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37718@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37718
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help