[core-updates] simple-scan fails to build

  • Done
  • quality assurance status badge
Details
3 participants
  • Björn Höfling
  • Jack Hill
  • Tobias Geerinckx-Rice
Owner
unassigned
Submitted by
Björn Höfling
Severity
normal
Merged with

Debbugs page

Björn Höfling wrote 5 years ago
(address . bug-guix@gnu.org)
20191009125726.32cc6098@alma-ubu
After the core-updates merge, simplescan fails to build:
This is on:

525ef21ba0d4a50a7d21f5543db40b6cc328f9cd


starting phase
`build' Making all in src
make[1]: Entering directory '/tmp/guix-build-simple-scan-3.24.1.drv-0/simple-scan-3.24.1/src'
CC simple_scan-book.o
CC simple_scan-book-view.o
CC simple_scan-page.o
CC simple_scan-page-view.o
CC simple_scan-simple-scan.o
CC simple_scan-scanner.o
make[2]: Entering directory '/tmp/guix-build-simple-scan-3.24.1.drv-0/simple-scan-3.24.1/src'
VALAC simple_scan_vala.stamp
CC simple_scan-autosave-manager.o
CC simple_scan-resources.o
page.vala:90.5-90.39: error: Property `Page.scan_direction' with custom `get' accessor and/or `set' mutator cannot have `default' value
public ScanDirection scan_direction
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
ui.vala:1295.25-1295.80: warning: Gtk.Arrow.new has been deprecated since 3.14
ui.vala:1867.13-1867.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1868.13-1868.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1869.13-1869.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1870.13-1870.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1871.13-1871.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1872.13-1872.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1873.13-1873.31: warning: Gtk.Application.add_accelerator has been deprecated since 3.14
ui.vala:1019.9-1019.23: warning: Gtk.Menu.popup has been deprecated since 3.22
simple-scan.vala:130.30-130.41: error: Argument 1: Cannot convert from `unowned GLib.List<weak ScanDevice>' to `unowned GLib.List<ScanDevice>'
ui.set_scan_devices (devices_copy, missing_driver);
^^^^^^^^^^^^
Compilation failed: 2 error(s), 9 warning(s)
make[2]: *** [Makefile:655: simple_scan_vala.stamp] Error 1
make[2]: Leaving directory '/tmp/guix-build-simple-scan-3.24.1.drv-0/simple-scan-3.24.1/src'
make[1]: *** [Makefile:645: ui.c] Error 2
make[1]: *** Waiting for unfinished jobs....
make[1]: Leaving directory '/tmp/guix-build-simple-scan-3.24.1.drv-0/simple-scan-3.24.1/src'
make: *** [Makefile:399: all-recursive] Error 1
command "make" "-j" "4" "gtk_update_icon_cache=true" failed with status 2


Björn
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXZ29FgAKCRC/KGy2WT5f
/XR/AKC29cOticxmv03H8R8Yr2Id/SM6TgCfRi/XJ+veZFApl32hYnq+rxehgaY=
=VX+5
-----END PGP SIGNATURE-----


Jack Hill wrote 5 years ago
simple-scan builds with newer version
(address . 37680@debbugs.gnu.org)
alpine.DEB.2.20.1910101247280.7762@marsh.hcoop.net
The version of simple-scan that current in Guix, 3.24.1, which fails to
build is a little old. I tried to update it to the version that
numerically matches our GNOME version, 3.30.2, but that fails with the
same problem.

However, the current newest simple-scan release, 3.34.1, does build.
Unfortunately, I had to take the colord out of inputs or native inputs
otherwise the build would fail with

"error: Package `colord' not found in specified Vala API directories or
GObject-Introspection GIR directories"

and I didn't see how it was detecting colord during configure, but not
during the build. The needs to be fixed eventually, but in the meantime I
have prepared the following patch.

A bigger problem than colord though, is that while simple-scan now builds,
it doesn't run. It exits after printing "Trace/breakpoint trap". I've
attached strace output.

I'm not sure what's next, thoughts?

Best,
Jack
Attachment: simple-scan.strace
Jack Hill wrote 5 years ago
[PATCH] gnu: simple-scan: Update to 3.34.1
(address . 37680@debbugs.gnu.org)(name . Jack Hill)(address . jackhill@jackhill.us)
20191010172354.31934-1-jackhill@jackhill.us
* gnu/package/gnome.scm (simple-scan): Update to 3.34.1
[build-system]: Switch to meson-build-system.
[source]: Fetch from GNOME mirrors.
[inputs]: Add libwebp.
[native-inputs]: Remove colord.
[arguments]: Remove #:configure-flags. Remove 'clean phase.
[home-page]: Update to current home-page.
---
gnu/packages/gnome.scm | 35 +++++++++++------------------------
1 file changed, 11 insertions(+), 24 deletions(-)

Toggle diff (66 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index eae62a1d06..1956a672a3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4302,48 +4302,35 @@ USB transfers with your high-level application or system daemon.")
(define-public simple-scan
(package
(name "simple-scan")
- (version "3.24.1")
+ (version "3.34.1")
(source (origin
(method url-fetch)
- (uri (string-append "https://launchpad.net/simple-scan/"
+ (uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
- version "/+download/simple-scan-"
- version ".tar.xz"))
+ name "-" version ".tar.xz"))
(sha256
(base32
- "1czg21cdbd2fgqylxfnzfhhzy69gycf816d5bbaq6hb62hmq7bjy"))))
- (build-system glib-or-gtk-build-system)
+ "0glzskxdc7p9z7nwcakqc7qzij4l79adlvvb2cj5fmis731zw9yq"))))
+ (build-system meson-build-system)
(inputs
`(("gtk" ,gtk+)
("zlib" ,zlib)
("cairo" ,cairo)
+ ;; Building with colord support fails with
+ ;; error: Package `colord' not found in specified Vala API directories or GObject-Introspection GIR directories
+ ;; ("colord-gtk" ,colord-gtk)
("gdk-pixbuf" ,gdk-pixbuf)
("gusb" ,gusb)
- ("libsane" ,sane-backends)))
+ ("libsane" ,sane-backends)
+ ("libwebp" ,libwebp)))
(native-inputs
`(("gettext" ,gettext-minimal)
("itstool" ,itstool)
- ("colord" ,colord)
("glib" ,glib "bin") ; glib-compile-schemas, etc.
("pkg-config" ,pkg-config)
("vala" ,vala)
("xmllint" ,libxml2)))
- (arguments
- '(#:configure-flags '("--disable-packagekit")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'clean
- (lambda _
- ;; Remove a left-over reference to PackageKit.
-
- ;; https://bugs.launchpad.net/simple-scan/+bug/1462769
-
- ;; There are some generated C files erroneously
- ;; included in the source distribution, and this
- ;; one breaks the build by referring to a
- ;; non-existent header (packagekit.h)
- (delete-file "src/ui.c"))))))
- (home-page "https://launchpad.net/simple-scan")
+ (home-page "https://gitlab.gnome.org/GNOME/simple-scan")
(synopsis "Document and image scanner")
(description "Simple Scan is an easy-to-use application, designed to let
users connect their scanner and quickly have the image/document in an
--
2.23.0
Björn Höfling wrote 5 years ago
merge simple-scan
(address . control@debbugs.gnu.org)
20191010213656.5e8cdd0f@alma-ubu
merge 37680 37687
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXZ+IWAAKCRC/KGy2WT5f
/aW2AJ0bc6eBQT2zEUjhD6KXrCICq9I1rQCgkZU/EFY/zWE7LDTwJD1/m/QtboQ=
=5tIN
-----END PGP SIGNATURE-----


Björn Höfling wrote 5 years ago
Re: bug#37680: simple-scan builds with newer version
(name . Jack Hill)(address . jackhill@jackhill.us)(address . 37680@debbugs.gnu.org)
20191010214540.76d12fb8@alma-ubu
Hi Jack,

thanks for looking into this.

On Thu, 10 Oct 2019 13:22:50 -0400 (EDT)
Jack Hill <jackhill@jackhill.us> wrote:

Toggle quote (9 lines)
> The version of simple-scan that current in Guix, 3.24.1, which fails
> to build is a little old. I tried to update it to the version that
> numerically matches our GNOME version, 3.30.2, but that fails with
> the same problem.
>
> However, the current newest simple-scan release, 3.34.1, does build.
> Unfortunately, I had to take the colord out of inputs or native
> inputs otherwise the build would fail with

I was also quickly trying out the same things you did and came to the
same conclusion. I hoped to find a way around today, but I don't know
the meson-build-system and have no futher idea.

[..]

Toggle quote (4 lines)
> A bigger problem than colord though, is that while simple-scan now
> builds, it doesn't run. It exits after printing "Trace/breakpoint
> trap". I've attached strace output.

Oh, sounds bad. I haven't tried to run it.
Toggle quote (2 lines)
> I'm not sure what's next, thoughts?

No.

Björn
-----BEGIN PGP SIGNATURE-----

iF0EARECAB0WIQQiGUP0np8nb5SZM4K/KGy2WT5f/QUCXZ+KZAAKCRC/KGy2WT5f
/agTAKC8fhGbvNDIyo5YeB5O35wzGDBkCgCcDpKIbOl229WAm3thC4neY+NVcNQ=
=ZWbK
-----END PGP SIGNATURE-----


Tobias Geerinckx-Rice wrote 5 years ago
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87d0enh9of.fsf@nckx
merge 37680 37885
merge 37680 37715
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEfo+u0AlEeO9y5k0W2Imw8BjFSTwFAl2wVdAACgkQ2Imw8BjF
STyOvg/8De9vJq6NebDKHnP4NIu+siAo+5gtnlcgVMO1e+MzF75q8vSQGmr5VBEr
VDKk4uYztVFACllLZdc6b8heViDOHk8NpIfw2Bc+WNq+8TOLSpkLCJxPPhWX2bBk
Pwxbq5WKK72MqbgXsb5aXPV79zPVVKABg1oFWSEvAfjRk01xnR/NXXSSclRsE5jU
2dQ48gPzkY4AqiG5zTb/2aYS/G+UcE0dvf0ryf5+SExrKgLTvLucC9udp49Olj+o
R8O44ofkuNlDUPzOGwt2g94w9H3pYEw2/XxhB20Wwy2RW5iF4FcEVOuLO7MG8mMe
ub2x7TrzLjhLFpQ0Tg/ASvUWU1COuVrw0dmUqOVJlu/Qy/MoJIj/lNP8w76bct9N
Dg5GVGQ02ASrOyYrFX0Z69a/1/m3D2zwBd7gn46e99y9CO49OrRj+rchRKJAnlcc
TFi2QSzHTI1NYG/cFvDe2sqYh0K8pdqSlXgirNJ4pgeWKlBoGylnAbDaf5flFJzM
fQ/WF2TICt29tT9xO3P5qZ88o9euXvY7M42uwzPocXjDgD94/txcA5X5DkYJdHdD
QyjKs+ZuErIbRj5mZ3pHljH98v4euAB3zB8VZQq0DHB8lbJfukKBP83aDmniFM2P
8f0I4vuDnI9TBIVq3IQw4QZDYYdu5rWwhUMW9v+XIr68hfRD8Fo=
=feiy
-----END PGP SIGNATURE-----

?
Your comment

This issue is archived.

To comment on this conversation send an email to 37680@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37680
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help