[PATCH] gnu: Add r-httpcode.

  • Done
  • quality assurance status badge
Details
2 participants
  • Marius Bakke
  • Wiktor ?elazny
Owner
unassigned
Submitted by
Wiktor ?elazny
Severity
normal
W
W
Wiktor ?elazny wrote on 3 Oct 2019 15:46
(address . guix-patches@gnu.org)
20191003134637.7040-1-wz@freeshell.de
From: Wiktor ?elazny <wzelazny@vurv.cz>

* gnu/packages/cran.scm (r-httpcode): New variable.
---
gnu/packages/cran.scm | 19 +++++++++++++++++++
1 file changed, 19 insertions(+)

Toggle diff (29 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 3a9a605efe..8d94047475 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -15637,3 +15637,22 @@ unique identifiers, and whether it is a certain length. In addition,
files and to efficiently import multiple tabular data files into one
data.table.")
(license license:gpl3)))
+
+(define-public r-httpcode
+ (package
+ (name "r-httpcode")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "httpcode" version))
+ (sha256
+ (base32
+ "06k853ihwzkcx4z3jzazpb03p91frqkwz18jy4fwr8j2nwyqbhgv"))))
+ (build-system r-build-system)
+ (home-page "https://github.com/sckott/httpcode")
+ (synopsis "HTTP status code helper")
+ (description "@code{httpcode} provides functionality for finding and
+explaining the meaning of @code{HTTP} status codes. Functions are included for
+searching for codes by full or partial number, by message, and to get
+appropriate dog and cat images for many status codes.")
+ (license license:expat)))
--
2.23.0
M
M
Marius Bakke wrote on 21 Mar 2020 21:12
87eetl5uwu.fsf@devup.no
Wiktor ?elazny <wz@freeshell.de> writes:

Toggle quote (4 lines)
> From: Wiktor ?elazny <wzelazny@vurv.cz>
>
> * gnu/packages/cran.scm (r-httpcode): New variable.

Applied, thanks!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl52dUEACgkQoqBt8qM6
VPrvqwgAregkqCuhw3tgA1o78JBLZWS4LG0UaPlnEkjdvHxhKyzAp/SIw8K5Gk4j
tzHiAQOPsW/l/iWCUJZgsdqakMf+SGaSLWoWdr/QUF61sgtUM7eP776+6xCUGrfe
9ZUQi0y1CWvWo1U26jwqj9GVfjoFgXwdcoyaLuVmr4F7AGxTrHaLWIDmM9EH2y7R
+ANabOkzVGjSOeO/UdPCBJzyrqY1VyCUQEmL6mKI67vziM33kJ8T2KHcZcNMQQ3A
ieoqFhbtaU8RErRXJbvR4pX4RytqEdlMOdbDVcQzW8w5LfSq7nDteaZPqpnSdhw5
Wt2nTDS2FO4uL0Lrb62/fgd8xw/dUg==
=7NNj
-----END PGP SIGNATURE-----

Closed
?