[PATCH] inferior: Change to using guix-repl.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
20190929130128.18484-1-mail@cbaines.net
Rather than machine-repl, that was removed in [1]. While this could work if
the %load-path is such that a module that defines machine-repl is loaded, I
believe the intent is that the (guix scripts repl) module comes from the Guix
managing the inferior. Therefore, matching the changes in [1], switch to
calling the guix-repl function with the right arguments.

1: 92a4087bf4862d5ba9b77111eba3c68c2a1c4679

* guix/inferior.scm (inferior-pipe): Call guix-repl, rather than machine-repl,
and add necessary arguments.
---
guix/inferior.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/guix/inferior.scm b/guix/inferior.scm
index dcbc954432..7c0143062b 100644
--- a/guix/inferior.scm
+++ b/guix/inferior.scm
@@ -137,7 +137,8 @@ it's an old Guix."
`(begin
(primitive-load ,(search-path %load-path
"guix/scripts/repl.scm"))
- ((@ (guix scripts repl) machine-repl))))))
+ ((@ (guix scripts repl) guix-repl)
+ "-t" "machine")))))
pipe)))
(define* (port->inferior pipe #:optional (close close-port))
--
2.23.0
Christopher Baines wrote 5 years ago
[PATCH] inferior: Change to use the (guix repl) module.
(address . 37553@debbugs.gnu.org)
20190929152004.20467-1-mail@cbaines.net
Rather than (guix scripts repl), from which the machine-repl procedure was
removed in [1].

1: 92a4087bf4862d5ba9b77111eba3c68c2a1c4679

* guix/inferior.scm (inferior-pipe): Load (guix repl) rather than (guix
scripts repl).
---
guix/inferior.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/guix/inferior.scm b/guix/inferior.scm
index dcbc954432..dcffb7b4ab 100644
--- a/guix/inferior.scm
+++ b/guix/inferior.scm
@@ -137,7 +137,7 @@ it's an old Guix."
`(begin
(primitive-load ,(search-path %load-path
"guix/scripts/repl.scm"))
- ((@ (guix scripts repl) machine-repl))))))
+ ((@ (guix repl) machine-repl))))))
pipe)))
(define* (port->inferior pipe #:optional (close close-port))
--
2.23.0
Christopher Baines wrote 5 years ago
(address . 37553@debbugs.gnu.org)
20190929155728.27777-1-mail@cbaines.net
Rather than (guix scripts repl), from which the machine-repl procedure was
removed in [1].

1: 92a4087bf4862d5ba9b77111eba3c68c2a1c4679

* guix/inferior.scm (inferior-pipe): Load (guix repl) rather than (guix
scripts repl).
---
guix/inferior.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (17 lines)
diff --git a/guix/inferior.scm b/guix/inferior.scm
index dcbc954432..d6d2053ab8 100644
--- a/guix/inferior.scm
+++ b/guix/inferior.scm
@@ -136,8 +136,8 @@ it's an old Guix."
(object->string
`(begin
(primitive-load ,(search-path %load-path
- "guix/scripts/repl.scm"))
- ((@ (guix scripts repl) machine-repl))))))
+ "guix/repl.scm"))
+ ((@ (guix repl) machine-repl))))))
pipe)))
(define* (port->inferior pipe #:optional (close close-port))
--
2.23.0
Ludovic Courtès wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 37553@debbugs.gnu.org)
87blv0sv2y.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (25 lines)
> Rather than (guix scripts repl), from which the machine-repl procedure was
> removed in [1].
>
> 1: 92a4087bf4862d5ba9b77111eba3c68c2a1c4679
>
> * guix/inferior.scm (inferior-pipe): Load (guix repl) rather than (guix
> scripts repl).
> ---
> guix/inferior.scm | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/guix/inferior.scm b/guix/inferior.scm
> index dcbc954432..d6d2053ab8 100644
> --- a/guix/inferior.scm
> +++ b/guix/inferior.scm
> @@ -136,8 +136,8 @@ it's an old Guix."
> (object->string
> `(begin
> (primitive-load ,(search-path %load-path
> - "guix/scripts/repl.scm"))
> - ((@ (guix scripts repl) machine-repl))))))
> + "guix/repl.scm"))
> + ((@ (guix repl) machine-repl))))))
> pipe)))

This one LGTM!

(Note that this code is only used when spawning an inferior for a
revision that dates back to before ‘guix repl’ existed, so before July
2018.)

Thanks,
Ludo’.
Christopher Baines wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37553-done@debbugs.gnu.org)
87tv8sp8qn.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (31 lines)
> Hi,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Rather than (guix scripts repl), from which the machine-repl procedure was
>> removed in [1].
>>
>> 1: 92a4087bf4862d5ba9b77111eba3c68c2a1c4679
>>
>> * guix/inferior.scm (inferior-pipe): Load (guix repl) rather than (guix
>> scripts repl).
>> ---
>> guix/inferior.scm | 4 ++--
>> 1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/guix/inferior.scm b/guix/inferior.scm
>> index dcbc954432..d6d2053ab8 100644
>> --- a/guix/inferior.scm
>> +++ b/guix/inferior.scm
>> @@ -136,8 +136,8 @@ it's an old Guix."
>> (object->string
>> `(begin
>> (primitive-load ,(search-path %load-path
>> - "guix/scripts/repl.scm"))
>> - ((@ (guix scripts repl) machine-repl))))))
>> + "guix/repl.scm"))
>> + ((@ (guix repl) machine-repl))))))
>> pipe)))
>
> This one LGTM!

Great :) I've pushed it as 2cd599f005bb91ae120a66824b8efbac81a27a69.

Toggle quote (4 lines)
> (Note that this code is only used when spawning an inferior for a
> revision that dates back to before ‘guix repl’ existed, so before July
> 2018.)

Yep, I've been experimenting with loading older revisions in to the Guix
Data Service, and this is one of the issues I came across.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2TqIBfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcI/w/9HFxjNejrBCeamAcjh9toWbKMUx2jN5JVCthVV0mGlU9MHK7/jpHCht7y
8Mq2lFkkWAVCkDRxXvWDiKCjngTIW6GCzNuRpKD1FgM9IbGalEyOI0rY07OLSqsB
9/l0H9ILEhWdfvH/8Iee3uLfpHQVr5LK+Tt5Bk/714X8w+dwPyopFKoXtDXrB2nz
wWYEpsFLY7L0iURKCA3S9jdvJnQ4M5IxyWsWUDgtBZx/390gsepIKfk6g2CLReDV
G0rcC6L+wB43IFju/95QcIB6PbR96/uRF4C8bB7OJ1R22N5UZMBLXc7AeCF+RZWv
eBYmTIg3CBhAxZM/+F7gjxBpEazOeS+pyWYEa02QmyvFl+18LsJxeWqJANce4IhE
jF7lVgAtAaljIoTs1hlnHMrOLwwPGQnfPgjKgAHcTNOTLY++yfLvmInNhm+aBxN4
QZeFBTkrHu3OJyIwVa7WDqzpOcRfFS58K4Q2kQ+qdKRlrjUca5GPsi75b5PI94+R
685wHMRHTq0e0tjgVWi23HsbIxOyNkg/0MJZtsJVo2xHT4q2IUyJJi/wHkxHQMQz
hVoL5BNzadvYznoqoA0jNYR7ScCQPL0U281e6Fj66XKONwtrtOJDilBhW10Eupp4
gkx9A/CYvDXLloKhnRKo9VZAjpcEsX+DUnWcAkNK9wPGVJ8wIeU=
=MGI8
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 37553-done@debbugs.gnu.org)
87imp7jy01.fsf@gnu.org
Hi,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (3 lines)
> Yep, I've been experimenting with loading older revisions in to the Guix
> Data Service, and this is one of the issues I came across.

Nice! I’ve been thinking we should have time-traveling continuous
integration. Like checking that we can build some Guix revision of the
past in between two ‘core-updates’ merges.

It would also be useful to flag known-bad revisions, but in a way the
Data Service is already doing that for recent revisions.

Thanks,
Ludo’.
Closed
Christopher Baines wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37553-done@debbugs.gnu.org)
874l0mp8gs.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (14 lines)
> Hi,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> Yep, I've been experimenting with loading older revisions in to the Guix
>> Data Service, and this is one of the issues I came across.
>
> Nice! I’ve been thinking we should have time-traveling continuous
> integration. Like checking that we can build some Guix revision of the
> past in between two ‘core-updates’ merges.
>
> It would also be useful to flag known-bad revisions, but in a way the
> Data Service is already doing that for recent revisions.

So I've been looking at retrying failed jobs in the Guix Data Service,
there are a few where it's just networking issues talking to Savannah.

I guess it could be useful to have a list of revisions which can't be
used through guix pull or a channel, and that information could also be
used in the Guix Data Service.
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl2ZqeNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XcVOhAAoas3ntAK+6MPBDvjYTeIgjBrkJUarpDi7gM8VdBXWXcSqNstv/yHSb4a
mWvxaGgZcaCxpRRf4aJ36gzkJUxNNAe0oNmgxg11jR4tCpFUcrXlLibonfrBoquo
23Edrbf4uWSt/E1UEqoIc6NEewLJv9reU/iBQe0bSL2Y4LdKiI8DIiqH7ZwlJ8UH
1KRundvLavJ2mW772p1uwF2vI1/mBE9Orgu8/Y8qJK/GuzG03Ypx3mUKm706i8RP
MlY3nx2XgHqxdjvVneah/ChW2XFNgQ2NV4kkpvC6XDYOd1zUGf3MPw3YruOW3c+H
WVggb0rDJr5sUdYfmgHoqQHhHD+aGIf/URxtSZA4smvy1H7BOtC1o5MdGqtNPXGF
DWa1Kl1gVyp90xoZFu0QHmqrpZfi64YEbElVNpAVjC4kQc3R7RBVQRyqbArCe6gs
s+eRG0KS5HsMmFsnzAoN97QEi0nbw2kpBLFL9PbEWrDS4gOB131DSK9/1n+uxdic
NNwCelsSNZyOuzBghiSJeeTEvz29OsKIQdwIDNauAkBMtxA24l4dOvjp4eNeofg6
ywOyo+5/a1IbX/ddbOEnZV29JgpUXwcRRCWqlD/oZth3i4UQiBES+27PKu8n69Ar
6UV6+5RPoovvHHrLbaPQbPfHZWtsf84xg4a8S/vNCrmLGs9xq6w=
=6Gxi
-----END PGP SIGNATURE-----

Closed
Ludovic Courtès wrote 5 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 37553-done@debbugs.gnu.org)
87y2xygsig.fsf@gnu.org
Hi Chris,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (19 lines)
> Ludovic Courtès <ludo@gnu.org> writes:
>
>> Hi,
>>
>> Christopher Baines <mail@cbaines.net> skribis:
>>
>>> Yep, I've been experimenting with loading older revisions in to the Guix
>>> Data Service, and this is one of the issues I came across.
>>
>> Nice! I’ve been thinking we should have time-traveling continuous
>> integration. Like checking that we can build some Guix revision of the
>> past in between two ‘core-updates’ merges.
>>
>> It would also be useful to flag known-bad revisions, but in a way the
>> Data Service is already doing that for recent revisions.
>
> So I've been looking at retrying failed jobs in the Guix Data Service,
> there are a few where it's just networking issues talking to Savannah.

Cool.

Toggle quote (4 lines)
> I guess it could be useful to have a list of revisions which can't be
> used through guix pull or a channel, and that information could also be
> used in the Guix Data Service.

Yes, thanks for looking into it!

Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37553@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37553
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help