[PATCH] services: dovecot: Fix predicate names for free-form fields

  • Done
  • quality assurance status badge
Details
2 participants
  • Alexey Abramov
  • Ludovic Courtès
Owner
unassigned
Submitted by
Alexey Abramov
Severity
normal

Debbugs page

Alexey Abramov wrote 5 years ago
(address . guix-patches@gnu.org)
20190916144215.25669-1-levenson@mmer.org
---
gnu/services/mail.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/services/mail.scm b/gnu/services/mail.scm
index 3de0b4c2f3..2606aa9e3e 100644
--- a/gnu/services/mail.scm
+++ b/gnu/services/mail.scm
@@ -137,7 +137,7 @@
(define (free-form-fields? val)
(match val
(() #t)
- ((((? symbol?) . (? string)) . val) (free-form-fields? val))
+ ((((? symbol?) . (? string?)) . val) (free-form-fields? val))
(_ #f)))
(define (serialize-free-form-fields field-name val)
(for-each (match-lambda ((k . v) (serialize-field k v))) val))
@@ -145,7 +145,7 @@
(define (free-form-args? val)
(match val
(() #t)
- ((((? symbol?) . (? string)) . val) (free-form-args? val))
+ ((((? symbol?) . (? string?)) . val) (free-form-args? val))
(_ #f)))
(define (serialize-free-form-args field-name val)
(serialize-field field-name
--
2.21.0
Ludovic Courtès wrote 5 years ago
(name . Alexey Abramov)(address . levenson@mmer.org)(address . 37427-done@debbugs.gnu.org)
87blvepuxi.fsf@gnu.org
Hi Alexey,

Alexey Abramov <levenson@mmer.org> skribis:

Toggle quote (9 lines)
> --- a/gnu/services/mail.scm
> +++ b/gnu/services/mail.scm
> @@ -137,7 +137,7 @@
> (define (free-form-fields? val)
> (match val
> (() #t)
> - ((((? symbol?) . (? string)) . val) (free-form-fields? val))
> + ((((? symbol?) . (? string?)) . val) (free-form-fields? val))

Good catch! I tweaked the commit log and committed.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37427@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37427
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help