Christopher Baines wrote 5 years ago
(address . guix-patches@gnu.org)
Otherwise the .go files appear within share, and Guile doesn't find them. With
this patch they appear in lib within the output. One thing this means is that
stack traces include the filenames.
* gnu/packages/guile-xyz.scm (guile-email)[arguments]: Add 'patch-module-dir
phase.
---
gnu/packages/guile-xyz.scm | 11 ++++++++++-
1 file changed, 10 insertions(+), 1 deletion(-)
Toggle diff (24 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index b765ef36e1..4fa2759205 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -927,7 +927,16 @@ tracker's SOAP service, such as @url{https://bugs.gnu.org}.")
(inputs
`(("guile" ,guile-2.2)))
(arguments
- '(#:make-flags '("GUILE_AUTO_COMPILE=0"))) ; to prevent guild warnings
+ '(#:make-flags '("GUILE_AUTO_COMPILE=0") ; to prevent guild warnings
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'patch-module-dir
+ (lambda _
+ (substitute* "Makefile.in"
+ (("^godir = ([[:graph:]]+)")
+ "godir = \
+$(libdir)/guile/@GUILE_EFFECTIVE_VERSION@/site-ccache\n"))
+ #t)))))
(home-page "https://guile-email.systemreboot.net")
(synopsis "Guile email parser")
(description "guile-email is a collection of email utilities implemented
--
2.23.0