[PATCH 0/4] Updates for git-annex

  • Done
  • quality assurance status badge
Details
2 participants
  • Kyle Meyer
  • Ludovic Courtès
Owner
unassigned
Submitted by
Kyle Meyer
Severity
normal

Debbugs page

Kyle Meyer wrote 5 years ago
(address . guix-patches@gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190914060840.4617-1-kyle@kyleam.com
This series makes the following updates to the git-annex package:

* update the license field for upstream changes

* build with MagicMime support (allows for using MIME-based conditions in
.gitattributes expressions for annex.largefiles)

* updates to the latest version

gnu/packages/haskell-apps.scm | 18 +++++++++++++-----
gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
2 files changed, 36 insertions(+), 5 deletions(-)

--
2.23.0
Kyle Meyer wrote 5 years ago
[PATCH 1/4] gnu: git-annex: Update license.
(address . 37402@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190914061534.4963-1-kyle@kyleam.com
* gnu/packages/haskell-apps.scm (git-annex)[license]: Update main license to
AGPLv3+ and include other licenses mentioned in the package's COPYRIGHT file.
---
gnu/packages/haskell-apps.scm | 13 ++++++++++---
1 file changed, 10 insertions(+), 3 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 5cd6549c27..8c4048aa66 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -374,9 +374,16 @@ (define-public git-annex
checking the file contents into Git. It can store files in many places,
such as local hard drives and cloud storage services. It can also be
used to keep a folder in sync between computers.")
- ;; The web app is released under the AGPLv3+.
- (license (list license:gpl3+
- license:agpl3+))))
+ ;; The main author has released all his changes under AGPLv3+ as of March
+ ;; 2019 (7.20190219-187-g40ecf58d4). These are also licensed under the
+ ;; original GPLv3+ license, but going forward new changes will be under
+ ;; only AGPLv3+. The other licenses below cover code written by others.
+ ;; See git-annex's COPYRIGHT file for details on each file.
+ (license (list license:agpl3+
+ license:gpl3+
+ license:bsd-2
+ license:expat
+ license:gpl2))))
(define-public hlint
(package
--
2.23.0
Kyle Meyer wrote 5 years ago
[PATCH 2/4] gnu: Add ghc-magic.
(address . 37402@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190914061534.4963-2-kyle@kyleam.com
* gnu/packages/haskell-xyz.scm (ghc-magic): New variable.
---
gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index ee26c1a25a..4313b6059e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
+;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -5954,6 +5955,28 @@ (define-public ghc-lzma-conduit
compression algorithm used in the @code{.xz} file format.")
(license license:bsd-3)))
+(define-public ghc-magic
+ (package
+ (name "ghc-magic")
+ (version "1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/magic/magic-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "10p0gjjjwr1dda7hahwrwn5njbfhl67arq3v3nf1jr3vymlkn75j"))))
+ (build-system haskell-build-system)
+ (home-page "http://hackage.haskell.org/package/magic")
+ (synopsis "Interface to C file/magic library")
+ (description
+ "This package provides a full-featured binding to the C libmagic library.
+With it, you can determine the type of a file by examining its contents rather
+than its name.")
+ (license license:bsd-3)))
+
(define-public ghc-markdown-unlit
(package
(name "ghc-markdown-unlit")
--
2.23.0
Kyle Meyer wrote 5 years ago
[PATCH 3/4] gnu: git-annex: Build with MagicMime support.
(address . 37402@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190914061534.4963-3-kyle@kyleam.com
git-annex has a mechanism for configuring whether a file is added to the annex
or stored in git. Building with MagicMime support makes it possible to
condition the behavior on a file's MIME type.

* gnu/packages/haskell-apps.scm (git-annex)[inputs]: Add ghc-magic.
---
gnu/packages/haskell-apps.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 8c4048aa66..1341994e60 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -337,6 +337,7 @@ (define-public git-annex
("ghc-http-conduit" ,ghc-http-conduit)
("ghc-http-types" ,ghc-http-types)
("ghc-ifelse" ,ghc-ifelse)
+ ("ghc-magic" ,ghc-magic)
("ghc-memory" ,ghc-memory)
("ghc-monad-control" ,ghc-monad-control)
("ghc-monad-logger" ,ghc-monad-logger)
--
2.23.0
Kyle Meyer wrote 5 years ago
[PATCH 4/4] gnu: git-annex: Update to 7.20190912.
(address . 37402@debbugs.gnu.org)(name . Kyle Meyer)(address . kyle@kyleam.com)
20190914061534.4963-4-kyle@kyleam.com
* gnu/packages/haskell-apps.scm (git-annex): Update 7.20190912.
---
gnu/packages/haskell-apps.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/haskell-apps.scm b/gnu/packages/haskell-apps.scm
index 1341994e60..e09285d63a 100644
--- a/gnu/packages/haskell-apps.scm
+++ b/gnu/packages/haskell-apps.scm
@@ -245,7 +245,7 @@ (define-public darcs
(define-public git-annex
(package
(name "git-annex")
- (version "7.20190708")
+ (version "7.20190912")
(source
(origin
(method url-fetch)
@@ -253,7 +253,7 @@ (define-public git-annex
"git-annex/git-annex-" version ".tar.gz"))
(sha256
(base32
- "18s563swrp8mx479995pdhhmn40y3xwlbm1z3w63qsnjqmj7zlij"))))
+ "1a3jvl5cx32v78s3015i10cx00jprm1391rpww4mzkk1vskzn9cv"))))
(build-system haskell-build-system)
(arguments
`(#:configure-flags
--
2.23.0
Ludovic Courtès wrote 5 years ago
Re: [bug#37402] [PATCH 0/4] Updates for git-annex
(name . Kyle Meyer)(address . kyle@kyleam.com)(address . 37402-done@debbugs.gnu.org)
87impsd3ss.fsf@gnu.org
Hello Kyle,

Kyle Meyer <kyle@kyleam.com> skribis:

Toggle quote (13 lines)
> This series makes the following updates to the git-annex package:
>
> * update the license field for upstream changes
>
> * build with MagicMime support (allows for using MIME-based conditions in
> .gitattributes expressions for annex.largefiles)
>
> * updates to the latest version
>
> gnu/packages/haskell-apps.scm | 18 +++++++++++++-----
> gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
> 2 files changed, 36 insertions(+), 5 deletions(-)

Applied, thanks!

Ludo’.
Closed
Kyle Meyer wrote 5 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37402-done@debbugs.gnu.org)
87a7b4z2pz.fsf@kyleam.com
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (6 lines)
>> gnu/packages/haskell-apps.scm | 18 +++++++++++++-----
>> gnu/packages/haskell-xyz.scm | 23 +++++++++++++++++++++++
>> 2 files changed, 36 insertions(+), 5 deletions(-)
>
> Applied, thanks!

Thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37402@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37402
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help