Vagrant Cascadian wrote 6 years ago
(address . guix-patches@gnu.org)
I was having infinite recursion issues importing additional modules such
as android.scm, bootloaders.scm and statistics.scm into
package-management.scm with use-modules calls, along these lines:
error: googletest: unbound variable
hint: Did you forget a `use-modules' form?
...
error: curl: unbound variable
hint: Did you forget a `use-modules' form?
guix build: error: diffoscope: unknown package
Moving diffoscope to it's own package module seemed to at least work
around the issue. Diffoscope itself attempts to deal with an arbitrary
and growing number of file types, so pulls in quite a few other package
modules, so at least splitting it into a separate module might limit the
impacts on other modules.
Attached are two patches attempting the split; comments welcome!
The first patch is the move itself, and also moves trydiffoscope; the
second patch adds the package modules that previously would fail to
import properly before the move.
This allows diffoscope to run a few additional tests, getting the test
suite down to only about 68 skipped tests (and falling); it was around
140 skipped tests before I started this mad rush...
live well,
vagrant
From c4ef8545514b4d594ab6fc083c954a22eace3786 Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Sun, 8 Sep 2019 15:35:33 -0700
Subject: [PATCH 2/2] gnu: diffoscope: Add additional test dependencies.
* gnu/packages/diffoscope (diffoscope)[native-inputs]: Add abootimg, dtc,
and r-minimal.
(use-module): Add android, bootloaders and statistics, respectively.
---
gnu/packages/diffoscope.scm | 6 ++++++
1 file changed, 6 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 6eb5c1d9fe..828e06a818 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -25,8 +25,10 @@
#:use-module (gnu packages)
#:use-module (gnu packages acl)
#:use-module (gnu packages admin)
+ #:use-module (gnu packages android)
#:use-module (gnu packages backup)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bootloaders)
#:use-module (gnu packages cdrom)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -50,6 +52,7 @@
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages ssh)
+ #:use-module (gnu packages statistics)
#:use-module (gnu packages textutils)
#:use-module (gnu packages video)
#:use-module (gnu packages vim)
@@ -137,6 +140,7 @@
(native-inputs `(("python-pytest" ,python-pytest)
("python-chardet" ,python-chardet)
;; test suite skips tests when tool is missing
+ ("abootimg" ,abootimg)
("bdb" ,bdb)
("binutils" ,binutils)
("bzip2" ,bzip2)
@@ -144,6 +148,7 @@
("colord" ,colord)
("cpio" ,cpio)
("docx2txt" ,docx2txt)
+ ("dtc" ,dtc)
("e2fsprogs" ,e2fsprogs)
("ffmpeg" ,ffmpeg)
("gettext" ,gettext-minimal)
@@ -163,6 +168,7 @@
("openssh" ,openssh)
("pgpdump" ,pgpdump)
("poppler" ,poppler)
+ ("r-minimal" ,r-minimal)
("rpm" ,rpm)
("sng" ,sng)
("sqlite" ,sqlite)
--
2.20.1
-----BEGIN PGP SIGNATURE-----
iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXXWQOAAKCRDcUY/If5cW
quCCAQCWSRWA/yRO9MzMkYpl78tzViv9ou9ugb06aSnKD2Ec2AEA3Zfj208QJGcb
0gj/xES0lSZgr31Z1lO1mn88NoeFlAM=
=U9Uj
-----END PGP SIGNATURE-----