[PATCH] gnu: Add wabt.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Vagrant Cascadian
Severity
normal
V
V
Vagrant Cascadian wrote on 8 Sep 2019 10:10
(address . guix-patches@gnu.org)
874l1n6we1.fsf@yucca
Hi Guix,

wabt includes tools for manipulating WebAssembly/Wasm related files.

Does web.scm make sense for it?

I'm sure better formatting could be done on the synopsis and
description... help would be appreciated!

This also adds yet another test suite dependency and optional feature
for diffoscope; not sure if that should be in a separate patch; in this
case I've added it in the same commit...

Thanks!

live well,
vagrant
From c0ec454bd69e69d2104fd2c64f22c4b07c1bb80f Mon Sep 17 00:00:00 2001
From: Vagrant Cascadian <vagrant@reproducible-builds.org>
Date: Thu, 5 Sep 2019 11:13:22 -0700
Subject: [PATCH] gnu: Add wabt.

* gnu/packages/web (wabt): New variable.
[use-module]: re2c.
* gnu/packages/package-management (diffoscope)[native-inputs]: Add wabt.
---
gnu/packages/package-management.scm | 1 +
gnu/packages/web.scm | 40 +++++++++++++++++++++++++++++
2 files changed, 41 insertions(+)

Toggle diff (72 lines)
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index b712bd7ec9..d5ead2acc3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -664,6 +664,7 @@ transactions from C or Python.")
("sqlite" ,sqlite)
("squashfs-tools" ,squashfs-tools)
("tcpdump" ,tcpdump)
+ ("wabt" ,wabt)
("xxd" ,xxd)
("xz" ,xz)))
(home-page "https://diffoscope.org/")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index ad6f0635dd..c4169da8c9 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -123,6 +123,7 @@
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages qt)
#:use-module (gnu packages readline)
+ #:use-module (gnu packages re2c)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages textutils)
@@ -859,6 +860,45 @@ for efficient socket-like bidirectional reliable communication channels.")
;; This is LGPLv2.1-only with extra exceptions specified in 'LICENSE'.
(license license:lgpl2.1)))
+(define-public wabt
+ (package
+ (name "wabt")
+ (version "1.0.11")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/WebAssembly/wabt")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hn88vlqyclpk79v3wg3lrssd9vwhjdgvb41g03jqakygxxgnmp5"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags '("-DBUILD_TESTS=OFF")
+ #:tests? #f))
+ (inputs `(("python" ,python-2)
+ ("re2c" ,re2c)))
+ (home-page "https://github.com/WebAssembly/wabt")
+ (synopsis "WebAssembly Binary Toolkit")
+ (description "WABT (pronounced: wabbit) is a suite of tools for
+WebAssembly, including:
+
+* wat2wasm: translate from WebAssembly text format to the WebAssembly binary
+ format
+* wasm2wat: the inverse of wat2wasm, translate from the binary format back
+ to the text format (also known as a .wat)
+* wasm-objdump: print information about a wasm binary. Similar to objdump.
+* wasm-interp: decode and run a WebAssembly binary file using a stack-based
+ interpreter
+* wat-desugar: parse .wat text form as supported by the spec interpreter
+ (s-expressions, flat syntax, or mixed) and print canonical flat format
+* wasm2c: convert a WebAssembly binary file to a C source and header
+
+These tools are intended for use in (or for development of) toolchains or
+other systems that want to manipulate WebAssembly files.")
+ (license license:asl2.0)))
+
(define-public websocketpp
(package
(name "websocketpp")
--
2.20.1
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXXS3hwAKCRDcUY/If5cW
qmYLAPwNkjc2mib4uxGXkxycC2W+W4OkXDuY2EstO88+92piFQEAxBqWbRfqo9Pd
0K1SX7sbG6E/sJ8nF5/NASC9RhpIbAg=
=QVen
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 19 Sep 2019 21:30
(address . 37340@debbugs.gnu.org)
87tv98ulqx.fsf@yucca
On 2019-09-08, Vagrant Cascadian wrote:
Toggle quote (11 lines)
> wabt includes tools for manipulating WebAssembly/Wasm related files.
>
> Does web.scm make sense for it?
>
> I'm sure better formatting could be done on the synopsis and
> description... help would be appreciated!
>
> This also adds yet another test suite dependency and optional feature
> for diffoscope; not sure if that should be in a separate patch; in this
> case I've added it in the same commit...

I went ahead and pushed a slightly modified version in
4d83157cd806aeb864664ebb380c19f6be04648c.

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCXYPXZgAKCRDcUY/If5cW
qoY5AQDOphTktsLOc7FyYrKfsxtjc42kO3vCk/Z1R5dF/Mpf9gD9FsnCz7Tujxfd
/5Jt1M0TV+oG3Asz7yiiLTSBwaWFYQM=
=xvIU
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 26 Sep 2019 23:10
control message for bug #37340
(address . control@debbugs.gnu.org)
87impeix1r.fsf@gnu.org
tags 37340 fixed
close 37340
quit
?