(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/music.scm (audacious): New variable.
---
gnu/packages/music.scm | 102 +++++++++++++++++++++++++++++++++++++++++
1 file changed, 102 insertions(+)
Toggle diff (115 lines)
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index a43bccf4f8..33c53dec35 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -203,6 +203,108 @@ and play MIDI files with a few clicks in a user-friendly interface offering
score, keyboard, guitar, drum and controller views.")
(license license:gpl3+)))
+(define-public audacious
+ (package
+ (name "audacious")
+ (version "3.10.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://distfiles.audacious-media-player.org/"
+ "audacious-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "14vbkhld5hwh96j8p8hjq9ybvc2m060a1y8crz14i51wpd0fhrl3"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ (list "--disable-gtk" "--enable-qt"
+ ;; Add the output lib directory to the RUNPATH.
+ (string-append "LDFLAGS=-Wl,-rpath=" %output "/lib"))
+ #:tests? #f ; no check target
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'unpack-plugins
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((plugins (assoc-ref inputs "audacious-plugins")))
+ (invoke "tar" "xvf" plugins)
+ (chdir (string-append "audacious-plugins-" ,version))
+ #t)))
+ (add-after 'unpack-plugins 'configure-plugins
+ (lambda* (#:key configure-flags outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out")))
+ (substitute* "configure"
+ (("/bin/sh") (which "sh")))
+ (apply invoke "./configure"
+ (append configure-flags
+ ;; audacious-plugins requires audacious to build.
+ (list (string-append "PKG_CONFIG_PATH="
+ out "/lib/pkgconfig:"
+ (getenv "PKG_CONFIG_PATH"))
+ (string-append "--prefix=" out)))))))
+ (add-after 'configure-plugins 'build-plugins
+ (lambda _
+ (invoke "make" "-j" (number->string (parallel-job-count)))))
+ (add-after 'build-plugins 'install-plugins
+ (lambda _
+ (invoke "make" "install"))))))
+ (native-inputs
+ `(("audacious-plugins"
+ ,(origin
+ (method url-fetch)
+ (uri (string-append "https://distfiles.audacious-media-player.org/"
+ "audacious-plugins-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0hi61825ayrwc4snwr76f2669k06fii3n8ll1szjk5zr65v1ghzf"))))
+ ("gettext" ,gettext-minimal)
+ ("glib:bin" ,glib "bin") ; for gdbus-codegen
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("dbus" ,dbus)
+ ("glib" ,glib)
+ ("qtbase" ,qtbase)
+ ;; Plugin dependencies
+ ("alsa-lib" ,alsa-lib)
+ ("curl" ,curl)
+ ("ffmpeg" ,ffmpeg)
+ ("flac" ,flac)
+ ("fluidsynth" ,fluidsynth)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("libbs2b" ,libbs2b)
+ ("libcddb" ,libcddb)
+ ("libcdio-paranoia" ,libcdio-paranoia)
+ ("libcue" ,libcue)
+ ("libmodplug" ,libmodplug)
+ ("libnotify" ,libnotify)
+ ("libogg" ,libogg)
+ ("libsamplerate" ,libsamplerate)
+ ("libsndfile" ,libsndfile)
+ ("libvorbis" ,libvorbis)
+ ("libxml2" ,libxml2)
+ ("lirc" ,lirc)
+ ("jack" ,jack-1)
+ ("mpg123" ,mpg123)
+ ("neon" ,neon)
+ ("pulseaudio" ,pulseaudio)
+ ("qtmultimedia" ,qtmultimedia)
+ ("soxr" ,soxr)
+ ("wavpack" ,wavpack)))
+ (home-page "https://audacious-media-player.org")
+ (synopsis "Audio player based on XMMS")
+ (description
+ "Audacious is an audio player descended from XMMS. Drag and drop folders
+and individual song files, search for artists and albums in your entire music
+library, or create and edit your own custom playlists. Listen to CD’s or stream
+music from the Internet. Tweak the sound with the graphical equalizer or
+experiment with LADSPA effects. Enjoy the modern GTK-themed interface or change
+things up with Winamp Classic skins. Use the plugins included with Audacious to
+fetch lyrics for your music, to set an alarm in the morning, and more.")
+ ;; According to COPYING, Audacious and its plugins are licensed under the
+ ;; BSD 2-clause license and libguess is licensed under the BSD 3-clause
+ ;; license.
+ (license (list license:bsd-2
+ license:bsd-3))))
+
;; We don't use the latest release because it depends on Qt4. Instead we
;; download the sources from the tip of the "qt5" branch.
(define-public clementine
--
2.23.0