image-size is meaningless when generating ext4 images

  • Open
  • quality assurance status badge
Details
One participant
  • Jesse Gibbons
Owner
unassigned
Submitted by
Jesse Gibbons
Severity
normal
J
J
Jesse Gibbons wrote on 3 Sep 2019 04:48
(name . bug-guix mailing list)(address . bug-guix@gnu.org)
46bad7b539bd9a7ce04e2dcbfad336a00fdc03f0.camel@gmail.com
The manual says in multiple places the --image-size option should set
the size of a generated ext4 disk image.

I start with a minimalist configuration (attached: minimal.scm) and run
build-minimal-os.sh (attached). I start virt-manager and make a new
virtual machine with the generated img as the disk image. virt-manager
says the disk image is 20G. So far so good...

I run "guix pull" and it fails because it runs out of disk space.

I run df -h and see the partition mounted on / has only 494M.
available.

I run cfdisk /dev/sda and see the first partition is 20G.

I have added quite a bit to the minimal os, but have not changed the
behavior. The attached minimal.scm is my most recent version.

Does anyone know of a way to expand the main partition's size?

Thanks,

--
-Jesse
(use-modules (gnu) (gnu services networking)) (operating-system (bootloader (bootloader-configuration (bootloader grub-bootloader))) (host-name "minimal-os") (file-systems (cons* (file-system (type "ext4") (mount-point "/") (device "/dev/sda1") (needed-for-boot? #t) (create-mount-point? #t)) %base-file-systems)) (packages (cons* %base-packages)) (services (cons* (service network-manager-service-type) (service wpa-supplicant-service-type) %base-services)) (timezone "America/Denver"))
J
J
Jesse Gibbons wrote on 3 Sep 2019 05:04
(address . 37293@debbugs.gnu.org)
756e464b19ac17ed6847fe091191503396e3fbfc.camel@gmail.com
On Mon, 2019-09-02 at 20:48 -0600, Jesse Gibbons wrote:
Toggle quote (24 lines)
> The manual says in multiple places the --image-size option should set
> the size of a generated ext4 disk image.
>
> I start with a minimalist configuration (attached: minimal.scm) and
> run
> build-minimal-os.sh (attached). I start virt-manager and make a new
> virtual machine with the generated img as the disk image. virt-
> manager
> says the disk image is 20G. So far so good...
>
> I run "guix pull" and it fails because it runs out of disk space.
>
> I run df -h and see the partition mounted on / has only 494M.
> available.
>
> I run cfdisk /dev/sda and see the first partition is 20G.
>
> I have added quite a bit to the minimal os, but have not changed the
> behavior. The attached minimal.scm is my most recent version.
>
> Does anyone know of a way to expand the main partition's size?
>
> Thanks,
>
If I take build-minimal-os.sh and have it build a qcow2 vm-image
instead of an ext4 disk-image it says I found a bug. I think it might
be related, but it doesn't give me any details.
?