git pull warns of http redirection

  • Done
  • quality assurance status badge
Details
3 participants
  • Bengt Richter
  • Gábor Boskovits
  • Royce Strange
Owner
unassigned
Submitted by
Bengt Richter
Severity
normal

Debbugs page

Bengt Richter wrote 6 years ago
(address . bug-guix@gnu.org)
20190830075323.GA12551@PhantoNv4ArchGx.localdomain
Hi all,

It seems to be working, but I like to
eliminate warnings ;-)

To reproduce, cd into your repo dir, then:

$ git status
On branch master
Your branch is up to date with 'origin/master'.

nothing to commit, working tree clean
$ git config -l
core.editor=emacs
user.name=Bengt Richter
user.email=bokr@bokr.com
core.repositoryformatversion=0
core.filemode=true
core.bare=false
core.logallrefupdates=true
remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
branch.master.remote=origin
branch.master.merge=refs/heads/master
$ git pull
Already up to date.
$

Is that http necessary for some load-balancing
redirection, or could it be done with https?

--== (the rest of this is ignorable context, FWIW :) ==--

I think I used the advice from guix 1.0.1 info
to do the initial clone, i.e.,
--advice
14.1 Building from Git

If you want to hack Guix itself, it is recommended to use the latest version from the Git repository:

--advice--
(though my purpose was not use it for building, but to have the latest
and greatest to grep around in when trying to figure something out ;-)

uname -a:
Linux PhantoNv4ArchGx 5.2.9-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 16 11:29:43 UTC 2019 x86_64 GNU/Linux

guix describe:
Generation 11 Aug 25 2019 20:58:43 (current)
guix a707484
branch: master
commit: a707484d64e7e46f8cb8401c660fbb6eb77ab9c6

(cd ~/wb/guix; git log|head):
commit 43412ab967ee00789fe933f916d804aed9961c57
Author: Tobias Geerinckx-Rice <me@tobias.gr>
Date: Fri Aug 30 03:17:07 2019 +0200

gnu: aqbanking: Update to 5.8.1.
* gnu/packages/gnucash.scm (aqbanking): Update to 5.8.1.
[source]: Remove FILE-NAME.

commit 521bb336782b8fe04b57ebaadd55be005a85d788

grep -m1 'model name' /proc/cpuinfo:
model name : Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz

--== (end of ignorable context, FWIW :) ==--

Regards,
Bengt Richter
Gábor Boskovits wrote 6 years ago
(name . Bengt Richter)(address . bokr@bokr.com)(address . 37232@debbugs.gnu.org)
CAE4v=phwJ0zAXP-3oNhqnmoptx9ZMQ1wWNryYyetJC8RTQ-5FQ@mail.gmail.com
Hello,

Bengt Richter <bokr@bokr.com> ezt írta (időpont: 2019. aug. 30., P, 9:54):

Toggle quote (23 lines)
> Hi all,
>
> It seems to be working, but I like to
> eliminate warnings ;-)
>
> To reproduce, cd into your repo dir, then:
>
> $ git status
> On branch master
> Your branch is up to date with 'origin/master'.
>
> nothing to commit, working tree clean
> $ git config -l
> core.editor=emacs
> user.name=Bengt Richter
> user.email=bokr@bokr.com
> core.repositoryformatversion=0
> core.filemode=true
> core.bare=false
> core.logallrefupdates=true
> remote.origin.url=http://git.sv.gnu.org/r/guix.git


This line says, that you confgiured remote is git.sv.gnu.org ...


Toggle quote (10 lines)
>
> remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
> branch.master.remote=origin
> branch.master.merge=refs/heads/master
> $ git pull
> warning: redirecting to http://git.savannah.gnu.org/r/guix.git/
> Already up to date.
> $
>

Toggle quote (5 lines)
>
> Is that http necessary for some load-balancing
> redirection, or could it be done with https?
>
>
So https is fine.

You can try:
git remote set-url origin



--== (the rest of this is ignorable context, FWIW :) ==--
Toggle quote (46 lines)
>
> I think I used the advice from guix 1.0.1 info
> to do the initial clone, i.e.,
> --advice
> 14.1 Building from Git
>
> If you want to hack Guix itself, it is recommended to use the latest
> version from the Git repository:
>
> git clone https://git.savannah.gnu.org/git/guix.git
> --advice--
> (though my purpose was not use it for building, but to have the latest
> and greatest to grep around in when trying to figure something out ;-)
>
> uname -a:
> Linux PhantoNv4ArchGx 5.2.9-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 16
> 11:29:43 UTC 2019 x86_64 GNU/Linux
>
> guix describe:
> Generation 11 Aug 25 2019 20:58:43 (current)
> guix a707484
> repository URL: https://git.savannah.gnu.org/git/guix.git
> branch: master
> commit: a707484d64e7e46f8cb8401c660fbb6eb77ab9c6
>
> (cd ~/wb/guix; git log|head):
> commit 43412ab967ee00789fe933f916d804aed9961c57
> Author: Tobias Geerinckx-Rice <me@tobias.gr>
> Date: Fri Aug 30 03:17:07 2019 +0200
>
> gnu: aqbanking: Update to 5.8.1.
>
> * gnu/packages/gnucash.scm (aqbanking): Update to 5.8.1.
> [source]: Remove FILE-NAME.
>
> commit 521bb336782b8fe04b57ebaadd55be005a85d788
>
> grep -m1 'model name' /proc/cpuinfo:
> model name : Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz
>
> --== (end of ignorable context, FWIW :) ==--
>
> Regards,
> Bengt Richter
>
> Best regards,
g_bor


--
OpenPGP Key Fingerprint: 7988:3B9F:7D6A:4DBF:3719:0367:2506:A96C:CF63:0B21
Attachment: file
Bengt Richter wrote 6 years ago
(name . Gábor Boskovits)(address . boskovits@gmail.com)(address . 37232@debbugs.gnu.org)
20190830102506.GB16694@PhantoNv4ArchGx.localdomain
On +2019-08-30 10:40:43 +0200, Gábor Boskovits wrote:
Toggle quote (10 lines)
> Hello,
>
> Bengt Richter <bokr@bokr.com> ezt írta (időpont: 2019. aug. 30., P, 9:54):
>
> > Hi all,
> >
> > It seems to be working, but I like to
> > eliminate warnings ;-)
> >
> > To reproduce, cd into your repo dir, then:
[...]

Toggle quote (13 lines)
> > $ git config -l
> > core.editor=emacs
> > user.name=Bengt Richter
> > user.email=bokr@bokr.com
> > core.repositoryformatversion=0
> > core.filemode=true
> > core.bare=false
> > core.logallrefupdates=true
> > remote.origin.url=http://git.sv.gnu.org/r/guix.git
>
>
> This line says, that you confgiured remote is git.sv.gnu.org ...
>
Yes, but AFAIK I only used git config to add my name, email, and
preferred editor.
Toggle quote (16 lines)
>
> >
> > remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
> > branch.master.remote=origin
> > branch.master.merge=refs/heads/master
> > $ git pull
> > warning: redirecting to http://git.savannah.gnu.org/r/guix.git/
> > Already up to date.
> > $
> >
>
> And this is the current url:
>
> git clone https://git.savannah.gnu.org/git/guix.git
>

Is that how guix info docs should read now, unlike what I used
from there? I'll try it fresh into a new guix git repo ...

Aha! Now, right after cloning, I get this
from git config -l:

core.editor=emacs
user.name=Bengt Richter
user.email=bokr@bokr.com
core.repositoryformatversion=0
core.filemode=true
core.bare=false
core.logallrefupdates=true
^^^^^--joy :)

remote.origin.fetch=+refs/heads/*:refs/remotes/origin/*
branch.master.remote=origin
branch.master.merge=refs/heads/master

And: git pull does not warn about http redirection \o/ :-)

Thank you!

[...]

Regards,
Bengt Richter
Royce Strange wrote 5 years ago
git pull warns of http redirection
(address . 37232-done@debbugs.gnu.org)
87eeqeo1tb.fsf@disroot.org
Hello.

Looks like Gábor Boskovits helped Bengt Richter resolve his issue.

Going to go ahead and close.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37232@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37232
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help