[PATCH] gnu: services: Add dkimproxy-out.

  • Open
  • quality assurance status badge
Details
5 participants
  • Julien Lepiller
  • Alexey Abramov
  • Ludovic Courtès
  • Tobias Geerinckx-Rice
  • Vivien Kraus
Owner
unassigned
Submitted by
Julien Lepiller
Severity
normal
J
J
Julien Lepiller wrote on 29 Aug 2019 21:52
(address . guix-patches@gnu.org)
20190829215226.173a4812@sybil.lepiller.eu
Hi guix, the attached patch adds the dkimproxy-out service that I use
for signing my emails (including this one, although it's probably not
valid because it went through a mailing list).

Thanks!
T
T
Tobias Geerinckx-Rice wrote on 29 Aug 2019 22:04
(address . guix-patches@gnu.org)(address . 37222@debbugs.gnu.org)
871rx3rb62.fsf@nckx
Julien,

Julien Lepiller ???
Toggle quote (6 lines)
> Hi guix, the attached patch adds the dkimproxy-out service that
> I use
> for signing my emails (including this one, although it's
> probably not
> valid because it went through a mailing list).

Interesting; I wasn't expecting that. I thought GNU'd finally
fixed their mailman to not break signatures, but you're right:

Received: from a.mx.tobias.gr (localhost [127.0.0.1])
by DKIM-proxy (OpenSMTPD) with ESMTP id a7e379af
for <me@tobias.gr>;
Thu, 29 Aug 2019 19:53:20 +0000 (UTC)
Authentication-Results: tobias.gr; dkim=fail (message has been
altered) header.i=@lepiller.eu; domainkeys=fail (message has
been altered) header.from=julien@lepiller.eu
X-DKIM-Authentication-Results: fail (message has been altered)
Received: from lists.gnu.org (lists.gnu.org [209.51.188.17])
by a.mx.tobias.gr (OpenSMTPD) with ESMTPS id eb36763a
(TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256:NO)
for <me@tobias.gr>;
Thu, 29 Aug 2019 19:53:20 +0000 (UTC)

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXWgvtQAKCRANsP+IT1Vt
eZpdAQD+ar0Z5Bz0JLLRI/dvH/JdJcayRgerPUpdaZzQr7yPaQEAvS4LDpLcWYzq
KmPF+mkA+uWCEAKQTuDmep6Dx0JzCAA=
=jLZ3
-----END PGP SIGNATURE-----

L
L
Ludovic Courtès wrote on 4 Sep 2019 14:16
(name . Julien Lepiller)(address . julien@lepiller.eu)(address . 37222@debbugs.gnu.org)
87pnkg5kab.fsf@gnu.org
Hi!

Julien Lepiller <julien@lepiller.eu> skribis:

Toggle quote (4 lines)
>>From 114067a7134ceb49dc5bbcef820edc49d62c8d0f Mon Sep 17 00:00:00 2001
> From: Julien Lepiller <julien@lepiller.eu>
> Date: Thu, 29 Aug 2019 21:48:25 +0200
> Subject: [PATCH] gnu: services: Add dkimproxy-out.
^
No need for “gnu:”, which is only for (gnu packages …). (Confusingly…)
Toggle quote (7 lines)
>
> * gnu/services/mail.scm (dkimproxy-out-service-type): New variable.
> * doc/guix.texi (Mail Services): Document it.
> +@subsubheading Dkimproxy Outbound Service
> +@cindex Dkimproxy Outbound Service
> +

Could you add an introductory paragraph, for instance mentioning what
DKIM is about, linking to the Wikipedia page or something?

Toggle quote (9 lines)
> +@deffn {Scheme Variable} dkimproxy-out-service-type
> +This is the type of the @uref{http://dkimproxy.sourceforge.net/, dkimproxy
> +outbound daemon}, whose value should be a @code{dkimproxy-out-configuration}
> +object as in this example:
> +
> +@example
> +(service dkimproxy-out-service-type
> + (dkimproxy-out-configuration
> + (listen "127.0.0.1:10027")
^
No tabs please. :-)

Toggle quote (4 lines)
> + %default-imap4d-config-file
> +
> + dkimproxy-out-service-type

Ditto (several occurrences in this file.)

Toggle quote (16 lines)
> +(define (generate-map-file config filename)
> + (apply plain-file filename
> + (map (lambda (config)
> + (match config
> + ((selector (config ...))
> + (string-append
> + selector " "
> + (string-join
> + (map generate-dkimproxy-out-signature-configuration config)
> + "\n")))
> + ((selector config)
> + (string-append
> + selector " "
> + (generate-dkimproxy-out-signature-configuration config)))))
> + config)))

This is incorrect since ‘plain-file’ takes exactly two arguments.
Should it be something like:

(plain-file file-name (string-join (map … config)))

?

Toggle quote (4 lines)
> + (domains
> + (apply append
> + (map

Use ‘append-map’ instead.

Toggle quote (9 lines)
> +(define dkimproxy-out-service-type
> + (service-type
> + (name 'dkimproxy-out)
> + (extensions
> + (list (service-extension account-service-type
> + (const %dkimproxy-accounts))
> + (service-extension shepherd-root-service-type
> + dkimproxy-out-shepherd-service)))))

Please add a ‘description’ field.

It would be nice to have a system test too, which I guess could at least
ensure that the generated config is valid and that the daemon happily
starts?

Thanks,
Ludo’.
A
A
Alexey Abramov wrote on 4 Feb 2021 12:19
dkimproxy-out status
(address . julien@lepiller.eu)(address . 37222@debbugs.gnu.org)
871rdw84h9.fsf@delta.lan
Hi Julien,

I copy&pasted your great dkimproxy service, and it works like a charm. Thank you! I was wondering when are you going to address those changes that Ludo has suggested?

If you don't have time for some reason, I am willing to help with it to let it merge. What do you think?

--
Alexey
J
J
Julien Lepiller wrote on 4 Feb 2021 12:37
(name . Alexey Abramov)(address . levenson@mmer.org)(address . 37222@debbugs.gnu.org)
A5DE8A6A-3346-4D97-A27D-388A4E0BA7E3@lepiller.eu
Oh, I totally forgot about it! With FOSDEM and everything, I don't think I'll be able to take care of this before next week. I appreciate any help you can provide!

Le 4 février 2021 06:19:46 GMT-05:00, Alexey Abramov <levenson@mmer.org> a écrit :
Toggle quote (11 lines)
>Hi Julien,
>
>I copy&pasted your great dkimproxy service, and it works like a charm.
>Thank you! I was wondering when are you going to address those changes
>that Ludo has suggested?
>
>If you don't have time for some reason, I am willing to help with it to
>let it merge. What do you think?
>
>--
>Alexey
Attachment: file
V
V
Vivien Kraus wrote on 15 Jun 2023 18:08
Re: [PATCH] gnu: services: Add dkimproxy-out.
(address . 37222@debbugs.gnu.org)
c314add08220853529e190d58cd64371c05ca672.camel@planete-kraus.eu
Dear guix,

I myself have a similar service for DKIM signing. I would be glad to
trash it and use this one. This patch series seems to be forgotten,
could we reconsider it?

Best regards,

Vivien
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 37222@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37222
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch