[PATCH] gnu: gcl: Enable tests.

  • Done
  • quality assurance status badge
Details
One participant
  • Kei Kebreau
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)
20190825154206.3885-1-kkebreau@posteo.net
This patch enables tests in GNU Common Lisp and also seems to repair Maxima's
build failure on master (at least on x86_64). Review and more testing would be
appreciated.
Kei Kebreau wrote 6 years ago
(address . 37180@debbugs.gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190825154401.4321-1-kkebreau@posteo.net
* gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
#:test-target to "ansi-tests/test_results".
---
gnu/packages/lisp.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index d32f4b19bd..2c08e06a55 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -113,7 +113,7 @@
(build-system gnu-build-system)
(arguments
`(#:parallel-build? #f ; The build system seems not to be thread safe.
- #:tests? #f ; There does not seem to be make check or anything similar.
+ #:test-target "ansi-tests/test_results"
#:configure-flags '("--enable-ansi") ; required for use by the maxima package
#:make-flags (list
(string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")
--
2.23.0
Kei Kebreau wrote 6 years ago
(address . 37180-done@debbugs.gnu.org)
87v9uar2cc.fsf@posteo.net
Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (20 lines)
> * gnu/packages/lisp.scm (gcl)[arguments]: Remove #:tests? flag and set the
> #:test-target to "ansi-tests/test_results".
> ---
> gnu/packages/lisp.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
> index d32f4b19bd..2c08e06a55 100644
> --- a/gnu/packages/lisp.scm
> +++ b/gnu/packages/lisp.scm
> @@ -113,7 +113,7 @@
> (build-system gnu-build-system)
> (arguments
> `(#:parallel-build? #f ; The build system seems not to be thread safe.
> - #:tests? #f ; There does not seem to be make check or anything similar.
> + #:test-target "ansi-tests/test_results"
> #:configure-flags '("--enable-ansi") ; required for use by the maxima package
> #:make-flags (list
> (string-append "GCL_CC=" (assoc-ref %build-inputs "gcc")

Pushed to master. The patch doesn't appear to negatively affect the
i686-linux, x86_64-linux and armhf-linux architectures.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37180@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37180
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help