[PATCH 1-3/3] gnu: Add nomad.

  • Done
  • quality assurance status badge
Details
4 participants
  • Jan Nieuwenhuizen
  • Ludovic Courtès
  • Mike Rosset
  • Amar Singh
Owner
unassigned
Submitted by
Amar Singh
Severity
normal

Debbugs page

Amar Singh wrote 6 years ago
(address . guix-patches@gnu.org)(address . mike.rosset@gmail.com)
85sgpwcoqz.fsf@disroot.org
From the package description:

Nomad is an Emacs-like Web Browser built using Webkitgtk and
Emacsy. It has a small C backend and most browser features are fully
programmable in Guile. It has hooks, keymaps, and self documentation
features.

Though it requires a few changes to existing packages:

Patches:

1. Shroud related patches
a. update to 0.1.2: brings Guile-2.2 support


2. Emacsy related patches
a. Add guile-emacsy package,
$ guix size emacsy ... total: 1136.3 MiB
versus:
$ guix size guile-emacsy ... total: 132.3 MiB

(Discussion about "emacsy" vs "guile-emacsy" naming)

3. Nomad related patches
a. Add 'Nomad' package in guile-xyz.scm

4. [Optional] Emacsy package can also be cleaned up a bit, mostly
removal of propagated-inputs. Though that's a seperate issue.
[patch 04 attached]

Cheers,
amar
From 1f5cb19d4e44e2f99250499b7a4f756cddb21d13 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Mon, 8 Jul 2019 12:04:56 +0530
Subject: [PATCH 1/4] gnu: Add guile-emacsy.

* (guile-emacsy): New variable.

Emacsy is a library for Guile. Emacsy package is too heavy for use as a
dependency for other packages:

$ guix size emacsy ... total: 1136.3 MiB

versus:
$ guix size guile-emacsy ... total: 132.3 MiB
---
gnu/packages/guile-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 91054fef25..760646259e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2430,6 +2430,36 @@ comes with a simple counter example using FreeGLUT and browser examples
in C using Gtk+-3 and WebKitGtk.")
(license license:gpl3+)))
+(define-public guile-emacsy
+ (let ((commit "f3bf0dbd803d7805b6ae8303253507ad13922293"))
+ (package
+ (inherit emacsy)
+ (name "guile-emacsy")
+ (version (git-version "v0.4.1" "19" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacsy.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ivy28km1p7nlrf63xx3hvrpxf5ld5amk1wcan3k7sqv1kq9mqdb"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("guile-lib" ,guile-lib)
+ ("guile-readline" ,guile-readline)))
+ (propagated-inputs '())
+ (arguments
+ `(#:configure-flags '("--without-examples")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "GUILE_AUTO_COMPILE" "0")
+ #t))))))))
+
(define-public guile-jpeg
(let ((commit "6a1673578b297c2c1b28e44a76bd5c49e76a5046")
(revision "0"))
--
2.22.1
From 6c3d8835105c09eda6215e4b0d8847f4a6b6b3e8 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Sun, 11 Aug 2019 03:44:16 +0530
Subject: [PATCH 2/4] gnu: shroud: Update to 0.1.2.

* gnu/packages/password-utils.scm (shroud): Update to 0.1.2.

Shroud now builds with Guile-2.2. Remove hardcoded '2.0' string.
---
gnu/packages/password-utils.scm | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 49024b26c4..6ca16025ef 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -236,28 +236,40 @@ platforms.")
(define-public shroud
(package
(name "shroud")
- (version "0.1.1")
+ (version "0.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/shroud/shroud-"
version ".tar.gz"))
(sha256
(base32
- "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
+ "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(arguments
- '(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-shroud
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (ccachedir (string-append out "/lib/guile/2.0/ccache"))
+ (guile (assoc-ref inputs "guile"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (ccachedir (string-append out
+ "/lib/guile/" effective "/site-ccache"))
(prog (string-append out "/bin/shroud")))
(wrap-program prog
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
#t))))))
(inputs
- `(("guile" ,guile-2.0)
+ `(("guile" ,guile-2.2)
("gnupg" ,gnupg)
("xclip" ,xclip)))
(synopsis "GnuPG-based secret manager")
--
2.22.1
From b8cc0e6db1abcb395df12437e16ba39007dff33d Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Wed, 10 Jul 2019 16:45:50 +0530
Subject: [PATCH 4/4] gnu: emacsy: cleanup build

fix conflicts; emacsy requires guile-2.2.4 but found guile-2.2.6 in profile etc.

build: add phase 'wrap-binaries
bulid: glib-or-gtk-build-system wraps binaries to work with glib or gtk
propagated-inputs: remove all but glib-network and gsettings
---
gnu/packages/guile-xyz.scm | 40 ++++++++++++++++++++++++++++++++------
1 file changed, 34 insertions(+), 6 deletions(-)

Toggle diff (78 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 0fed3c6da5..d515e1ed5e 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
+;;; Copyright (C) 2019 by Amar Singh<nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2393,7 +2394,7 @@ more expressive and flexible than the traditional @code{format} procedure.")
(sha256
(base32
"1cpb85dl1nibd34c2x2h7vfmjpkgh353p5b1w20v6cs6gmvgg4np"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
@@ -2405,22 +2406,49 @@ more expressive and flexible than the traditional @code{format} procedure.")
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)
("texlive" ,(texlive-union (list texlive-generic-epsf)))))
- (propagated-inputs
+ (inputs
`(("dbus-glib" ,dbus-glib)
("guile" ,guile-2.2)
("guile-lib" ,guile-lib)
("guile-readline" ,guile-readline)
- ("glib-networking" ,glib-networking)
("freeglut" ,freeglut)
- ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)
("webkitgtk" ,webkitgtk)))
+ (propagated-inputs
+ `(("glib-networking" ,glib-networking)
+ ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)))
(arguments
- `(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build glib-or-gtk-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim)
+ (ice-9 regex)
+ (ice-9 ftw)
+ (srfi srfi-26))
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'setenv
(lambda _
(setenv "GUILE_AUTO_COMPILE" "0")
- #t)))))
+ #t))
+ (add-after 'install 'wrap-binaries
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ "guile" "-c"
+ "(display (effective-version))")))
+ (deps (map (cut assoc-ref inputs <>) '("guile-lib" "guile-readline")))
+ (scm-path (map (cut string-append <> "/share/guile/site/" effective) `(,out ,@deps)))
+ (go-path (map (cut string-append <> "/lib/guile/" effective "/site-ccache/") `(,out ,@deps)))
+ (examples (filter (cut string-match "emacsy" <>)
+ (scandir (string-append out "/bin/"))))
+ (progs (map (cut string-append out "/bin/" <>)
+ examples)))
+ (map (cut wrap-program <>
+ `("GUILE_LOAD_PATH" ":" prefix ,scm-path)
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix ,go-path)) progs)
+ #t))))))
(home-page "https://savannah.nongnu.org/projects/emacsy")
(synopsis "Embeddable GNU Emacs-like library using Guile")
(description
--
2.22.1
Amar Singh wrote 6 years ago
[PATCH 1-1] gnu: Add nomad
(address . 37094@debbugs.gnu.org)(address . mike.rosset@gmail.com)
858srns3y1.fsf@disroot.org
"Patch 003: Add nomad" might not apply cleanly(thanks str1ngs). So this
is an alternative. The fault was that the patch mentions g-golf which is
not packaged in guix master yet. This was resolved by moving around the
nomad package.

This patch adds package Nomad to guile-xyz.scm.
Amar Singh wrote 6 years ago
[PATCH 1-3/3] Add nomad
(address . 37094@debbugs.gnu.org)(address . mike.rosset@gmail.com)
855zmqsyqg.fsf@disroot.org
After a few suggestions from Mike and Janneke:
1. Rename guile-emacsy --> emacsy-minimal
2. Removed glib-or-gtk-build-system in patch 004

cheers,
amar
From 7040563cb1386c672c75ddb141b235d5895adfdf Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Mon, 8 Jul 2019 12:04:56 +0530
Subject: [PATCH 1/4] gnu: Add emacsy-minimal.

* (guile-emacsy): New variable.

Emacsy is a library for Guile. Emacsy package is too heavy for use as a
dependency for other packages:

$ guix size emacsy ... total: 1136.3 MiB

versus:
$ guix size guile-emacsy ... total: 132.3 MiB
---
gnu/packages/guile-xyz.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 16e30b9de7..77a765b52c 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2377,6 +2377,36 @@ comes with a simple counter example using FreeGLUT and browser examples
in C using Gtk+-3 and WebKitGtk.")
(license license:gpl3+)))
+(define-public emacsy-minimal
+ (let ((commit "f3bf0dbd803d7805b6ae8303253507ad13922293"))
+ (package
+ (inherit emacsy)
+ (name "emacsy-minimal")
+ (version (git-version "v0.4.1" "19" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.savannah.gnu.org/git/emacsy.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0ivy28km1p7nlrf63xx3hvrpxf5ld5amk1wcan3k7sqv1kq9mqdb"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("guile" ,guile-2.2)
+ ("guile-lib" ,guile-lib)
+ ("guile-readline" ,guile-readline)))
+ (propagated-inputs '())
+ (arguments
+ `(#:configure-flags '("--without-examples")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (setenv "GUILE_AUTO_COMPILE" "0")
+ #t))))))))
+
(define-public guile-jpeg
(let ((commit "6a1673578b297c2c1b28e44a76bd5c49e76a5046")
(revision "0"))
--
2.22.1
From faba8ff1ef7ceedd4b3dc861d77d4a16a8f2fa0d Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Sun, 11 Aug 2019 03:44:16 +0530
Subject: [PATCH 2/4] gnu: shroud: Update to 0.1.2.

* gnu/packages/password-utils.scm (shroud): Update to 0.1.2.

Shroud now builds with Guile-2.2. Remove hardcoded '2.0' string.
---
gnu/packages/password-utils.scm | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 49024b26c4..6ca16025ef 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -236,28 +236,40 @@ platforms.")
(define-public shroud
(package
(name "shroud")
- (version "0.1.1")
+ (version "0.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/shroud/shroud-"
version ".tar.gz"))
(sha256
(base32
- "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
+ "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(arguments
- '(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-shroud
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (ccachedir (string-append out "/lib/guile/2.0/ccache"))
+ (guile (assoc-ref inputs "guile"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (ccachedir (string-append out
+ "/lib/guile/" effective "/site-ccache"))
(prog (string-append out "/bin/shroud")))
(wrap-program prog
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
#t))))))
(inputs
- `(("guile" ,guile-2.0)
+ `(("guile" ,guile-2.2)
("gnupg" ,gnupg)
("xclip" ,xclip)))
(synopsis "GnuPG-based secret manager")
--
2.22.1
From b082d2b141f87f91330e8416c40622b6213c9c9c Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Wed, 10 Jul 2019 16:45:50 +0530
Subject: [PATCH 4/4] gnu: emacsy: cleanup build

fix conflicts; emacsy requires guile-2.2.4 but found guile-2.2.6 in profile etc.

build: add phase 'wrap-binaries
bulid: glib-or-gtk-build-system wraps binaries to work with glib or gtk
propagated-inputs: remove all but glib-network and gsettings
---
gnu/packages/guile-xyz.scm | 37 ++++++++++++++++++++++++++++++++-----
1 file changed, 32 insertions(+), 5 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 573dd461ad..88fc2eef2a 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
+;;; Copyright (C) 2019 by Amar Singh<nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2352,22 +2353,48 @@ more expressive and flexible than the traditional @code{format} procedure.")
("pkg-config" ,pkg-config)
("texinfo" ,texinfo)
("texlive" ,(texlive-union (list texlive-generic-epsf)))))
- (propagated-inputs
+ (inputs
`(("dbus-glib" ,dbus-glib)
("guile" ,guile-2.2)
("guile-lib" ,guile-lib)
("guile-readline" ,guile-readline)
- ("glib-networking" ,glib-networking)
("freeglut" ,freeglut)
- ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)
("webkitgtk" ,webkitgtk)))
+ (propagated-inputs
+ `(("glib-networking" ,glib-networking)
+ ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)))
(arguments
- `(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim)
+ (ice-9 regex)
+ (ice-9 ftw)
+ (srfi srfi-26))
+ #:phases
(modify-phases %standard-phases
(add-before 'configure 'setenv
(lambda _
(setenv "GUILE_AUTO_COMPILE" "0")
- #t)))))
+ #t))
+ (add-after 'install 'wrap-binaries
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ "guile" "-c"
+ "(display (effective-version))")))
+ (deps (map (cut assoc-ref inputs <>) '("guile-lib" "guile-readline")))
+ (scm-path (map (cut string-append <> "/share/guile/site/" effective) `(,out ,@deps)))
+ (go-path (map (cut string-append <> "/lib/guile/" effective "/site-ccache/") `(,out ,@deps)))
+ (examples (filter (cut string-match "emacsy" <>)
+ (scandir (string-append out "/bin/"))))
+ (progs (map (cut string-append out "/bin/" <>)
+ examples)))
+ (map (cut wrap-program <>
+ `("GUILE_LOAD_PATH" ":" prefix ,scm-path)
+ `("GUILE_LOAD_COMPILED_PATH" ":" prefix ,go-path)) progs)
+ #t))))))
(home-page "https://savannah.nongnu.org/projects/emacsy")
(synopsis "Embeddable GNU Emacs-like library using Guile")
(description
--
2.22.1
Mike Rosset wrote 6 years ago
(name . Amar Singh)(address . nly@disroot.org)(address . 37094@debbugs.gnu.org)
CADaV+2U4Pr_NXGTW6xKALf3i=9wiRA8TPW27ACb+9impOnzObA@mail.gmail.com
use version 0.1.0-alpha as version and git tag.

On Wed, Aug 21, 2019 at 1:34 AM Amar Singh <nly@disroot.org> wrote:
Toggle quote (9 lines)
>
>
> After a few suggestions from Mike and Janneke:
> 1. Rename guile-emacsy --> emacsy-minimal
> 2. Removed glib-or-gtk-build-system in patch 004
>
> cheers,
> amar
>
From 8fac69d6f6e0d40411093bf84aa89302a84c0743 Mon Sep 17 00:00:00 2001
From: Mike Rosset <mike.rosset@gmail.com>
Date: Wed, 21 Aug 2019 09:42:57 -0700
Subject: [PATCH 5/5] gnu: nomad: Update to 0.1.0-alpha.

* gnu/packages/guile-xyz.scm (nomad): Update to 0.1.0-alpha.

use git tag 0.1.0-alpha so nomad version conforms to semver
---
gnu/packages/guile-xyz.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (15 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 88fc2eef2a..4f1a1ee10b 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2473,7 +2473,7 @@ perform geometrical transforms on JPEG images.")
(define-public nomad
(package
(name "nomad")
- (version "v0.1.0-alpha")
+ (version "0.1.0-alpha")
(source (origin
(method git-fetch)
(uri (git-reference
--
2.20.1
Mike Rosset wrote 6 years ago
(name . Amar Singh)(address . nly@disroot.org)(address . 37094@debbugs.gnu.org)
CADaV+2U=PcMJHsZkN4wEOupFUHvnkDuGj_psjG28RoVVCnkvPA@mail.gmail.com
Minor version bump to address outdated README and some minor fix's

On Wed, Aug 21, 2019 at 1:34 AM Amar Singh <nly@disroot.org> wrote:
Toggle quote (9 lines)
>
>
> After a few suggestions from Mike and Janneke:
> 1. Rename guile-emacsy --> emacsy-minimal
> 2. Removed glib-or-gtk-build-system in patch 004
>
> cheers,
> amar
>
From 805210959a2a478e862e5687ab2aaf966317ee99 Mon Sep 17 00:00:00 2001
From: Mike Rosset <mike.rosset@gmail.com>
Date: Thu, 22 Aug 2019 09:44:41 -0700
Subject: [PATCH 6/6] gnu: nomad: Update to 0.1.1-alpha.

* gnu/packages/guile-xyz.scm (nomad): Update to 0.1.1-alpha.
---
gnu/packages/guile-xyz.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 4f1a1ee10b..5d0c08ff61 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -2473,7 +2473,7 @@ perform geometrical transforms on JPEG images.")
(define-public nomad
(package
(name "nomad")
- (version "0.1.0-alpha")
+ (version "0.1.1-alpha")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -2482,7 +2482,7 @@ perform geometrical transforms on JPEG images.")
(file-name (git-file-name name version))
(sha256
(base32
- "0bffysgq3swpx2qyi8fnkyjfsla92haqhdq17m31wa3yzkpqq3a6"))))
+ "0abz07hl5dh802ciy71xzkvkhyryypq1i94wna40a2wndbd73f7z"))))
(build-system gnu-build-system)
(native-inputs
`(("autoconf" ,autoconf)
--
2.20.1
Ludovic Courtès wrote 6 years ago
Re: [bug#37094] [PATCH 1-3/3] Add nomad
(name . Amar Singh)(address . nly@disroot.org)
87blwdvunh.fsf@gnu.org
Hello!

Amar Singh <nly@disroot.org> skribis:

Toggle quote (4 lines)
> After a few suggestions from Mike and Janneke:
> 1. Rename guile-emacsy --> emacsy-minimal
> 2. Removed glib-or-gtk-build-system in patch 004

Nice! Janneke, could you take a look and apply the Emacsy patches?

I’ve applied the Shroud patch.

Thanks,
Ludo’.
Jan Nieuwenhuizen wrote 6 years ago
(name . Amar Singh)(address . nly@disroot.org)
87ftlmabrt.fsf@gnu.org
Amar Singh writes:

Hello,

Toggle quote (10 lines)
> After a few suggestions from Mike and Janneke:
> 1. Rename guile-emacsy --> emacsy-minimal
> 2. Removed glib-or-gtk-build-system in patch 004
>
> cheers,
> amar
>
>>From 7040563cb1386c672c75ddb141b235d5895adfdf Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>

Your attachments start with an escaped `>From' line, it's long ago that
I saw those in emails, any idea where they come from?

Toggle quote (4 lines)
> Date: Mon, 8 Jul 2019 12:04:56 +0530
> Subject: [PATCH 1/4] gnu: Add emacsy-minimal.
>
> * (guile-emacsy): New variable.
^extra space

I have removed the extra space, we want just one here.

Toggle quote (5 lines)
> +++ b/gnu/packages/guile-xyz.scm
> @@ -2377,6 +2377,36 @@ comes with a simple counter example using FreeGLUT and browser examples
> in C using Gtk+-3 and WebKitGtk.")
> (license license:gpl3+)))

I have added:

@@ -21,6 +21,7 @@
;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
+;;; Copyright © 2019 Amar Singh <nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;

Note the use of © instead of (C), no `by' and a space after your name.

For the rest, LGTM.

Toggle quote (20 lines)
>>From ede5e0fd3234d82bd7158f0a58f58efc27d26850 Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Wed, 10 Jul 2019 16:46:35 +0530
> Subject: [PATCH 3/4] gnu: Add nomad.
>
> * gnu/packages/guile-xyz.scm (nomad): New variable.
> ---
> gnu/packages/guile-xyz.scm | 91 ++++++++++++++++++++++++++++++++++++++
> 1 file changed, 91 insertions(+)
>
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index 77a765b52c..573dd461ad 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -58,6 +58,7 @@
> #:use-module (gnu packages gperf)
> #:use-module (gnu packages gtk)
> #:use-module (gnu packages guile)
> + #:use-module (gnu packages gnupg)

I have put this in its alphabetical place

@@ -56,6 +56,7 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
#:use-module (gnu packages gnome)
+ #:use-module (gnu packages gnupg)
#:use-module (gnu packages gperf)
#:use-module (gnu packages gtk)
#:use-module (gnu packages guile)

Toggle quote (2 lines)
> + (version "v0.1.0-alpha")

and from here on, merged Mike's update.

Toggle quote (5 lines)
>>From b082d2b141f87f91330e8416c40622b6213c9c9c Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Wed, 10 Jul 2019 16:45:50 +0530
> Subject: [PATCH 4/4] gnu: emacsy: cleanup build

I have changed this to

gnu: emacsy: Cleanup build.


Toggle quote (19 lines)
> fix conflicts; emacsy requires guile-2.2.4 but found guile-2.2.6 in profile etc.
>
> build: add phase 'wrap-binaries
> bulid: glib-or-gtk-build-system wraps binaries to work with glib or gtk
> propagated-inputs: remove all but glib-network and gsettings
> ---
> gnu/packages/guile-xyz.scm | 37 ++++++++++++++++++++++++++++++++-----
> 1 file changed, 32 insertions(+), 5 deletions(-)
>
> diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
> index 573dd461ad..88fc2eef2a 100644
> --- a/gnu/packages/guile-xyz.scm
> +++ b/gnu/packages/guile-xyz.scm
> @@ -21,6 +21,7 @@
> ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
> ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
> ;;; Copyright © 2019 swedebugia <swedebugia@riseup.net>
> +;;; Copyright (C) 2019 by Amar Singh<nly@disroot.org>

Removed this bit, see remarks above.

Toggle quote (4 lines)
> + (propagated-inputs
> + `(("glib-networking" ,glib-networking)
> + ("gssettings-desktop-schemas" ,gsettings-desktop-schemas)))

I have added ("glib" ,glib), which fixes

Settings schema 'org.gnome.system.proxy' is not installed

Toggle quote (11 lines)
> + (add-after 'install 'wrap-binaries
> + (lambda* (#:key inputs outputs #:allow-other-keys)
> + (let* ((out (assoc-ref outputs "out"))
> + (effective (read-line
> + (open-pipe* OPEN_READ
> + "guile" "-c"
> + "(display (effective-version))")))
> + (deps (map (cut assoc-ref inputs <>) '("guile-lib" "guile-readline")))
> + (scm-path (map (cut string-append <> "/share/guile/site/" effective) `(,out ,@deps)))
> + (go-path (map (cut string-append <> "/lib/guile/" effective "/site-ccache/") `(,out ,@deps)))

I have reformatted this to not exceed 80 columns.

Thanks, I'm very excited to have nomad in Guix!

Pushed to master as 114f02bac47d86c04bf211e33864beffcde74aab

Greetings,
janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
Closed
Jan Nieuwenhuizen wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)
87blwaabm7.fsf@gnu.org
Ludovic Courtès writes:

Toggle quote (6 lines)
>> After a few suggestions from Mike and Janneke:
>> 1. Rename guile-emacsy --> emacsy-minimal
>> 2. Removed glib-or-gtk-build-system in patch 004
>
> Nice! Janneke, could you take a look and apply the Emacsy patches?

Thanks for the ping/encouragement.

Toggle quote (2 lines)
> I’ve applied the Shroud patch.

Thanks, done.

janneke

--
Jan Nieuwenhuizen <janneke@gnu.org> | GNU LilyPond http://lilypond.org
Freelance IT http://JoyofSource.com| Avatar® http://AvatarAcademy.com
Amar Singh wrote 6 years ago
(name . Jan Nieuwenhuizen)(address . janneke@gnu.org)
485430CD-CF6D-4E4E-88AF-8F1CAB798685@disroot.org
Your attachments start with an escaped `>From' line, it's long ago that
I saw those in emails, any idea where they come from?

Sorry, I don't have any idea. I use Emacs and K-9(Android) for mails.

Nomad in Guix, awesome!

Thanks,
Amar Singh<nly@disroot.org>
----------------
Sent fromK-9 Mail. Please excuse my brevity.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37094@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37094
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help