[PATCH] packages: Apply target triplet in bag-transitive-host-inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • David Thompson
  • Ludovic Courtès
Owner
unassigned
Submitted by
David Thompson
Severity
normal

Debbugs page

David Thompson wrote 6 years ago
(address . guix-patches@gnu.org)(name . David Thompson)(address . dthompson2@worcester.edu)
20190814125755.18360-1-dthompson2@worcester.edu
Fixes a bug where propagated inputs that should be cross-compiled are instead
compiled for the host system.

* guix/packages.scm (bag-transitive-host-inputs): Call transitive-inputs in
the context of the bag's target system triplet.
---
guix/packages.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (16 lines)
diff --git a/guix/packages.scm b/guix/packages.scm
index c94a651f27..143417b861 100644
--- a/guix/packages.scm
+++ b/guix/packages.scm
@@ -796,7 +796,8 @@ dependencies are known to build on SYSTEM."
(define (bag-transitive-host-inputs bag)
"Same as 'package-transitive-target-inputs', but applied to a bag."
- (transitive-inputs (bag-host-inputs bag)))
+ (parameterize ((%current-target-system (bag-target bag)))
+ (transitive-inputs (bag-host-inputs bag))))
(define (bag-transitive-target-inputs bag)
"Return the \"target inputs\" of BAG, recursively."
--
2.17.1
Ludovic Courtès wrote 6 years ago
(name . David Thompson)(address . dthompson2@worcester.edu)(address . 37026@debbugs.gnu.org)
87r25bzi03.fsf@gnu.org
Hello,

David Thompson <dthompson2@worcester.edu> skribis:

Toggle quote (21 lines)
> Fixes a bug where propagated inputs that should be cross-compiled are instead
> compiled for the host system.
>
> * guix/packages.scm (bag-transitive-host-inputs): Call transitive-inputs in
> the context of the bag's target system triplet.
> ---
> guix/packages.scm | 3 ++-
> 1 file changed, 2 insertions(+), 1 deletion(-)
>
> diff --git a/guix/packages.scm b/guix/packages.scm
> index c94a651f27..143417b861 100644
> --- a/guix/packages.scm
> +++ b/guix/packages.scm
> @@ -796,7 +796,8 @@ dependencies are known to build on SYSTEM."
>
> (define (bag-transitive-host-inputs bag)
> "Same as 'package-transitive-target-inputs', but applied to a bag."
> - (transitive-inputs (bag-host-inputs bag)))
> + (parameterize ((%current-target-system (bag-target bag)))
> + (transitive-inputs (bag-host-inputs bag))))

Good catch, please push!

Thanks,
Ludo’.
Thompson, David wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 37026-done@debbugs.gnu.org)
CAJ=RwfbSiu3Lb=msH4iKe_gSGVux56Yj+Uq+4x1gvS=1bF7QYA@mail.gmail.com
On Fri, Aug 23, 2019 at 5:31 PM Ludovic Courtès <ludo@gnu.org> wrote:
Toggle quote (3 lines)
>
> Good catch, please push!

Thanks. Done!

- Dave
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 37026@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 37026
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help