Some importer tests failing?

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Lemmer Webber
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Christopher Lemmer Webber
Severity
normal

Debbugs page

Christopher Lemmer Webber wrote 6 years ago
(name . bug-guix)(address . bug-guix@gnu.org)
87y304oi60.fsf@dustycloud.org
A number of tests, including in cpan.scm, crate.scm, gem.scm are
failing for me. Not sure if it's just me or not...

Some example output:

actual-value: #f
actual-error:
+ (wrong-type-arg
+ "string-prefix?"
+ "Wrong type argument in position ~A (expecting ~A): ~S"
+ (2 "string" #f)
+ (#f))
result: FAIL

;;; (fail #f #f)
actual-value: #f
result: FAIL

actual-value: #f
actual-error:
+ (wrong-type-arg
+ "string-prefix?"
+ "Wrong type argument in position ~A (expecting ~A): ~S"
+ (2 "string" #f)
+ (#f))
result: FAIL

I'm guessing something changed in the general importer code?
Ricardo Wurmus wrote 6 years ago
(name . Christopher Lemmer Webber)(address . cwebber@dustycloud.org)(address . 36964-done@debbugs.gnu.org)
8736icyb94.fsf@elephly.net
Christopher Lemmer Webber <cwebber@dustycloud.org> writes:

Toggle quote (3 lines)
> A number of tests, including in cpan.scm, crate.scm, gem.scm are
> failing for me. Not sure if it's just me or not...

I think it’s just you. You’re probably doing this in “guix environment
guix”, which gives you guile-json@1. We have since switched to
guile-json@3.

(This has previously been reported.)

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36964@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36964
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help