Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
GNOME Control Center should now display the correct GNOME version and graphics
information in the "Details > About" panel.
* gnu/packages/gnome.scm (gnome-control-center)[arguments]: Add configure
flag. Adjust 'patch-paths' phase accordingly.
[inputs]: Add gnome-session.
---
gnu/packages/gnome.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)
Toggle diff (47 lines)
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 3f7bbac214..72b88c73c3 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5915,7 +5915,10 @@ devices using the GNOME desktop.")
(arguments
'(#:glib-or-gtk? #t
#:configure-flags
- (list "-Dcheese=false")
+ (list "-Dcheese=false"
+ (string-append "-Dgnome_session_libexecdir="
+ (assoc-ref %build-inputs "gnome-session")
+ "/libexec"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'patch-paths
@@ -5923,7 +5926,8 @@ devices using the GNOME desktop.")
(let ((libc (assoc-ref inputs "libc"))
(tzdata (assoc-ref inputs "tzdata"))
(libgnomekbd (assoc-ref inputs "libgnomekbd"))
- (nm-applet (assoc-ref inputs "network-manager-applet")))
+ (nm-applet (assoc-ref inputs "network-manager-applet"))
+ (gnome-desktop (assoc-ref inputs "gnome-desktop")))
(substitute* "panels/datetime/tz.h"
(("/usr/share/zoneinfo/zone.tab")
(string-append tzdata "/share/zoneinfo/zone.tab")))
@@ -5943,6 +5947,10 @@ devices using the GNOME desktop.")
(substitute* '("panels/user-accounts/run-passwd.c")
(("/usr/bin/passwd")
"/run/setuid-programs/passwd"))
+ (substitute* "panels/info/cc-info-overview-panel.c"
+ (("DATADIR \"/gnome/gnome-version.xml\"")
+ (string-append "\"" gnome-desktop
+ "/share/gnome/gnome-version.xml\"")))
#t))))))
(native-inputs
`(("glib:bin" ,glib "bin") ; for glib-mkenums, etc.
@@ -5962,6 +5970,7 @@ devices using the GNOME desktop.")
("gnome-desktop" ,gnome-desktop)
("gnome-online-accounts" ,gnome-online-accounts)
("gnome-online-accounts:lib" ,gnome-online-accounts "lib")
+ ("gnome-session" ,gnome-session)
("gnome-settings-daemon" ,gnome-settings-daemon)
("grilo" ,grilo)
("ibus" ,ibus)
--
2.22.0