[PATCH] gnu: add lxqt-archiver

  • Done
  • quality assurance status badge
Details
One participant
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 1 Aug 2019 18:07
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20190801160725.30347-1-r.majd@pantherx.org
* gnu/packages/lxqt.scm (lxqt-archiver): New Variable.
---
gnu/packages/lxqt.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a8699b3d09..fe6e71971d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1245,6 +1245,38 @@ easily publishing them on internet image hosting services.")
(license license:gpl2+)))
+(define-public lxqt-archiver
+ (package
+ (name "lxqt-archiver")
+ (version "0.0.96")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/lxqt/" name ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09rw774vxj96wcpxxncz6nr9bmw7l4l0kwylmz1saq6rpa2yvn2i"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("libfm-qt" ,libfm-qt)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://lxqt.org/")
+ (synopsis "Simple & lightweight desktop-agnostic Qt file archiver")
+ (description "Simple & lightweight desktop-agnostic Qt file archiver.
+This is only a front-end (a graphical interface) to archiving programs like tar and zip.")
+ (license license:gpl2+)))
+
;; The LXQt Desktop Environment
(define-public lxqt
--
2.19.0
R
R
Reza Alizadeh Majd wrote on 1 Aug 2019 18:18
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
50ce2fe9-9b70-4800-8b58-0f751b42cb1b@www.fastmail.com
close 36891
archive 36891
quit
R
R
Reza Alizadeh Majd wrote on 1 Aug 2019 18:22
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
36e065a3-2a33-4803-a0fc-3f99a2a793c8@www.fastmail.com
unarchive 36891
R
R
R
Reza Alizadeh Majd wrote on 1 Aug 2019 18:30
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
b2703dd1-130d-45b4-9ad0-7d6cf005cf84@www.fastmail.com
archive 36891
?