[PATCH] gnu: add lxqt-archiver

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Reza Alizadeh Majd
Owner
unassigned
Submitted by
Reza Alizadeh Majd
Severity
normal
R
R
Reza Alizadeh Majd wrote on 1 Aug 2019 17:59
(address . guix-patches@gnu.org)(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)
20190801155906.29506-1-r.majd@pantherx.org
* gnu/packages/lxqt.scm (lxqt-archiver): New Variable.
---
gnu/packages/lxqt.scm | 32 ++++++++++++++++++++++++++++++++
1 file changed, 32 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a8699b3d09..fe6e71971d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1245,6 +1245,38 @@ easily publishing them on internet image hosting services.")
(license license:gpl2+)))
+(define-public lxqt-archiver
+ (package
+ (name "lxqt-archiver")
+ (version "0.0.96")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/lxqt/" name ".git"))
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "09rw774vxj96wcpxxncz6nr9bmw7l4l0kwylmz1saq6rpa2yvn2i"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("json-glib" ,json-glib)
+ ("libfm-qt" ,libfm-qt)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f))
+ (home-page "https://lxqt.org/")
+ (synopsis "Simple & lightweight desktop-agnostic Qt file archiver")
+ (description "Simple & lightweight desktop-agnostic Qt file archiver.
+This is only a front-end (a graphical interface) to archiving programs like tar and zip.")
+ (license license:gpl2+)))
+
;; The LXQt Desktop Environment
(define-public lxqt
--
2.19.0
L
L
Ludovic Courtès wrote on 22 Aug 2019 17:51
(name . Reza Alizadeh Majd)(address . r.majd@pantherx.org)(address . 36890-done@debbugs.gnu.org)
87h869p59v.fsf@gnu.org
Hello,

Reza Alizadeh Majd <r.majd@pantherx.org> skribis:

Toggle quote (2 lines)
> * gnu/packages/lxqt.scm (lxqt-archiver): New Variable.

Applied with the minor tweaks below.

Thank you!

Ludo’.
Toggle diff (16 lines)
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index fe6e71971d..e72f5b82d9 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -1273,8 +1273,9 @@ easily publishing them on internet image hosting services.")
'(#:tests? #f))
(home-page "https://lxqt.org/")
(synopsis "Simple & lightweight desktop-agnostic Qt file archiver")
- (description "Simple & lightweight desktop-agnostic Qt file archiver.
-This is only a front-end (a graphical interface) to archiving programs like tar and zip.")
+ (description
+ "This package provides a Qt graphical interface to archiving programs
+like @command{tar} and @command{zip}.")
(license license:gpl2+)))
;; The LXQt Desktop Environment
Closed
?