Guix graphical installation failure on all drives with size > 1 TiB

  • Done
  • quality assurance status badge
Details
3 participants
  • Danny Milosavljevic
  • Mathieu Othacehe
  • Mathieu Othacehe
Owner
unassigned
Submitted by
Danny Milosavljevic
Severity
normal

Debbugs page

Danny Milosavljevic wrote 6 years ago
20190724145558.1d854ed9@scratchpost.org
Hi,

using the Guix graphical installation method, one cannot install Guix on a drive
with more than 1 TiB. (symptom: "null pointer dereference" in mkpart)

The reason is a bug in guile-parted.

An example is to use the "separate /home" option with a 2 TiB disk.

The fix that lets me install is:


Toggle diff (19 lines)
diff --git a/parted/unit.scm b/parted/unit.scm
index 6818b7e..68862a8 100644
--- a/parted/unit.scm
+++ b/parted/unit.scm
@@ -147,7 +147,7 @@
out-range)))
(if (return-int->bool result)
(values (car
- (parse-c-struct c-sector (list int)))
+ (parse-c-struct c-sector (list sector-type)))
(pointer->geometry
(dereference-pointer out-range)))
(values #f #f)))))

However, even after that, disk-print, if used, prints nonsensical (negative)
values for "free" (but installation succeeds).

That bug prevents graphical installation on any drive bigger than 1 TiB.
Let's make a bugfix Guix release shortly.
Mathieu Othacehe wrote 6 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . bug-guix@gnu.org)
87y30nif7n.fsf@gmail.com
Hello Danny,

Toggle quote (6 lines)
> However, even after that, disk-print, if used, prints nonsensical (negative)
> values for "free" (but installation succeeds).
>
> That bug prevents graphical installation on any drive bigger than 1 TiB.
> Let's make a bugfix Guix release shortly.

Your fix seems ok for me, thank you! I don't get why you negative values
though. I'll try to find a big hard drive to understand this before
pushing this patch.

Thanks,

Mathieu
Mathieu Othacehe wrote 5 years ago
(name . Danny Milosavljevic)(address . dannym@scratchpost.org)(address . 36783@debbugs.gnu.org)
87mu7fn58u.fsf@gmail.com
Hello,

Toggle quote (4 lines)
> Your fix seems ok for me, thank you! I don't get why you negative values
> though. I'll try to find a big hard drive to understand this before
> pushing this patch.

I still don't have a big enough hard drive to test it, but I applied
your patch anyway. If someone with hard drive > 1 TiB is willing to
investigate why:

Toggle snippet (3 lines)
[disk-print] prints nonsensical (negative) values for "free"

that would be nice :)

Thanks,

Mathieu
Mathieu Othacehe wrote 5 years ago
control message for bug #36783
(address . control@debbugs.gnu.org)
87bljx81zp.fsf@cervin.i-did-not-set--mail-host-address--so-tickle-me
close 36783
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36783@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36783
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help