feature request: checked variant of "substitute*"

  • Open
  • quality assurance status badge
Details
3 participants
  • Ludovic Courtès
  • Ricardo Wurmus
  • Robert Vollmert
Owner
unassigned
Submitted by
Robert Vollmert
Severity
wishlist
R
R
Robert Vollmert wrote on 23 Jul 2019 14:49
(address . bug-guix@gnu.org)
E8613602-3151-405B-AC42-20D0A2CAD299@vllmrt.net
I think it would be great to have the following variant of substitute*:

(substitute*-once filename (pattern vars) body)

which acts like the usual substitute-*, except it also asserts that the
substitution applies to exactly one line in the file, causing a build
failure otherwise.

In the cases where this is sufficient (I believe most), it would make
substitution work quite a bit more reliably, making it both easier to
debug substitution when first packaging, and noticing more easily when
they need to be adapted on upgrades.

(It would be possible to make the signature a bit more flexible and to
allow multiple files or patterns as in substitute*, but that would
make the meaning of “applies exactly once” a bit unclear, so I’d prefer
to not do that. Similarly, I find it cleaner to potentially call
substitute*-once several times in a row with different substitutions to
make the ordering of effects explicit.)

(I’d be happy to supply a patch myself eventually, but the syntax rule
business is a bit out of reach at this point.)
R
R
Ricardo Wurmus wrote on 23 Jul 2019 15:35
(name . Robert Vollmert)(address . rob@vllmrt.net)(address . 36772@debbugs.gnu.org)
87zhl4c1rc.fsf@elephly.net
Hi Robert,

Toggle quote (8 lines)
> I think it would be great to have the following variant of substitute*:
>
> (substitute*-once filename (pattern vars) body)
>
> which acts like the usual substitute-*, except it also asserts that the
> substitution applies to exactly one line in the file, causing a build
> failure otherwise.

I agree that the effect of substitute* should be checked. I think
substitute* should fail when one of its clauses failed to match
anything.

Each clause could also accept an optional argument to make them only
match one location. We wouldn’t have to duplicate the macro for that
and it’s a simple extension to failing on zero matches.

What do you think?

--
Ricardo
R
R
Robert Vollmert wrote on 23 Jul 2019 15:41
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 36772@debbugs.gnu.org)
15DD757F-8CCE-4092-925C-0B76824B5E47@vllmrt.net
Toggle quote (23 lines)
> On 23. Jul 2019, at 15:35, Ricardo Wurmus <rekado@elephly.net> wrote:
>
>
> Hi Robert,
>
>> I think it would be great to have the following variant of substitute*:
>>
>> (substitute*-once filename (pattern vars) body)
>>
>> which acts like the usual substitute-*, except it also asserts that the
>> substitution applies to exactly one line in the file, causing a build
>> failure otherwise.
>
> I agree that the effect of substitute* should be checked. I think
> substitute* should fail when one of its clauses failed to match
> anything.
>
> Each clause could also accept an optional argument to make them only
> match one location. We wouldn’t have to duplicate the macro for that
> and it’s a simple extension to failing on zero matches.
>
> What do you think?

That sounds like a good improvement, too. I think the important part is
ensuring the substitution matches at all, maybe we could leave out the
“at most once” part. (I doubt it would be used a lot if it’s not the default.)

Cheers
Robert
L
L
Ludovic Courtès wrote on 25 Jul 2019 19:40
(name . Ricardo Wurmus)(address . rekado@elephly.net)
875znqrp0f.fsf@gnu.org
Hi,

Ricardo Wurmus <rekado@elephly.net> skribis:

Toggle quote (18 lines)
>> I think it would be great to have the following variant of substitute*:
>>
>> (substitute*-once filename (pattern vars) body)
>>
>> which acts like the usual substitute-*, except it also asserts that the
>> substitution applies to exactly one line in the file, causing a build
>> failure otherwise.
>
> I agree that the effect of substitute* should be checked. I think
> substitute* should fail when one of its clauses failed to match
> anything.
>
> Each clause could also accept an optional argument to make them only
> match one location. We wouldn’t have to duplicate the macro for that
> and it’s a simple extension to failing on zero matches.
>
> What do you think?

That’d be a useful extension.

Ludo’.
?