Arun Isaac wrote 6 years ago
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
* gnu/packages/audio.scm (gnaural): New variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)
Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3168a97414..86967beb64 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3723,3 +3724,32 @@ library.")
(description "FAudio is an XAudio reimplementation that focuses solely on
developing fully accurate DirectX Audio runtime libraries.")
(license license:zlib)))
+
+(define-public gnaural
+ (package
+ (name "gnaural")
+ (version "20110606")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnaural/Gnaural/gnaural_"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1gq519c0imsh57zklyi0f8h64l3ai48lh672c834470z8c6kvbfi"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("gtk+" ,gtk+-2)
+ ("libsndfile" ,libsndfile)
+ ("portaudio" ,portaudio)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://gnaural.sourceforge.net/")
+ (synopsis "Binaural beat synthesizer")
+ (description "Gnaural is a programmable auditory binaural beat synthesizer
+intended to be used for brainwave entrainment. Gnaural supports creation of
+binaural beat tracks of different frequencies and exporting of tracks into
+different audio formats. Gnaural can also be linked over the internet with
+other Gnaural instances, allowing synchronous sessions between many users.")
+ (license license:gpl2+)))
--
2.22.0