[PATCH] gnu: Add gnaural.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Marius Bakke
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal

Debbugs page

Arun Isaac wrote 6 years ago
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
20190715161212.8087-1-arunisaac@systemreboot.net
* gnu/packages/audio.scm (gnaural): New variable.
---
gnu/packages/audio.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (47 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 3168a97414..86967beb64 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -21,6 +21,7 @@
;;; Copyright © 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
;;; Copyright © 2019 Rutger Helling <rhelling@mykolab.com>
+;;; Copyright © 2019 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3723,3 +3724,32 @@ library.")
(description "FAudio is an XAudio reimplementation that focuses solely on
developing fully accurate DirectX Audio runtime libraries.")
(license license:zlib)))
+
+(define-public gnaural
+ (package
+ (name "gnaural")
+ (version "20110606")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/gnaural/Gnaural/gnaural_"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1gq519c0imsh57zklyi0f8h64l3ai48lh672c834470z8c6kvbfi"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("alsa-lib" ,alsa-lib)
+ ("gtk+" ,gtk+-2)
+ ("libsndfile" ,libsndfile)
+ ("portaudio" ,portaudio)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (home-page "http://gnaural.sourceforge.net/")
+ (synopsis "Binaural beat synthesizer")
+ (description "Gnaural is a programmable auditory binaural beat synthesizer
+intended to be used for brainwave entrainment. Gnaural supports creation of
+binaural beat tracks of different frequencies and exporting of tracks into
+different audio formats. Gnaural can also be linked over the internet with
+other Gnaural instances, allowing synchronous sessions between many users.")
+ (license license:gpl2+)))
--
2.22.0
Marius Bakke wrote 6 years ago
87lfwx6gq2.fsf@devup.no
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (2 lines)
> * gnu/packages/audio.scm (gnaural): New variable.

LGTM.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl0uBtUACgkQoqBt8qM6
VPp8Zgf/XhgTWwaU2BsjKNY5NOHJY4LPbt0D9qWtsOZnY1r4P1jJEqDpyQ+l5/vN
87zC/8E42Q6m753lEqw/bowiFunALqivyS9o81gFUW5ZDhXdC+WKWl1+ZXLEm0KA
qxQOJqs26onrbV9kI+7NXwbJI17tFfWnxeYAUoy0tLawdyVVoZfzCtfrOPTE/EUx
JQaF3i1p1It5087WlB8/lZI3S7FyBxeo3Y7XniwDfAPGWuA0vVaqL3d4PgUp7xZZ
GMQRMjlmGAD+4xWfLyqKywDHb8Z0ed3Iw7YGvWSEev0oKG/IhhsEG4ln2mdSNpg+
Qd1ktz0VppIFt6rGKCjZpVCw5K/FdQ==
=EstR
-----END PGP SIGNATURE-----

Arun Isaac wrote 6 years ago
cu7ftn5glab.fsf@systemreboot.net
Thanks for the review, pushed to master!
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCAAdFiEEf3MDQ/Lwnzx3v3nTLiXui2GAK7MFAl0u0TwACgkQLiXui2GA
K7PiTgf/UiJoCo5NBljl51NAA+ZvD6FQYDK4nZa4CS+jejBh/6jwpG79B7uz9ClM
R4sQka2lOvlZdFpZGIc0D06M5n778SBOjTornQYulgYc7kz1FDwUP3LI4LGtIW4o
vR/W7pd48dAJRFJMoWakiW52h2P2yF03f1Nyhwqt83IwfIq75tmXXl1W+qbjHxAP
LnxffffwI3PUpdSpFfGLzuP5CEuqvsum1P8xnR802PIj8sp7qcUNdqjrQ4o+svKU
urjZRpYTdJMVXSoutzlDmhEo8VU0CqXEF7Cvxod04nOjOApx4R4UIuQS2kTi6HvP
+ElA/0WWzqREFcIJMBlLJDc4MmC7fQ==
=zUcD
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36669@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36669
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help