[PATCH 2/2] gnu: python-gst: Fix build failure.

  • Done
  • quality assurance status badge
Details
One participant
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190713220102.7416-2-mail@cbaines.net
Building python-gst fails with:

Unbound variable: python-version

Therefore, add python-build-system to #:modules so that it's imported, and
give it a prefix to avoid clashing with the gnu-build-system.

Also, simplify the code by using the site-packages function from the
python-build-system module.

* gnu/packages/gstreamer.scm (python-gst)[arguments]: Rework to fix build
failure.
---
gnu/packages/gstreamer.scm | 15 ++++++---------
1 file changed, 6 insertions(+), 9 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index b0f0b032b3..efb9a6f796 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -431,17 +431,14 @@ compression formats through the use of the libav library.")
"0f1d9rvy2qxlymmfzyknnfr5rz1vx69jv17gp7wnamc5s6p7mp2m"))))
(build-system gnu-build-system)
(arguments
- ;; XXX: Factorize python-sitedir with python-build-system.
- `(#:imported-modules (,@%gnu-build-system-modules
+ `(#:modules ((guix build gnu-build-system)
+ ((guix build python-build-system) #:prefix python:))
+ #:imported-modules (,@%gnu-build-system-modules
(guix build python-build-system))
#:configure-flags
- (let* ((python (assoc-ref %build-inputs "python"))
- (python-version (python-version python))
- (python-sitedir (string-append
- "lib/python" python-version "/site-packages")))
- (list (string-append
- "--with-pygi-overrides-dir=" %output "/" python-sitedir
- "/gi/overrides")))))
+ (list (string-append
+ "--with-pygi-overrides-dir=" %output "/"
+ (python:site-packages %build-inputs %outputs) "/gi/overrides"))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python" ,python)))
--
2.22.0
Christopher Baines wrote 6 years ago
(address . 36642-done@debbugs.gnu.org)
87sgr9ziqz.fsf@cbaines.net
Closing, as this is a duplicate of [1].

-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl0qV1RfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XfoxQ/+KdInmaD4kNRBsw09A5GmOfvB3uqchjDkytjKeHzu/f9hW3I63+9vHKT8
YaHlXTaxpNKKqLmoRFRjchy0JoFEJ+px5comwjuvH6kedjDiU4KF3zustjvhjqD3
0RFr0QUNds66rBuIKNZ+LGPbi/Mxz/raKf9QiDCxWTq7SC6r0GlhD3bTnQ19kghz
yhACxAJlyZZDH2Ca1kEiJrdw16JkyRcMmVPdiqG8tCBfnkbQ36imSOTVZf/0QJRI
lwiIcDvguE0awI89Ii/cAG2Mly48++HyTjTL3V5dXmq8BhE1h2ctHGNLNZJTqPMP
5E1/uKhi4wzLzAQ64bV02aDzu8FE+JegBbN8QHzT0eLyspXfYLyJoIYRAf8EBvZO
FKGUS8Gxhr26xnRMgWYeyBhbRxE1FH2JVZ2Oh8Sos9TeUYMb3St+1fdrInapoyDf
KWoO3sKbG3iFZ2LY3LZrJCPEEu1+v/09F41iWys1Vn9/x6bs5wXKlCHGFP+5Pa7r
SyucJKjITzbZzFj8W50AH0PQ/RknP1nvu6e0hldDveg9e1Z640PyQLLw8LNiznPg
o5968+PwJrpSN03VgXrCSLi8lu5zLTb3rRBGzKy7MSMOxNr4Jh46VKYrUPY0wNUl
LeZ0SiUjXPYBaegNjGnNwdDv5pVQlpec3ZYtmP4E8dLEY0SOCGc=
=/8Xx
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36642@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36642
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help