(address . bug-guix@gnu.org)
- Mon 13 Jul 2019 02:22
- Mon 29 Jul 2019 19:59
- Mon 2 Aug 2019 00:16
- Mon 5 Aug 2019 03:25
- Ron 5 Aug 2019 21:36
- Mon 21 Aug 2019 12:34
- Ron 21 Aug 2019 22:38
ungoogled-chromium needs font-gnu-freefont-ttf
M
[Patch] add font-gnu-freefont-ttf propagated-inputs
(address . 36632@debbugs.gnu.org)
5ff60dda7f2e1a70c85832b51fa74dd3@riseup.net
hi this fixes bug 36632
---
gnu/packages/chromium.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (25 lines)
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index d072fc58ad..04ce780be0 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages compression)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
+ #:use-module (gnu packages fonts)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
@@ -763,6 +764,8 @@ from forcing GEXP-PROMISE."
("udev" ,eudev)
("valgrind" ,valgrind)
("vulkan-headers" ,vulkan-headers)))
+ (propagated-inputs
+ `(("font-gnu-freefont-ttf" ,font-gnu-freefont-ttf)))
;; Building Chromium takes ... a very long time. On a single core,
a busy
;; mid-end x86 system may need more than 24 hours to complete the
build.
--
2.22.0
M
Re: [Patch] add font-gnu-freefont-ttf propagated-inputs
(address . 36632@debbugs.gnu.org)
882789cfa85760cacd43617b3f5cea8a@riseup.net
On 2019-07-29 13:59, mjbecze@riseup.net wrote:
Toggle quote (31 lines)
> hi this fixes bug 36632
>
> ---
> gnu/packages/chromium.scm | 3 +++
> 1 file changed, 3 insertions(+)
>
> diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
> index d072fc58ad..04ce780be0 100644
> --- a/gnu/packages/chromium.scm
> +++ b/gnu/packages/chromium.scm
> @@ -35,6 +35,7 @@
> #:use-module (gnu packages compression)
> #:use-module (gnu packages cups)
> #:use-module (gnu packages curl)
> + #:use-module (gnu packages fonts)
> #:use-module (gnu packages fontutils)
> #:use-module (gnu packages freedesktop)
> #:use-module (gnu packages gcc)
> @@ -763,6 +764,8 @@ from forcing GEXP-PROMISE."
> ("udev" ,eudev)
> ("valgrind" ,valgrind)
> ("vulkan-headers" ,vulkan-headers)))
> + (propagated-inputs
> + `(("font-gnu-freefont-ttf" ,font-gnu-freefont-ttf)))
>
> ;; Building Chromium takes ... a very long time. On a single core,
> a busy
> ;; mid-end x86 system may need more than 24 hours to complete the
> build.
bump bump :)
R
Re: bug#36632: ungoogled-chromium needs font-gnu-freefont-ttf
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 36632@debbugs.gnu.org)
87a7cnz9on.fsf@elephly.net
Hi Martin,
Toggle quote (2 lines)
> ungoogled-chromium will crash until font-gnu-freefont-ttf is installed.
Thank you for reporting this problem and proposing a patch.
I’d prefer not to propagate any fonts. Do you happen to know what the
mechanism underlying the fix is? Why does this fix the problem? Why
does it crash in the first place?
Is this at all related to a stale font cache, perhaps?
--
Ricardo
M
(name . Ricardo Wurmus)(address . rekado@elephly.net)(address . 36632@debbugs.gnu.org)
3b327caa80991fcf6528f718bca8e718@riseup.net
On 2019-08-05 15:36, Ricardo Wurmus wrote:
Toggle quote (12 lines)
> Hi Martin,
>
>> ungoogled-chromium will crash until font-gnu-freefont-ttf is installed.
>
> Thank you for reporting this problem and proposing a patch.
>
> I’d prefer not to propagate any fonts. Do you happen to know what the
> mechanism underlying the fix is? Why does this fix the problem? Why
> does it crash in the first place?
>
> Is this at all related to a stale font cache, perhaps?
So i got a chance to dig into this a bit. chromium needs a ttf font and
there are no fonts installed yet, so defaintly not a stale cache issue.
Chrome is crashing here
Its using fontconfig i think. I have no idea how to get chromium to read
fonts from a custom path.
R
(name . Martin Becze)(address . mjbecze@riseup.net)(address . 36632@debbugs.gnu.org)
87h86al0dy.fsf@elephly.net
Hi Martin,
Toggle quote (7 lines)
> So i got a chance to dig into this a bit. chromium needs a ttf font and
> there are no fonts installed yet, so defaintly not a stale cache issue.
> Chrome is crashing here
> https://chromium.googlesource.com/chromium/src/+/master/ui/gfx/platform_font_skia.cc#97
> Its using fontconfig i think. I have no idea how to get chromium to read
> fonts from a custom path.
Can we arrange for a default font to be returned by fontconfig? Perhaps
the fix is not needed in Chromium but in fontconfig or our profile hooks?
--
Ricardo
?