[PATCH] gnu: shroud: Update to 0.1.2

  • Done
  • quality assurance status badge
Details
2 participants
  • Tobias Geerinckx-Rice
  • Amar Singh
Owner
unassigned
Submitted by
Amar Singh
Severity
normal
Merged with
A
A
Amar Singh wrote on 10 Jul 2019 16:29
(address . guix-patches@gnu.org)
85sgrenetp.fsf@disroot.org
Shroud now builds with Guile-2.2.
From 21bb1505f663084584ab5d61f32a6b168f64f3ca Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Wed, 10 Jul 2019 19:57:29 +0530
Subject: [PATCH] gnu: shroud: Update to 0.1.2.

* gnu/packages/password-utils.scm (shroud): Update to 0.1.2.

Shroud now builds with Guile-2.2.
---
gnu/packages/password-utils.scm | 42 +++++++++++++++++++++++++--------
1 file changed, 32 insertions(+), 10 deletions(-)

Toggle diff (74 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 49024b26c4..5c3cff64c9 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -50,6 +50,7 @@
#:use-module (gnu packages admin)
#:use-module (gnu packages aidc)
#:use-module (gnu packages authentication)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages base)
#:use-module (gnu packages check)
#:use-module (gnu packages compression)
@@ -236,28 +237,49 @@ platforms.")
(define-public shroud
(package
(name "shroud")
- (version "0.1.1")
+ (version "0.1.2")
(source (origin
(method url-fetch)
- (uri (string-append "https://files.dthompson.us/shroud/shroud-"
- version ".tar.gz"))
+ (uri (string-append "https://files.dthompson.us/"
+ name "/shroud-" version ".tar.gz"))
(sha256
(base32
- "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
+ "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("autoconf" ,autoconf-wrapper)
+ ("automake" ,automake)
+ ("gettext" ,gettext-minimal)))
(arguments
- '(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim)
+ (srfi srfi-26))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-shroud
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (ccachedir (string-append out "/lib/guile/2.0/ccache"))
- (prog (string-append out "/bin/shroud")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (guile (assoc-ref inputs "guile"))
+ (xclip (assoc-ref inputs "xclip"))
+ (prog (string-append out "/bin/shroud"))
+ (deps (list xclip))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (path (map (cut string-append <> "/bin")
+ (delete #f deps)))
+ (ccachedir (string-append out
+ "/lib/guile/" effective "/site-ccache")))
(wrap-program prog
+ `("PATH" ":" prefix ,path)
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
#t))))))
(inputs
- `(("guile" ,guile-2.0)
+ `(("guile" ,guile-2.2)
("gnupg" ,gnupg)
("xclip" ,xclip)))
(synopsis "GnuPG-based secret manager")
--
2.22.0
T
T
Tobias Geerinckx-Rice wrote on 10 Jul 2019 16:49
(no subject)
(name . GNU bug tracker automated control server)(address . control@debbugs.gnu.org)
87r26yymf0.fsf@nckx
merge 36576 36575
T
T
Tobias Geerinckx-Rice wrote on 10 Jul 2019 16:51
Re: [bug#36576] [PATCH] gnu: shroud: Update to 0.1.2
(address . 36576@debbugs.gnu.org)
87pnmiymb4.fsf@nckx
Amar,

Amar Singh wrote:
Toggle quote (2 lines)
> Shroud now builds with Guile-2.2.

Thanks!

I've merged this with your previous bug. If you use git
send-email, you can add patches to an existing bug report with
‘git send-email --to=nnnnn@debbugs.gnu.org …’.

Kind regards,

T G-R
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQT12iAyS4c9C3o4dnINsP+IT1VteQUCXSX7jwAKCRANsP+IT1Vt
eSh8AP96hrS1F8WKzANirxEPn4LM0JR15Adt0uiAI77pGbMBdgD7BBzFMgUJk/yQ
tVq2pKhteUZzX4ZGe+FEcbusb656VAY=
=43iB
-----END PGP SIGNATURE-----

A
A
Amar Singh wrote on 11 Aug 2019 00:17
[PATCH] gnu: shroud: Update to 0.1.2.
(address . 36576@debbugs.gnu.org)
85o90w4qd8.fsf@disroot.org
Update shroud to 0.1.2. Uses effective Guile-2.2 now. Remove hardcoded
'2.0' string.
From ea9cea9d3e179025156dfac7aece4286291dfe45 Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Sun, 11 Aug 2019 03:44:16 +0530
Subject: [PATCH] gnu: shroud: Update to 0.1.2.

* gnu/packages/password-utils.scm (shroud): Update to 0.1.2.

Shroud now builds with Guile-2.2. Remove hardcoded '2.0' string.
---
gnu/packages/password-utils.scm | 24 ++++++++++++++++++------
1 file changed, 18 insertions(+), 6 deletions(-)

Toggle diff (53 lines)
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 49024b26c4..6ca16025ef 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -236,28 +236,40 @@ platforms.")
(define-public shroud
(package
(name "shroud")
- (version "0.1.1")
+ (version "0.1.2")
(source (origin
(method url-fetch)
(uri (string-append "https://files.dthompson.us/shroud/shroud-"
version ".tar.gz"))
(sha256
(base32
- "1y43yhgy2zbrk5bqj3qyx9rkcz2bma9sinlrg7dip3jqms9gq4lr"))))
+ "1l2shrhvcwfzkar9qiwb75nhcqmx25iz55lzmz0c187nbjhqzi9p"))))
(build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(arguments
- '(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (ice-9 popen)
+ (ice-9 rdelim))
+ #:phases
(modify-phases %standard-phases
(add-after 'install 'wrap-shroud
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
- (ccachedir (string-append out "/lib/guile/2.0/ccache"))
+ (guile (assoc-ref inputs "guile"))
+ (effective (read-line
+ (open-pipe* OPEN_READ
+ (string-append guile "/bin/guile")
+ "-c" "(display (effective-version))")))
+ (ccachedir (string-append out
+ "/lib/guile/" effective "/site-ccache"))
(prog (string-append out "/bin/shroud")))
(wrap-program prog
`("GUILE_LOAD_COMPILED_PATH" ":" prefix (,ccachedir)))
#t))))))
(inputs
- `(("guile" ,guile-2.0)
+ `(("guile" ,guile-2.2)
("gnupg" ,gnupg)
("xclip" ,xclip)))
(synopsis "GnuPG-based secret manager")
--
2.22.0
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36576@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36576
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch