The installer recommends wrong initrd module names
(address . bug-guix@gnu.org)
Hi,
When I install Guix on a low end computer using the `guix system init`
command, the installer says that "mmc_block" and "sdhci_acpi" should be
added into initrd-modules:
#+begin_example
error: you may need these modules in the initrd for /dev/mmcblk0p2: mmc_block sdhci_acpi
hint: Try adding them to the `initrd-modules' field of your `operating-system' declaration, along these lines:
(operating-system
;; ...
(initrd-modules (append (list "mmc_block" "sdhci_acpi")
%base-initrd-modules)))
#+end_example
This computer has an eMMC disk, so this sounds reasonable. I made that
modification and the installation process succeeded. But when I boot
the computer, it complained that "sdhci_acpi" could not be found. After
spending hours digging around, I finally found out that the required
module name is actuall called "sdhci-acpi" rather than "sdhci_acpi".
The computer can successfully boot into Guix when I replace "sdhci_acpi"
with "sdhci-acpi" and reinstall Guix.
So the problem is that the Guix installer recommends wrong initrd module
names to user.
--
Meiyo Peng