[PATCH] gnu: Add s-tui.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Christopher Baines
Owner
unassigned
Submitted by
Christopher Baines
Severity
normal

Debbugs page

Christopher Baines wrote 6 years ago
(address . guix-patches@gnu.org)
20190707175503.11386-1-mail@cbaines.net
* gnu/packages/admin.scm (s-tui): New variable.
---
gnu/packages/admin.scm | 22 ++++++++++++++++++++++
1 file changed, 22 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 411be40f5b..98795966f1 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1453,6 +1453,28 @@ tables. This package contains only the user-space tools needed for ACPI table
development, not the kernel implementation of ACPI.")
(license license:gpl2))) ; dual GPLv2/ACPICA Licence
+(define-public s-tui
+ (package
+ (name "s-tui")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "s-tui" version))
+ (sha256
+ (base32
+ "00lsh2v4i8rwfyjyxx5lijd6rnk9smcfffhzg5sv94ijpcnh216m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-urwid" ,python-urwid)))
+ (home-page "https://github.com/amanusk/s-tui")
+ (synopsis "Interactive terminal stress test and monitoring tool")
+ (description
+ "The Stress Terminal UI displays graphs of the CPU frequency,
+utilization, temperature and power.")
+ (license license:gpl2+)))
+
(define-public stress
(package
(name "stress")
--
2.22.0
Ludovic Courtès wrote 6 years ago
(name . Christopher Baines)(address . mail@cbaines.net)(address . 36541@debbugs.gnu.org)
877e8niatl.fsf@gnu.org
Hello,

Christopher Baines <mail@cbaines.net> skribis:

Toggle quote (2 lines)
> * gnu/packages/admin.scm (s-tui): New variable.

LGTM! :-)

Ludo’.
Christopher Baines wrote 6 years ago
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36541-done@debbugs.gnu.org)
87o91xzie2.fsf@cbaines.net
Ludovic Courtès <ludo@gnu.org> writes:

Toggle quote (8 lines)
> Hello,
>
> Christopher Baines <mail@cbaines.net> skribis:
>
>> * gnu/packages/admin.scm (s-tui): New variable.
>
> LGTM! :-)

Great, I've pushed this as bee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23
now. Thanks for taking a look :)
-----BEGIN PGP SIGNATURE-----

iQKTBAEBCgB9FiEEPonu50WOcg2XVOCyXiijOwuE9XcFAl0qWSVfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcACgkQXiijOwuE
9XdlghAAgcnWJq1gCIl+beBjDBY//0GMOmEF9o9krTHJwvPVV+SEZoZOjxFlN4or
ZwSOzB+8wovgT/ILv+cDJRNdrIx52wYK+q95lePTEZgsHBOdgyRPYRUZNGQNhKr3
blPd3mhvleb3FFjqFlR0V2t0vvCGLh7cRGXxWSQuMLIRjGdq+eMrxHBaj47UPrUv
FDZ0i/KE6cCzXz94POW0gibFHb/k1zBxH3GtNuCLM+mA0A6kkXCcp85D3bi1OqeQ
qqVaHHKio6lg77G9Jc0iAFX7TbBSW6DVD4oUahmxt+x6OCIZTfvCvDs946QT8vlj
nR4ZcdIp9CvMwczDpxAaEctnGhscW6XxWG733lOQBjfNNCgKw/3h6qWT2rCwVD98
prhDOs/i0EKhHnQS4OkqO0v2cVQ+hD6XceBCE246JT7WW6mOIEJGwV0WopYq/lQc
eJ0q6bSZIKk0+XtWMNJ1c0bi1x1PSM8JYW0Rv75GwCgv2topsPZRhU8eJJfuDqjw
upRvN32Bh8PMej7FQon4c1wYjz0vNEL3YVgW5QdOwfisXgcKJLtOEU+iAoL9xASE
XCKziGlfhSyXEcIczoEhxSiiNN3Mb+hPwlJkrJYHGrV4hsvrNJ+wFLXNzIzseuQ1
KU3H6sQyyz1MUyx6sknBdoswPMxHc//RcMqwSd3N33f50GdAwJE=
=yplA
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36541@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36541
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help