[PATCH] gnu: Add bitcoin-abc.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • swedebugia
Owner
unassigned
Submitted by
swedebugia
Severity
normal
S
S
swedebugia wrote on 27 Jun 2019 22:11
(address . guix-patches@gnu.org)
7db680ab-ff53-9569-3835-dd28f4889b8e@riseup.net
I verified with the hash found here

I have not tested this with downloading the chain neither have I made
any transactions.

Warning: if you start it without specifying a datadir then it defaults
to ~/.bitcoin like bitcoin-core.

--
Cheers Swedebugia
From 1ce83b0ceabac0260f6a9dc43d4df1cc75236aa7 Mon Sep 17 00:00:00 2001
From: swedebugia <swedebugia@riseup.net>
Date: Thu, 27 Jun 2019 22:06:33 +0200
Subject: [PATCH] gnu: Add bitcoin-abc.

* gnu/packages/finance.scm (bitcoin-abc): New variable.
---
gnu/packages/finance.scm | 67 ++++++++++++++++++++++++++++++++++++++++
1 file changed, 67 insertions(+)

Toggle diff (77 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index cd5d3b7d9..9301b5826 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1029,3 +1029,70 @@ Its features are:
@item get account amount.
@end itemize")
(license license:agpl3+)))
+
+(define-public bitcoin-abc
+ ;; This is a fork of bitcoin-core and identical to upstream.
+ (package
+ (name "bitcoin-abc")
+ (version "0.19.8")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://download.bitcoinabc.org/" version "/linux/src/bitcoin-abc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("python" ,python) ; for the tests
+ ("util-linux" ,util-linux) ; provides the hexdump command for tests
+ ("qttools" ,qttools)))
+ (inputs
+ `(("bdb" ,bdb-5.3) ; with 6.2.23, there is an error: ambiguous overload
+ ("boost" ,boost)
+ ("libevent" ,libevent)
+ ("miniupnpc" ,miniupnpc)
+ ("openssl" ,openssl)
+ ("protobuf" ,protobuf)
+ ("qtbase" ,qtbase)))
+ (arguments
+ `(#:configure-flags
+ (list
+ ;; We use a bdb version newer than 4.8.
+ "--with-incompatible-bdb"
+ ;; Boost is not found unless specified manually.
+ (string-append "--with-boost="
+ (assoc-ref %build-inputs "boost"))
+ ;; XXX: The configure script looks up Qt paths by
+ ;; `pkg-config --variable=host_bins Qt5Core`, which fails to pick
+ ;; up executables residing in 'qttools', so we specify them here.
+ (string-append "ac_cv_path_LRELEASE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lrelease")
+ (string-append "ac_cv_path_LUPDATE="
+ (assoc-ref %build-inputs "qttools")
+ "/bin/lupdate"))
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'configure 'make-qt-deterministic
+ (lambda _
+ ;; Make Qt deterministic.
+ (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
+ #t))
+ (add-before 'check 'set-home
+ (lambda _
+ (setenv "HOME" (getenv "TMPDIR")) ; Tests write to $HOME.
+ #t)))))
+ (home-page "https://bitcoinabc.org/")
+ (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+ (description
+ "Bitcoin Cash is a digital currency that enables instant payments to anyone
+anywhere in the world. It uses peer-to-peer technology to operate without
+central authority: managing transactions and issuing money are carried out
+collectively by the network. Bitcoin ABC is the reference implementation
+of the Bitcoin Cash protocol. This package provides the Bitcoin Cash command
+line client and a client based on Qt. This is a fork of bitcoin-core.")
+ (license license:expat)))
+
--
2.19.2
L
L
Ludovic Courtès wrote on 3 Jul 2019 00:39
(name . swedebugia)(address . swedebugia@riseup.net)(address . 36406@debbugs.gnu.org)
87d0is3vu6.fsf@gnu.org
Hi swedebugia,

swedebugia <swedebugia@riseup.net> skribis:

Toggle quote (7 lines)
>>From 1ce83b0ceabac0260f6a9dc43d4df1cc75236aa7 Mon Sep 17 00:00:00 2001
> From: swedebugia <swedebugia@riseup.net>
> Date: Thu, 27 Jun 2019 22:06:33 +0200
> Subject: [PATCH] gnu: Add bitcoin-abc.
>
> * gnu/packages/finance.scm (bitcoin-abc): New variable.

[...]

Toggle quote (5 lines)
> +(define-public bitcoin-abc
> + ;; This is a fork of bitcoin-core and identical to upstream.
> + (package
> + (name "bitcoin-abc")

Since everything except ‘source’ is identical, I think we should write
it as:

(package
(inherit bitcoin-core)
…)

Toggle quote (9 lines)
> + (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
> + (description
> + "Bitcoin Cash is a digital currency that enables instant payments to anyone
> +anywhere in the world. It uses peer-to-peer technology to operate without
> +central authority: managing transactions and issuing money are carried out
> +collectively by the network. Bitcoin ABC is the reference implementation
> +of the Bitcoin Cash protocol. This package provides the Bitcoin Cash command
> +line client and a client based on Qt. This is a fork of bitcoin-core.")

Could you make the description a bit more specific to Bitcoin ABC?
Otherwise it’s hard to tell how it differs from bitcoin-core.

Thanks in advance!

Ludo’.
L
L
Ludovic Courtès wrote on 7 Jul 2019 15:18
control message for bug #36406
(address . control@debbugs.gnu.org)
87k1cuc79t.fsf@gnu.org
tags 36406 + moreinfo
quit
S
S
swedebugia wrote on 1 Aug 2019 22:43
Re: [bug#36406] [PATCHv2] gnu: Add bitcoin-abc.
(name . Ludovic Courtès)(address . ludo@gnu.org)(address . 36406@debbugs.gnu.org)
004ccd40-b7f9-1d7e-3ff3-f22a78d5d2bc@riseup.net
On 2019-07-03 00:39, Ludovic Courtès wrote:
Toggle quote (34 lines)
> Hi swedebugia,
>
> swedebugia <swedebugia@riseup.net> skribis:
>
>> >From 1ce83b0ceabac0260f6a9dc43d4df1cc75236aa7 Mon Sep 17 00:00:00 2001
>> From: swedebugia <swedebugia@riseup.net>
>> Date: Thu, 27 Jun 2019 22:06:33 +0200
>> Subject: [PATCH] gnu: Add bitcoin-abc.
>>
>> * gnu/packages/finance.scm (bitcoin-abc): New variable.
> [...]
>
>> +(define-public bitcoin-abc
>> + ;; This is a fork of bitcoin-core and identical to upstream.
>> + (package
>> + (name "bitcoin-abc")
> Since everything except ‘source’ is identical, I think we should write
> it as:
>
> (package
> (inherit bitcoin-core)
> …)
>
>> + (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
>> + (description
>> + "Bitcoin Cash is a digital currency that enables instant payments to anyone
>> +anywhere in the world. It uses peer-to-peer technology to operate without
>> +central authority: managing transactions and issuing money are carried out
>> +collectively by the network. Bitcoin ABC is the reference implementation
>> +of the Bitcoin Cash protocol. This package provides the Bitcoin Cash command
>> +line client and a client based on Qt. This is a fork of bitcoin-core.")
> Could you make the description a bit more specific to Bitcoin ABC?
> Otherwise it’s hard to tell how it differs from bitcoin-core.

Ok, updated patch attached.

--
Cheers Swedebugia
From 5ecc8f90ed89f41ca1e4e1fa5372cf6da114adaf Mon Sep 17 00:00:00 2001
From: swedebugia <swedebugia@riseup.net>
Date: Thu, 1 Aug 2019 22:31:42 +0200
Subject: [PATCH] gnu: Add bitcoin-abc.

* gnu/packages/finance.scm (bitcoin-abc): New variable.
---
gnu/packages/finance.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 9b2301360..28af2c261 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1086,3 +1086,31 @@ financial years, budget estimates, bankcard management and other
information.")
(home-page "http://grisbi.org")
(license license:gpl2+)))
+
+(define-public bitcoin-abc
+ (package
+ (inherit bitcoin-core)
+ (name "bitcoin-abc")
+ (version "0.19.8")
+ (source (origin
+ (method url-fetch)
+ (uri
+ (string-append "https://download.bitcoinabc.org/" version "/linux/src/bitcoin-abc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ (home-page "https://bitcoinabc.org/")
+ (synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
+ (description
+ "Bitcoin Cash brings sound money to the world, fulfilling the original
+promise of Bitcoin as Peer-to-Peer Electronic Cash. Merchants and users are
+empowered with low fees and reliable confirmations is a digital currency that
+enables instant payments to anyone anywhere in the world. It uses
+peer-to-peer technology to operate without central authority: managing
+transactions and issuing money are carried out collectively by the network.
+As a fork it implemented changes lowering the time between blocks and now
+offers confimations after less than 5 seconds and have significantly lower
+fees that BTC. Bitcoin ABC is the reference implementation of the Bitcoin
+Cash protocol. This package provides the Bitcoin Cash command line client and
+a client based on Qt. This is a fork of bitcoin-core.")))
--
2.19.2
L
L
Ludovic Courtès wrote on 22 Aug 2019 17:41
(name . swedebugia)(address . swedebugia@riseup.net)(address . 36406-done@debbugs.gnu.org)
87mug1p5qq.fsf@gnu.org
Hi!

swedebugia <swedebugia@riseup.net> skribis:

Toggle quote (7 lines)
> From 5ecc8f90ed89f41ca1e4e1fa5372cf6da114adaf Mon Sep 17 00:00:00 2001
> From: swedebugia <swedebugia@riseup.net>
> Date: Thu, 1 Aug 2019 22:31:42 +0200
> Subject: [PATCH] gnu: Add bitcoin-abc.
>
> * gnu/packages/finance.scm (bitcoin-abc): New variable.

I addressed two tiny issues reported by ‘guix lint’ (see below) and
applied.

Thanks!

Ludo’.
Toggle diff (27 lines)
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 1ea583abe3..377cb3a405 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1118,14 +1118,14 @@ Trezor wallet.")
(name "bitcoin-abc")
(version "0.19.8")
(source (origin
- (method url-fetch)
- (uri
- (string-append "https://download.bitcoinabc.org/" version "/linux/src/bitcoin-abc-"
- version ".tar.gz"))
- (sha256
- (base32
- "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
- (home-page "https://bitcoinabc.org/")
+ (method url-fetch)
+ (uri (string-append "https://download.bitcoinabc.org/"
+ version "/linux/src/bitcoin-abc-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0ndvkxv5m8346bdhfqzgdiz1k9wyjycj05jp7daf9pml3cw79sz5"))))
+ (home-page "https://www.bitcoinabc.org/")
(synopsis "Bitcoin ABC peer-to-peer full node for the Bitcoin Cash protocol")
(description
"Bitcoin Cash brings sound money to the world, fulfilling the original
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36406@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36406
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch