Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
* gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
---
gnu/packages/gl.scm | 9 +++++++++
1 file changed, 9 insertions(+)
Toggle diff (22 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96e7fc7165..78f7401f20 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
(("'u_format_test',") ""))
#t)))
'())
+ (add-after
+ 'unpack 'patch-meson-build
+ (lambda _
+ ;; Without this, meson fails with the following error:
+ ;; Dependency "wayland-scanner" not found, tried pkgconfig.
+ (substitute* "meson.build"
+ (("dependency\\('wayland-scanner', native: true\\)")
+ "dependency('wayland-scanner')"))
+ #t))
(add-before
'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.22.0