[PATCH] gnu: mesa: Fix detection of wayland-scanner pkg-config file.

  • Done
  • quality assurance status badge
Details
2 participants
  • Kei Kebreau
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Kei Kebreau
Severity
normal

Debbugs page

Kei Kebreau wrote 6 years ago
(address . guix-patches@gnu.org)(name . Kei Kebreau)(address . kkebreau@posteo.net)
20190626015345.19432-2-kkebreau@posteo.net
* gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
---
gnu/packages/gl.scm | 9 +++++++++
1 file changed, 9 insertions(+)

Toggle diff (22 lines)
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 96e7fc7165..78f7401f20 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
(("'u_format_test',") ""))
#t)))
'())
+ (add-after
+ 'unpack 'patch-meson-build
+ (lambda _
+ ;; Without this, meson fails with the following error:
+ ;; Dependency "wayland-scanner" not found, tried pkgconfig.
+ (substitute* "meson.build"
+ (("dependency\\('wayland-scanner', native: true\\)")
+ "dependency('wayland-scanner')"))
+ #t))
(add-before
'configure 'fix-dlopen-libnames
(lambda* (#:key inputs outputs #:allow-other-keys)
--
2.22.0
Maxim Cournoyer wrote 3 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 36387@debbugs.gnu.org)
87k0hbil8w.fsf_-_@gmail.com
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (26 lines)
> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
> ---
> gnu/packages/gl.scm | 9 +++++++++
> 1 file changed, 9 insertions(+)
>
> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
> index 96e7fc7165..78f7401f20 100644
> --- a/gnu/packages/gl.scm
> +++ b/gnu/packages/gl.scm
> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
> (("'u_format_test',") ""))
> #t)))
> '())
> + (add-after
> + 'unpack 'patch-meson-build
> + (lambda _
> + ;; Without this, meson fails with the following error:
> + ;; Dependency "wayland-scanner" not found, tried pkgconfig.
> + (substitute* "meson.build"
> + (("dependency\\('wayland-scanner', native: true\\)")
> + "dependency('wayland-scanner')"))
> + #t))
> (add-before
> 'configure 'fix-dlopen-libnames
> (lambda* (#:key inputs outputs #:allow-other-keys)

Was this fixing a build failure of mesa itself? Or does it manifest
when building other packages depending on mesa?

Given the patch is 2 years old, I'm guessing it went stale?

Thanks,

Maxim
Kei Kebreau wrote 3 years ago
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)(address . 36387@debbugs.gnu.org)
ce5de4c2-f580-02d4-2b01-c0bef310d30b@posteo.net
It did in fact go stale. I vaguely remember having some trouble building
mesa locally, but this no longer seems to be the case.

On 11/13/21 8:22 PM, Maxim Cournoyer wrote:
Toggle quote (37 lines)
> Hello,
>
> Kei Kebreau<kkebreau@posteo.net> writes:
>
>> * gnu/packages/gl.scm (mesa)[arguments]: Add "patch-meson-build" phase.
>> ---
>> gnu/packages/gl.scm | 9 +++++++++
>> 1 file changed, 9 insertions(+)
>>
>> diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
>> index 96e7fc7165..78f7401f20 100644
>> --- a/gnu/packages/gl.scm
>> +++ b/gnu/packages/gl.scm
>> @@ -337,6 +337,15 @@ also known as DXTn or DXTC) for Mesa.")
>> (("'u_format_test',") ""))
>> #t)))
>> '())
>> + (add-after
>> + 'unpack 'patch-meson-build
>> + (lambda _
>> + ;; Without this, meson fails with the following error:
>> + ;; Dependency "wayland-scanner" not found, tried pkgconfig.
>> + (substitute* "meson.build"
>> + (("dependency\\('wayland-scanner', native: true\\)")
>> + "dependency('wayland-scanner')"))
>> + #t))
>> (add-before
>> 'configure 'fix-dlopen-libnames
>> (lambda* (#:key inputs outputs #:allow-other-keys)
> Was this fixing a build failure of mesa itself? Or does it manifest
> when building other packages depending on mesa?
>
> Given the patch is 2 years old, I'm guessing it went stale?
>
> Thanks,
>
> Maxim
Maxim Cournoyer wrote 3 years ago
(name . Kei Kebreau)(address . kkebreau@posteo.net)(address . 36387-done@debbugs.gnu.org)
87ee5xwj8a.fsf@gmail.com
Hello,

Kei Kebreau <kkebreau@posteo.net> writes:

Toggle quote (3 lines)
> It did in fact go stale. I vaguely remember having some trouble
> building mesa locally, but this no longer seems to be the case.

Alright, thank you for the heads up. Closing.

Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36387@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36387
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help