[Patch] gnu: add celestia; celestia-gtk

  • Done
  • quality assurance status badge
Details
5 participants
  • Eric Bavier
  • Ludovic Courtès
  • Amar Singh
  • Sharlatan Hellseher
  • swedebugia
Owner
unassigned
Submitted by
Amar Singh
Severity
normal

Debbugs page

Amar Singh wrote 6 years ago
(address . guix-patches@gnu.org)
855zp9gxna.fsf@disroot.org
Added Celestia; space visualisation and simulator to (gnu packages
astronomy).

Tests are disabled because the project does not include any tests.
From dba590074e9a0c7cf3dc8440492190de732feaea Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Sun, 19 May 2019 12:39:48 +0530
Subject: [PATCH 1/2] gnu: Add celestia.

* gnu/packages/astronomy.scm (celestia): New variable.
---
gnu/packages/astronomy.scm | 62 ++++++++++++++++++++++++++++++++++++++
1 file changed, 62 insertions(+)

Toggle diff (91 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 9ddb9e1d52..c0ddbca033 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019 by Amar Singh<nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,11 +23,18 @@
#:use-module (guix packages)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix utils)
#:use-module (gnu packages autotools)
#:use-module (gnu packages image)
#:use-module (gnu packages compression)
#:use-module (gnu packages gettext)
+ #:use-module (gnu packages version-control)
+ #:use-module (gnu packages pkg-config)
+ #:use-module (gnu packages xiph)
+ #:use-module (gnu packages pretty-print)
+ #:use-module (gnu packages algebra)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages perl)
#:use-module (gnu packages gl)
#:use-module (gnu packages qt)
@@ -176,3 +184,57 @@ programs for the manipulation and analysis of astronomical data.")
can be used to control telescopes over a serial port for tracking celestial
objects.")
(license license:gpl2+)))
+
+(define-public celestia
+ (let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
+ (package
+ (name "celestia")
+ (version
+ (git-version "1.6.1" "815" commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url
+ "https://github.com/celestiaproject/celestia")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00xibg87l1arzifakgj7s828x9pszcgx7x7ij88a561ig49ryh78"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("perl" ,perl)
+ ("libgit2" ,libgit2)
+ ("pkg-config" ,pkg-config)
+ ("libtool" ,libtool)
+ ("gettext" ,gettext-minimal)))
+ (inputs
+ `(("glu" ,glu)
+ ("glew" ,glew)
+ ("libtheora" ,libtheora)
+ ("libjpeg" ,libjpeg)
+ ("libpng" ,libpng)
+ ;; maybe required?
+ ("mesa" ,mesa)
+ ;; optional: fmtlib, Eigen3;
+ ("fmt" ,fmt)
+ ("eigen" ,eigen)
+ ;; glut: for glut interface
+ ("freeglut" ,freeglut)))
+ (propagated-inputs
+ `(("lua" ,lua)))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GLUT=ON" "-DENABLE_QT=OFF")
+ #:tests? #f))
+ (home-page "https://celestia.space/")
+ (synopsis "Real-time 3D visualization of space")
+ (description
+ "The free space simulation that lets you explore our universe in three
+dimensions. Celestia simulates many different types of celestial objects.
+From planets and moons to star clusters and galaxies, you can visit every
+object in the expandable database and view it from any point in space and
+time. The position and movement of solar system objects is calculated
+accurately in real time at any rate desired.")
+ (license license:gpl2))))
--
2.22.0
From c8dd3c6871da910761ea8908f6bc9866c7f3c5ac Mon Sep 17 00:00:00 2001
From: Amar Singh <nly@disroot.org>
Date: Thu, 13 Jun 2019 22:53:22 +0530
Subject: [PATCH 2/2] gnu: Add celestia-gtk.

* gnu/packages/astronomy.scm (celestia-gtk): New variable.
---
gnu/packages/astronomy.scm | 17 +++++++++++++++++
1 file changed, 17 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c0ddbca033..206b9b0b5a 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -38,6 +38,8 @@
#:use-module (gnu packages perl)
#:use-module (gnu packages gl)
#:use-module (gnu packages qt)
+ #:use-module (gnu packages gtk)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages maths)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
@@ -238,3 +240,18 @@ object in the expandable database and view it from any point in space and
time. The position and movement of solar system objects is calculated
accurately in real time at any rate desired.")
(license license:gpl2))))
+
+(define-public celestia-gtk
+ (package (inherit celestia)
+ (name "celestia-gtk")
+ (version (package-version celestia))
+ (inputs
+ (append (filter (lambda (x)
+ (not (equal? (car x) "freeglut")))
+ (package-inputs celestia))
+ `(("gtk2" ,gtk+-2)
+ ("gtkglext" ,gtkglext))))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+ #:tests? #f))))
+
--
2.22.0
swedebugia wrote 6 years ago
(address . guix-patches@gnu.org)
4b03ca6e-c0e6-a9cf-e2f7-2f635f8f14d0@riseup.net
On 2019-06-13 20:15, Amar Singh wrote:
Toggle quote (6 lines)
>
> Added Celestia; space visualisation and simulator to (gnu packages
> astronomy).
>
> Tests are disabled because the project does not include any tests.

> + (license license:gpl2))))

Source code files say 2 or later. Otherwise LGTM.

I'm not going to review the celestia-gtk because of small bandwidth.

Thanks for the patch!

--
Cheers Swedebugia
Ludovic Courtès wrote 6 years ago
(name . Amar Singh)(address . nly@disroot.org)(address . 36197-done@debbugs.gnu.org)
87y31oik6m.fsf@gnu.org
Hi Amar,

Amar Singh <nly@disroot.org> skribis:

Toggle quote (7 lines)
>>From dba590074e9a0c7cf3dc8440492190de732feaea Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Sun, 19 May 2019 12:39:48 +0530
> Subject: [PATCH 1/2] gnu: Add celestia.
>
> * gnu/packages/astronomy.scm (celestia): New variable.

I fixed the license as swedebugia noted, made the minor cosmetic changes
shown below, and applied.

Toggle quote (7 lines)
>>From c8dd3c6871da910761ea8908f6bc9866c7f3c5ac Mon Sep 17 00:00:00 2001
> From: Amar Singh <nly@disroot.org>
> Date: Thu, 13 Jun 2019 22:53:22 +0530
> Subject: [PATCH 2/2] gnu: Add celestia-gtk.
>
> * gnu/packages/astronomy.scm (celestia-gtk): New variable.

Applied with the changes below.

Thank you!

Ludo’.
Toggle diff (62 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 20639bc779..59fa11bfda 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2016 John Darrington <jmd@gnu.org>
;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019 by Amar Singh<nly@disroot.org>
+;;; Copyright © 2019 by Amar Singh <nly@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -189,20 +189,16 @@ objects.")
(let ((commit "9dbdf29c4ac3d20afb2d9a80d3dff241ecf81dce"))
(package
(name "celestia")
- (version
- (git-version "1.6.1" "815" commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url
- "https://github.com/celestiaproject/celestia")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "00xibg87l1arzifakgj7s828x9pszcgx7x7ij88a561ig49ryh78"))))
+ (version (git-version "1.6.1" "815" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/celestiaproject/celestia")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00xibg87l1arzifakgj7s828x9pszcgx7x7ij88a561ig49ryh78"))))
(build-system cmake-build-system)
(native-inputs
`(("perl" ,perl)
@@ -227,14 +223,14 @@ objects.")
`(("lua" ,lua)))
(arguments
`(#:configure-flags '("-DENABLE_GLUT=ON" "-DENABLE_QT=OFF")
- #:tests? #f))
+ #:tests? #f)) ;no tests
(home-page "https://celestia.space/")
(synopsis "Real-time 3D visualization of space")
(description
- "The free space simulation that lets you explore our universe in three
+ "This simulation program lets you explore our universe in three
dimensions. Celestia simulates many different types of celestial objects.
From planets and moons to star clusters and galaxies, you can visit every
object in the expandable database and view it from any point in space and
time. The position and movement of solar system objects is calculated
accurately in real time at any rate desired.")
- (license license:gpl2))))
+ (license license:gpl2+))))
Toggle diff (40 lines)
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index df801ef444..81c7481e0b 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -42,7 +42,8 @@
#:use-module (gnu packages gnome)
#:use-module (gnu packages maths)
#:use-module (guix build-system cmake)
- #:use-module (guix build-system gnu))
+ #:use-module (guix build-system gnu)
+ #:use-module (srfi srfi-1))
(define-public cfitsio
(package
@@ -238,15 +239,13 @@ accurately in real time at any rate desired.")
(license license:gpl2+))))
(define-public celestia-gtk
- (package (inherit celestia)
- (name "celestia-gtk")
- (version (package-version celestia))
- (inputs
- (append (filter (lambda (x)
- (not (equal? (car x) "freeglut")))
- (package-inputs celestia))
- `(("gtk2" ,gtk+-2)
- ("gtkglext" ,gtkglext))))
- (arguments
- `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
- #:tests? #f))))
+ (package
+ (inherit celestia)
+ (name "celestia-gtk")
+ (inputs
+ (append (alist-delete "freeglut" (package-inputs celestia))
+ `(("gtk2" ,gtk+-2)
+ ("gtkglext" ,gtkglext))))
+ (arguments
+ `(#:configure-flags '("-DENABLE_GTK=ON" "-DENABLE_QT=OFF")
+ #:tests? #f))))
Closed
Ludovic Courtès wrote 6 years ago
control message for bug #36197
(address . control@debbugs.gnu.org)
87ef369qiq.fsf@gnu.org
reopen 36197
tags 36197 - fixed patch
quit
Ludovic Courtès wrote 6 years ago
Re: [Patch] gnu: add celestia; celestia-gtk
(name . Eric Bavier)(address . ericbavier@centurylink.net)(address . 36197@debbugs.gnu.org)
87d0iq9qhm.fsf@gnu.org
Hi Eric,

Eric Bavier <ericbavier@centurylink.net> skribis:

Toggle quote (2 lines)
> Did this patch address the concerns raised in this thread: https://lists.gnu.org/archive/html/guix-devel/2015-07/msg00030.html?

Good question, I don’t know. Could you take a look?

I picked it up because there had been no comments for some time, but I
was unaware of the issues you raise.

Thanks for the heads-up,
Ludo’.
Sharlatan Hellseher wrote 11 months ago
[Patch] gnu: add celestia; celestia-gtk
(address . 36197-done@debbugs.gnu.org)
8734s9dqrf.fsf@gmail.com
Hi!

Celestia is on the latest version and periodically checked for
updates.

Closing this issue as no more relevant.

Thanks,
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmYG2EQACgkQdtcnv/Ys
0rWvzhAAzGmw3sPeYD8Ya2iXup58DBzT3UuPsnVSQ8UxSd6TlekIcfFufSc4+tBK
4v2tak0ab6NAG8Ium2+PXOcZgr1/dM90cIFdBWrDB3I77r7cjGU6rRo70c/fhCjh
MLQ3YgXIBhYRBYM1fptEH5wRKASGf3bimy0ofA8evTpMkFzgJgv8tvBkDRNmdwoT
L4EIq2C4hCm8JkvlEhJy+5ZMsaq6dbspu5ClN0rDaQllmtGwZf7qL5taiU+dRcoi
4olhSe/k7WqCyHdvU7YTplOeuTpph5EBjFl1QKOPLu8W0JLP3FOmdgQM5yoV+UTU
XQnZZW38X7y3mHUWGREkJny/JYmlR282qAG0HA5l5PMRnKVL/TMfpxmwXY47oXvl
yV6ckUKGu3HBqJedhluRcRiPO7o+H8f2uiUhOTCWobADUS775MuOuF5RhT6nxhaP
xQD2TD9N8UeCxxB9n1euLTJFAPUoiZWFzzMB8jPti5mhJbSRMQEbonZvmxNkBPtK
yltqhKAZ3ieyDwXF+yd67UK1mAnQROBVm6phQ4IV+pEeHr8TYJKtawsQO4oOGacD
7mF7cYN2GNod8EBEOcJz7jiCShqJz0GM1oh36/m4EaDmfgpnZdQeerbczf1lz5eM
R7oy42vyVt08BkkzvTufsoO465XykZ7TEeUiI/73cU21He77pKA=
=wM0f
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36197@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36197
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help