Jeremiah wrote 6 years ago
(address . bug-guix@gnu.org)
Currently python@3.7.0 fails to build on low memory systems;
despite actually building successfully.
The diff required to disable the test is as follows:
Toggle diff (13 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 11f3aacf00..75afeba2a1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -310,6 +310,8 @@ data types.")
;; memory on some systems:
;; <https://bugs.python.org/issue34587>
"Lib/test/test_socket.py"
+ ;; Allow python to be built on lower memory systems
+ "Lib/test/test_mmap.py"
;; These tests fail on AArch64.
"Lib/ctypes/test/test_win32.py"