python@3.7.0

  • Done
  • quality assurance status badge
Details
2 participants
  • Jeremiah
  • Marius Bakke
Owner
unassigned
Submitted by
Jeremiah
Severity
normal

Debbugs page

Jeremiah wrote 6 years ago
(address . bug-guix@gnu.org)
878su7u9gi.fsf@ITSx01.pdp10.guru
Currently python@3.7.0 fails to build on low memory systems;
despite actually building successfully.

The diff required to disable the test is as follows:
Toggle diff (13 lines)
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 11f3aacf00..75afeba2a1 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -310,6 +310,8 @@ data types.")
;; memory on some systems:
;; <https://bugs.python.org/issue34587>
"Lib/test/test_socket.py"
+ ;; Allow python to be built on lower memory systems
+ "Lib/test/test_mmap.py"
;; These tests fail on AArch64.
"Lib/ctypes/test/test_win32.py"
Marius Bakke wrote 6 years ago
(address . Jeremiah@pdp10.guru)(address . 36175-done@debbugs.gnu.org)
877e9f3ogg.fsf@devup.no
Jeremiah@pdp10.guru writes:

Toggle quote (18 lines)
> Currently python@3.7.0 fails to build on low memory systems;
> despite actually building successfully.
>
> The diff required to disable the test is as follows:
> diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
> index 11f3aacf00..75afeba2a1 100644
> --- a/gnu/packages/python.scm
> +++ b/gnu/packages/python.scm
> @@ -310,6 +310,8 @@ data types.")
> ;; memory on some systems:
> ;; <https://bugs.python.org/issue34587>
> "Lib/test/test_socket.py"
> + ;; Allow python to be built on lower memory systems
> + "Lib/test/test_mmap.py"
>
> ;; These tests fail on AArch64.
> "Lib/ctypes/test/test_win32.py"

Thanks! Pushed in e7041c8ef8b9137f40e0a5377b8224314168e226.
-----BEGIN PGP SIGNATURE-----

iQEzBAEBCgAdFiEEu7At3yzq9qgNHeZDoqBt8qM6VPoFAl0MAm8ACgkQoqBt8qM6
VPrDMQgAn1KtvK37dsbHFqoAa0u6+y1ES0vBa544XSMDoBzd8UBjYcblyvwEKFW8
kOQ+5GosPIAa1BsKDgfzWqEhVi+WRCE82+Dg5LnGB/qvJymkhlii9vYghscIBbrX
3Qyd/JTZ42CneLz+duOdUS9XJ71sCVCd0cWVCAaTh1vHsi0VaVxP8aW1S06OSFC0
4xyHYmru15WWGV7SlLrjNnLKpDkK5Nsk3Kw2tFNjz/IHCaKN4Up6IFKJiVCrepJc
wS60vcueqLQo3kfFUDjQc6QBlXgNyLKoDzYvUQfCARUZdjX+stkrC3/bDSyLoGGQ
jq6nK5WTbWaEDzTQovJJI6b98bSPmA==
=4+Os
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 36175@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 36175
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help